aboutsummaryrefslogtreecommitdiff
path: root/lang/p5-JavaScript/Makefile
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2006-06-02 13:24:55 +0000
committerAnton Berezin <tobez@FreeBSD.org>2006-06-02 13:24:55 +0000
commitce763c0d5a89f427b3d28f93c3ff4cd279273597 (patch)
treedca36e141879d3883aa2dc76f5b0ec824dbbdb8a /lang/p5-JavaScript/Makefile
parent3f7d395834f0ca5c4b5f806ee6c748998da1847c (diff)
Notes
Diffstat (limited to 'lang/p5-JavaScript/Makefile')
-rw-r--r--lang/p5-JavaScript/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/lang/p5-JavaScript/Makefile b/lang/p5-JavaScript/Makefile
new file mode 100644
index 000000000000..a833a559217c
--- /dev/null
+++ b/lang/p5-JavaScript/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: p5-JavaScript
+# Date created: 02 June 2006
+# Whom: dom@happygiraffe.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= JavaScript
+PORTVERSION= 0.55
+CATEGORIES= lang perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= JavaScript
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= dom@happygiraffe.net
+COMMENT= Perl extension for executing embedded JavaScript
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libjs.so:${PORTSDIR}/lang/spidermonkey
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= JavaScript.3
+
+PERL_CONFIGURE= yes
+CONFIGURE_ARGS= INC=-I${LOCALBASE}/include
+
+post-patch:
+ ${REINPLACE_CMD} -e 's/<malloc.h>/<stdlib.h>/' ${WRKSRC}/JavaScript.xs
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= a dependency does not compile on FreeBSD 4.x
+.endif
+
+.include <bsd.port.post.mk>