aboutsummaryrefslogtreecommitdiff
path: root/lang/p5-JavaScript
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2006-06-02 13:24:55 +0000
committerAnton Berezin <tobez@FreeBSD.org>2006-06-02 13:24:55 +0000
commitce763c0d5a89f427b3d28f93c3ff4cd279273597 (patch)
treedca36e141879d3883aa2dc76f5b0ec824dbbdb8a /lang/p5-JavaScript
parent3f7d395834f0ca5c4b5f806ee6c748998da1847c (diff)
downloadports-ce763c0d5a89f427b3d28f93c3ff4cd279273597.tar.gz
ports-ce763c0d5a89f427b3d28f93c3ff4cd279273597.zip
Notes
Diffstat (limited to 'lang/p5-JavaScript')
-rw-r--r--lang/p5-JavaScript/Makefile35
-rw-r--r--lang/p5-JavaScript/distinfo3
-rw-r--r--lang/p5-JavaScript/pkg-descr8
-rw-r--r--lang/p5-JavaScript/pkg-plist7
4 files changed, 53 insertions, 0 deletions
diff --git a/lang/p5-JavaScript/Makefile b/lang/p5-JavaScript/Makefile
new file mode 100644
index 000000000000..a833a559217c
--- /dev/null
+++ b/lang/p5-JavaScript/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: p5-JavaScript
+# Date created: 02 June 2006
+# Whom: dom@happygiraffe.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= JavaScript
+PORTVERSION= 0.55
+CATEGORIES= lang perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= JavaScript
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= dom@happygiraffe.net
+COMMENT= Perl extension for executing embedded JavaScript
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libjs.so:${PORTSDIR}/lang/spidermonkey
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= JavaScript.3
+
+PERL_CONFIGURE= yes
+CONFIGURE_ARGS= INC=-I${LOCALBASE}/include
+
+post-patch:
+ ${REINPLACE_CMD} -e 's/<malloc.h>/<stdlib.h>/' ${WRKSRC}/JavaScript.xs
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= a dependency does not compile on FreeBSD 4.x
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/lang/p5-JavaScript/distinfo b/lang/p5-JavaScript/distinfo
new file mode 100644
index 000000000000..20441d14e557
--- /dev/null
+++ b/lang/p5-JavaScript/distinfo
@@ -0,0 +1,3 @@
+MD5 (JavaScript-0.55.tar.gz) = 40984476f20c7bc68a685759ec38fd64
+SHA256 (JavaScript-0.55.tar.gz) = f209663e92370d702b79ab9b2490ef299eeeadaff737282d64e085276ec91ba8
+SIZE (JavaScript-0.55.tar.gz) = 18169
diff --git a/lang/p5-JavaScript/pkg-descr b/lang/p5-JavaScript/pkg-descr
new file mode 100644
index 000000000000..19cae987f444
--- /dev/null
+++ b/lang/p5-JavaScript/pkg-descr
@@ -0,0 +1,8 @@
+Always thought JavaScript was for web only? well, think again...
+
+JavaScript.pm gives you the power of embedded JavaScript in your
+applications. You can write your subs, classes etc in perl and bind them
+to the JavaScript engine. Variables are converted between the language
+automaticlly and you don't have to worry about that.
+
+WWW: http://search.cpan.org/dist/JavaScript/
diff --git a/lang/p5-JavaScript/pkg-plist b/lang/p5-JavaScript/pkg-plist
new file mode 100644
index 000000000000..37612c5fe7d6
--- /dev/null
+++ b/lang/p5-JavaScript/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/JavaScript.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/JavaScript.pod
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/JavaScript/JavaScript.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/JavaScript/JavaScript.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/JavaScript/autosplit.ix
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/JavaScript/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/JavaScript