aboutsummaryrefslogtreecommitdiff
path: root/lang/p5-Perl6-Subs
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2006-01-07 23:57:34 +0000
committerAnton Berezin <tobez@FreeBSD.org>2006-01-07 23:57:34 +0000
commit8d585117a82353af5381b73609166129c66be88f (patch)
treeb4dfa1365604ddcfbdb4faf0b3de8a367f289614 /lang/p5-Perl6-Subs
parent6ae67d95b2b1d7687abfdab65fbf25f621f7fda2 (diff)
downloadports-8d585117a82353af5381b73609166129c66be88f.tar.gz
ports-8d585117a82353af5381b73609166129c66be88f.zip
Notes
Diffstat (limited to 'lang/p5-Perl6-Subs')
-rw-r--r--lang/p5-Perl6-Subs/Makefile33
-rw-r--r--lang/p5-Perl6-Subs/distinfo3
-rw-r--r--lang/p5-Perl6-Subs/pkg-descr7
-rw-r--r--lang/p5-Perl6-Subs/pkg-plist5
4 files changed, 48 insertions, 0 deletions
diff --git a/lang/p5-Perl6-Subs/Makefile b/lang/p5-Perl6-Subs/Makefile
new file mode 100644
index 000000000000..6eefd15ff1ec
--- /dev/null
+++ b/lang/p5-Perl6-Subs/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: lang/p5-Perl6-Subs
+# Date created: 07 January 2006
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Perl6-Subs
+PORTVERSION= 0.05
+CATEGORIES= lang perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Perl6
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Perl6::Subs - Define your subroutines in the Perl 6 style
+
+BUILD_DEPENDS= ${SITE_PERL}/Filter/Simple.pm:${PORTSDIR}/textproc/p5-Filter-Simple \
+ ${SITE_PERL}/Text/Balanced.pm:${PORTSDIR}/textproc/p5-Text-Balanced \
+ ${SITE_PERL}/Parse/RecDescent.pm:${PORTSDIR}/devel/p5-Parse-RecDescent
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Perl6::Subs.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500804
+IGNORE= requires perl 5.8.4 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/lang/p5-Perl6-Subs/distinfo b/lang/p5-Perl6-Subs/distinfo
new file mode 100644
index 000000000000..565e4e58332d
--- /dev/null
+++ b/lang/p5-Perl6-Subs/distinfo
@@ -0,0 +1,3 @@
+MD5 (Perl6-Subs-0.05.tar.gz) = dea930e4ac17a84475a24f483e176e0b
+SHA256 (Perl6-Subs-0.05.tar.gz) = 9079ddd49327ea08cd44a11e021f5e35f07debb4c3128c905620563cd6c04604
+SIZE (Perl6-Subs-0.05.tar.gz) = 23294
diff --git a/lang/p5-Perl6-Subs/pkg-descr b/lang/p5-Perl6-Subs/pkg-descr
new file mode 100644
index 000000000000..f7be0849eb10
--- /dev/null
+++ b/lang/p5-Perl6-Subs/pkg-descr
@@ -0,0 +1,7 @@
+Perl6::Subs is a source filter that adds a very useful subset of Perl
+6 subroutine syntax to Perl 5. Given a subroutine defined with a Perl
+6 prototype, the code generated by Perl6::Subs will, at runtime,
+declare the formal parameters, assign them their values, and validate
+their contents according to both built-in and user-given rules.
+
+WWW: http://search.cpan.org/dist/Perl6-Subs/
diff --git a/lang/p5-Perl6-Subs/pkg-plist b/lang/p5-Perl6-Subs/pkg-plist
new file mode 100644
index 000000000000..13e9e65b7b5d
--- /dev/null
+++ b/lang/p5-Perl6-Subs/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Perl6/Subs.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Perl6/Subs/.packlist
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Perl6/Subs 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Perl6 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Perl6 2>/dev/null || true