aboutsummaryrefslogtreecommitdiff
path: root/lang/p5-Try-Tiny
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2009-09-01 18:07:07 +0000
committerAnton Berezin <tobez@FreeBSD.org>2009-09-01 18:07:07 +0000
commit647fcce0ef90da46c02c0913011331d778d0ee37 (patch)
treed1e3596892d0c95c579ba11ce670eb6a252b4f89 /lang/p5-Try-Tiny
parent9d2ba9406230d6cd3349057865c34091291b5775 (diff)
downloadports-647fcce0ef90da46c02c0913011331d778d0ee37.tar.gz
ports-647fcce0ef90da46c02c0913011331d778d0ee37.zip
Notes
Diffstat (limited to 'lang/p5-Try-Tiny')
-rw-r--r--lang/p5-Try-Tiny/Makefile22
-rw-r--r--lang/p5-Try-Tiny/distinfo3
-rw-r--r--lang/p5-Try-Tiny/pkg-descr6
-rw-r--r--lang/p5-Try-Tiny/pkg-plist5
4 files changed, 36 insertions, 0 deletions
diff --git a/lang/p5-Try-Tiny/Makefile b/lang/p5-Try-Tiny/Makefile
new file mode 100644
index 000000000000..7aedb63bcff3
--- /dev/null
+++ b/lang/p5-Try-Tiny/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: lang/p5-Try-Tiny
+# Date created: 01 September 2009
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Try-Tiny
+PORTVERSION= 0.01
+CATEGORIES= lang perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/N/NU/NUFFIN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Minimal try/catch with proper localization of $$@
+
+PERL_CONFIGURE= yes
+
+MAN3= Try::Tiny.3
+
+.include <bsd.port.mk>
diff --git a/lang/p5-Try-Tiny/distinfo b/lang/p5-Try-Tiny/distinfo
new file mode 100644
index 000000000000..759fa0b361b9
--- /dev/null
+++ b/lang/p5-Try-Tiny/distinfo
@@ -0,0 +1,3 @@
+MD5 (Try-Tiny-0.01.tar.gz) = 2b1bed5fd3e9157ad11d16f29ac1a957
+SHA256 (Try-Tiny-0.01.tar.gz) = ed016444c57734d4752af6a1c1d46e31a9b862c31c5f02d57a426454b9f7f8c3
+SIZE (Try-Tiny-0.01.tar.gz) = 6092
diff --git a/lang/p5-Try-Tiny/pkg-descr b/lang/p5-Try-Tiny/pkg-descr
new file mode 100644
index 000000000000..d7894b49cc43
--- /dev/null
+++ b/lang/p5-Try-Tiny/pkg-descr
@@ -0,0 +1,6 @@
+This module provides bare bones try/catch statements that are designed
+to minimize common mistakes done with eval blocks (for instance assuming
+that $@ is set to a true value on error, or clobbering previous values
+of $@, and NOTHING else.
+
+WWW: http://search.cpan.org/dist/Try-Tiny/
diff --git a/lang/p5-Try-Tiny/pkg-plist b/lang/p5-Try-Tiny/pkg-plist
new file mode 100644
index 000000000000..85e031a04e45
--- /dev/null
+++ b/lang/p5-Try-Tiny/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Try/Tiny.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Try/Tiny/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Try/Tiny
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Try
+@dirrmtry %%SITE_PERL%%/Try