aboutsummaryrefslogtreecommitdiff
path: root/lang/p5-signatures/Makefile
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2009-08-04 11:36:50 +0000
committerAnton Berezin <tobez@FreeBSD.org>2009-08-04 11:36:50 +0000
commit6ee43f9478ff133db6d36342e8e50d1c2d9dbb54 (patch)
treecc3205f35ee39da1fd03a2090424836f1ab8cf34 /lang/p5-signatures/Makefile
parentb6fa22b64f3f44c4af36c7b295ff1bcd83d61316 (diff)
Notes
Diffstat (limited to 'lang/p5-signatures/Makefile')
-rw-r--r--lang/p5-signatures/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/lang/p5-signatures/Makefile b/lang/p5-signatures/Makefile
new file mode 100644
index 000000000000..e92772b9af5a
--- /dev/null
+++ b/lang/p5-signatures/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: lang/p5-signatures
+# Date created: 04 August 2009
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= signatures
+PORTVERSION= 0.06
+CATEGORIES= lang perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/F/FL/FLORA
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Subroutine signatures for Perl with no source filter
+
+BUILD_DEPENDS= p5-B-Hooks-OP-Check>=0.18:${PORTSDIR}/devel/p5-B-Hooks-OP-Check \
+ p5-B-Hooks-Parser>=0.07:${PORTSDIR}/devel/p5-B-Hooks-Parser \
+ p5-B-Hooks-OP-PPAddr>0:${PORTSDIR}/devel/p5-B-Hooks-OP-PPAddr \
+ p5-ExtUtils-Depends>=0.302:${PORTSDIR}/devel/p5-ExtUtils-Depends \
+ p5-B-Hooks-EndOfScope>=0.08:${PORTSDIR}/devel/p5-B-Hooks-EndOfScope
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= signatures.3
+
+.include <bsd.port.mk>