aboutsummaryrefslogtreecommitdiff
path: root/lang/parrot/Makefile
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2008-06-24 12:13:38 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2008-06-24 12:13:38 +0000
commit7422036064e13b1818ab15a4d9ab5f57537841ed (patch)
tree8affc70804c599f60de55f4d72560da7fafcbd1d /lang/parrot/Makefile
parent01a9ddb50e3dfe7cac89ea3fd9172aeedf41de37 (diff)
downloadports-7422036064e13b1818ab15a4d9ab5f57537841ed.tar.gz
ports-7422036064e13b1818ab15a4d9ab5f57537841ed.zip
Notes
Diffstat (limited to 'lang/parrot/Makefile')
-rw-r--r--lang/parrot/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/lang/parrot/Makefile b/lang/parrot/Makefile
index f9e732c84f67..50ec2d959329 100644
--- a/lang/parrot/Makefile
+++ b/lang/parrot/Makefile
@@ -6,9 +6,10 @@
#
PORTNAME= parrot
-PORTVERSION= 0.6.0
-CATEGORIES= lang perl5
+PORTVERSION= 0.6.3
+CATEGORIES= lang
MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/S/SM/SMASH
MAINTAINER= skv@FreeBSD.org
COMMENT= Parrot - virtual machine for dynamic languages
@@ -19,8 +20,6 @@ BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4 \
icudata:${PORTSDIR}/devel/icu
-BROKEN= incorrect plist
-
USE_BISON= build
USE_GCC= 3.4+
USE_PERL5= 5.8.0+
@@ -80,4 +79,8 @@ PLIST_SUB+= JIT="@comment "
BROKEN= Does not compile on ia64
.endif
+pre-configure:
+ @if [ `${ID} -u` -eq 0 ]; then \
+ ${ECHO_MSG} "==> Please do not build ${PORTNAME} as 'root' (because of 'perldoc' issue)."; exit 1; fi
+
.include <bsd.port.post.mk>