aboutsummaryrefslogtreecommitdiff
path: root/lang/parrot
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-01-13 15:34:22 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-01-13 15:34:22 +0000
commit1d7ded6fe9f44714761e75d79e400d71da8c56e8 (patch)
tree3408ccbb0ebb00a77d0e86e50e80c478e7023e02 /lang/parrot
parentef1380dc192d31b522c38c2937d6b87ba740a278 (diff)
downloadports-1d7ded6fe9f44714761e75d79e400d71da8c56e8.tar.gz
ports-1d7ded6fe9f44714761e75d79e400d71da8c56e8.zip
Notes
Diffstat (limited to 'lang/parrot')
-rw-r--r--lang/parrot/Makefile23
-rw-r--r--lang/parrot/Makefile.common3
-rw-r--r--lang/parrot/distinfo4
-rw-r--r--lang/parrot/files/patch-compilers_imcc_imcc.y11
-rw-r--r--lang/parrot/pkg-plist10
5 files changed, 19 insertions, 32 deletions
diff --git a/lang/parrot/Makefile b/lang/parrot/Makefile
index 99a5ab80614a..ee5e80c1c87a 100644
--- a/lang/parrot/Makefile
+++ b/lang/parrot/Makefile
@@ -2,10 +2,11 @@
# $FreeBSD$
PORTNAME= parrot
-PORTVERSION= ${PARROT_VERSION}
-PORTREVISION= 1
+PORTVERSION= 6.9.0
CATEGORIES= lang
-MASTER_SITES= ftp://ftp.parrot.org/pub/parrot/releases/stable/${PORTVERSION}/
+MASTER_SITES= ftp://ftp.parrot.org/pub/parrot/releases/stable/${PORTVERSION}/ \
+ ftp://ftp.parrot.org/pub/parrot/releases/supported/${PORTVERSION}/ \
+ LOCAL/sunpoet
MAINTAINER= perl@FreeBSD.org
COMMENT= Parrot - virtual machine for dynamic languages
@@ -18,8 +19,6 @@ BUILD_DEPENDS= ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex \
LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp \
libicudata.so:${PORTSDIR}/devel/icu
-CONFLICTS= rakudo-[0-9]*
-
OPTIONS_DEFINE= DOCS
ALL_TARGET= installable
@@ -38,15 +37,12 @@ USES= bison gmake perl5 tar:bzip2
PARROT_SHARE_DIR= share/doc/${PORTNAME}/${PORTVERSION}
PARROT_DOCS= ${PARROT_SHARE_DIR}
-PLIST_SUB+= PARROT_VER="${PORTVERSION}" \
+PLIST_SUB= PARROT_VER="${PORTVERSION}" \
PARROT_DOCS="${PARROT_DOCS}"
-.include "${.CURDIR}/Makefile.common"
-.include <bsd.port.pre.mk>
+BROKEN_ia64= Does not compile on ia64
-.if ${ARCH} == ia64
-BROKEN= Does not compile on ia64
-.endif
+.include <bsd.port.options.mk>
post-patch:
.if ${PORT_OPTIONS:MDOCS}
@@ -56,7 +52,10 @@ post-patch:
do-configure:
cd ${WRKSRC} && ${PERL} ${CONFIGURE_SCRIPT} ${CONFIGURE_ARGS}
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/* ${STAGEDIR}${PREFIX}/lib/libparrot.so.${PORTVERSION} ${STAGEDIR}${PREFIX}/lib/parrot/${PORTVERSION}/dynext/*.so
+
regression-test test: build
cd ${WRKSRC} && ${MAKE} test
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/lang/parrot/Makefile.common b/lang/parrot/Makefile.common
deleted file mode 100644
index 510a739c7699..000000000000
--- a/lang/parrot/Makefile.common
+++ /dev/null
@@ -1,3 +0,0 @@
-# $FreeBSD$
-
-PARROT_VERSION= 5.9.0
diff --git a/lang/parrot/distinfo b/lang/parrot/distinfo
index f76f5cd89224..5d417008307e 100644
--- a/lang/parrot/distinfo
+++ b/lang/parrot/distinfo
@@ -1,2 +1,2 @@
-SHA256 (parrot-5.9.0.tar.bz2) = b4704231d90ddec827f45f945b9ad13dd4f9dc7cc9bc0cfc97ab6e30ec1c38ca
-SIZE (parrot-5.9.0.tar.bz2) = 4398795
+SHA256 (parrot-6.9.0.tar.bz2) = ad5f3723c216675b9ebc2e3d3807d24fd13aa55e1eb3e7ffcad4062e0026f482
+SIZE (parrot-6.9.0.tar.bz2) = 4428559
diff --git a/lang/parrot/files/patch-compilers_imcc_imcc.y b/lang/parrot/files/patch-compilers_imcc_imcc.y
deleted file mode 100644
index 3245e8f2e85b..000000000000
--- a/lang/parrot/files/patch-compilers_imcc_imcc.y
+++ /dev/null
@@ -1,11 +0,0 @@
---- compilers/imcc/imcc.y.orig 2013-01-28 19:57:42 UTC
-+++ compilers/imcc/imcc.y
-@@ -45,7 +45,7 @@ This file contains the grammar of the PI
-
- /* prevent declarations of malloc() and free() in the generated parser. */
- #define YYMALLOC
--#define YYFREE(Ptr) do { /* empty */; } while (YYID (0))
-+#define YYFREE(Ptr) do { /* empty */; } while (0)
-
- #ifndef YYENABLE_NLS
- # define YYENABLE_NLS 0
diff --git a/lang/parrot/pkg-plist b/lang/parrot/pkg-plist
index 5d3b00a82d35..0ef0170cf8b7 100644
--- a/lang/parrot/pkg-plist
+++ b/lang/parrot/pkg-plist
@@ -1,6 +1,6 @@
-bin/ops2c
bin/parrot
bin/parrot-nqp
+bin/parrot-ops2c
bin/parrot-prove
bin/parrot_config
bin/parrot_nci_thunk_gen
@@ -60,6 +60,7 @@ include/parrot/%%PARROT_VER%%/parrot/longopt.h
include/parrot/%%PARROT_VER%%/parrot/memory.h
include/parrot/%%PARROT_VER%%/parrot/misc.h
include/parrot/%%PARROT_VER%%/parrot/multidispatch.h
+include/parrot/%%PARROT_VER%%/parrot/namealias.h
include/parrot/%%PARROT_VER%%/parrot/namespace.h
include/parrot/%%PARROT_VER%%/parrot/nci.h
include/parrot/%%PARROT_VER%%/parrot/oo.h
@@ -111,7 +112,6 @@ include/parrot/%%PARROT_VER%%/pmc/pmc_continuation.h
include/parrot/%%PARROT_VER%%/pmc/pmc_coroutine.h
include/parrot/%%PARROT_VER%%/pmc/pmc_default.h
include/parrot/%%PARROT_VER%%/pmc/pmc_env.h
-include/parrot/%%PARROT_VER%%/pmc/pmc_eval.h
include/parrot/%%PARROT_VER%%/pmc/pmc_eventhandler.h
include/parrot/%%PARROT_VER%%/pmc/pmc_exception.h
include/parrot/%%PARROT_VER%%/pmc/pmc_exceptionhandler.h
@@ -577,13 +577,16 @@ lib/parrot/%%PARROT_VER%%/tools/lib/Parrot/Test/Util.pm
lib/parrot/%%PARROT_VER%%/tools/lib/Parrot/Test/Util/Runloop.pm
lib/parrot/%%PARROT_VER%%/tools/lib/Parrot/Vtable.pm
lib/parrot/%%PARROT_VER%%/tools/myconfig
-man/man1/ops2c.1.gz
man/man1/parrot-nqp.1.gz
+man/man1/parrot-ops2c.1.gz
man/man1/parrot-prove.1.gz
man/man1/parrot.1.gz
man/man1/parrot_config.1.gz
man/man1/parrot_nci_thunk_gen.1.gz
man/man1/parrotbug.1.gz
+man/man1/pbc_disassemble.1.gz
+man/man1/pbc_dump.1.gz
+man/man1/pbc_merge.1.gz
man/man1/pbc_to_exe.1.gz
man/man1/plumage.1.gz
man/man1/winxed.1.gz
@@ -616,7 +619,6 @@ src/parrot/%%PARROT_VER%%/pmc/continuation.dump
src/parrot/%%PARROT_VER%%/pmc/coroutine.dump
src/parrot/%%PARROT_VER%%/pmc/default.dump
src/parrot/%%PARROT_VER%%/pmc/env.dump
-src/parrot/%%PARROT_VER%%/pmc/eval.dump
src/parrot/%%PARROT_VER%%/pmc/eventhandler.dump
src/parrot/%%PARROT_VER%%/pmc/exception.dump
src/parrot/%%PARROT_VER%%/pmc/exceptionhandler.dump