aboutsummaryrefslogtreecommitdiff
path: root/lang/parrot
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2011-12-19 18:22:59 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2011-12-19 18:22:59 +0000
commit77ec2d52e13ff77b7bc24e4a71ee2dcbd0a5f0d0 (patch)
treeffe210347b1e875b672d7bdf229445ef54697aff /lang/parrot
parentfa94729ea277ca0f140cf61e6551f757b3275a8a (diff)
downloadports-77ec2d52e13ff77b7bc24e4a71ee2dcbd0a5f0d0.tar.gz
ports-77ec2d52e13ff77b7bc24e4a71ee2dcbd0a5f0d0.zip
Notes
Diffstat (limited to 'lang/parrot')
-rw-r--r--lang/parrot/Makefile2
-rw-r--r--lang/parrot/Makefile.common2
-rw-r--r--lang/parrot/distinfo4
-rw-r--r--lang/parrot/pkg-plist12
4 files changed, 15 insertions, 5 deletions
diff --git a/lang/parrot/Makefile b/lang/parrot/Makefile
index 4862a91c2130..4166d62d86e8 100644
--- a/lang/parrot/Makefile
+++ b/lang/parrot/Makefile
@@ -8,7 +8,7 @@
PORTNAME= parrot
PORTVERSION= ${PARROT_VERSION}
CATEGORIES= lang
-MASTER_SITES= ftp://ftp.parrot.org/pub/parrot/releases/supported/${PORTVERSION}/
+MASTER_SITES= ftp://ftp.parrot.org/pub/parrot/releases/devel/${PORTVERSION}/
MAINTAINER= perl@FreeBSD.org
COMMENT= Parrot - virtual machine for dynamic languages
diff --git a/lang/parrot/Makefile.common b/lang/parrot/Makefile.common
index d667f21ad865..3c10e0cf9ef1 100644
--- a/lang/parrot/Makefile.common
+++ b/lang/parrot/Makefile.common
@@ -1,4 +1,4 @@
# $FreeBSD$
-PARROT_VERSION= 3.9.0
+PARROT_VERSION= 3.10.0
diff --git a/lang/parrot/distinfo b/lang/parrot/distinfo
index 286c46c0aa49..cea09336758a 100644
--- a/lang/parrot/distinfo
+++ b/lang/parrot/distinfo
@@ -1,2 +1,2 @@
-SHA256 (parrot-3.9.0.tar.bz2) = 923b5ef403c26dd94c04127940659aea94516f79243a80de65fbababff44bfad
-SIZE (parrot-3.9.0.tar.bz2) = 4305319
+SHA256 (parrot-3.10.0.tar.bz2) = 9d646579d64b070d1db9c23981d2b4401c75cc036cfaf479266e066f52859e7b
+SIZE (parrot-3.10.0.tar.bz2) = 4305583
diff --git a/lang/parrot/pkg-plist b/lang/parrot/pkg-plist
index fc2761069bd9..4a93bf5c7368 100644
--- a/lang/parrot/pkg-plist
+++ b/lang/parrot/pkg-plist
@@ -12,6 +12,7 @@ bin/winxed
include/parrot/%%PARROT_VER%%/imcc/api.h
include/parrot/%%PARROT_VER%%/imcc/embed.h
include/parrot/%%PARROT_VER%%/imcc/yyscanner.h
+include/parrot/%%PARROT_VER%%/parrot/alarm.h
include/parrot/%%PARROT_VER%%/parrot/api.h
include/parrot/%%PARROT_VER%%/parrot/caches.h
include/parrot/%%PARROT_VER%%/parrot/call.h
@@ -23,10 +24,11 @@ include/parrot/%%PARROT_VER%%/parrot/core_pmcs.h
include/parrot/%%PARROT_VER%%/parrot/core_types.h
include/parrot/%%PARROT_VER%%/parrot/datatypes.h
include/parrot/%%PARROT_VER%%/parrot/debugger.h
+include/parrot/%%PARROT_VER%%/parrot/disassemble.h
include/parrot/%%PARROT_VER%%/parrot/dynext.h
-include/parrot/%%PARROT_VER%%/parrot/embed.h
include/parrot/%%PARROT_VER%%/parrot/encoding.h
include/parrot/%%PARROT_VER%%/parrot/enums.h
+include/parrot/%%PARROT_VER%%/parrot/events.h
include/parrot/%%PARROT_VER%%/parrot/exceptions.h
include/parrot/%%PARROT_VER%%/parrot/exit.h
include/parrot/%%PARROT_VER%%/parrot/extend.h
@@ -79,11 +81,13 @@ include/parrot/%%PARROT_VER%%/parrot/vtables.h
include/parrot/%%PARROT_VER%%/parrot/warnings.h
include/parrot/%%PARROT_VER%%/pmc/dummy
include/parrot/%%PARROT_VER%%/pmc/pmc_addrregistry.h
+include/parrot/%%PARROT_VER%%/pmc/pmc_alarm.h
include/parrot/%%PARROT_VER%%/pmc/pmc_arrayiterator.h
include/parrot/%%PARROT_VER%%/pmc/pmc_bigint.h
include/parrot/%%PARROT_VER%%/pmc/pmc_bignum.h
include/parrot/%%PARROT_VER%%/pmc/pmc_boolean.h
include/parrot/%%PARROT_VER%%/pmc/pmc_bytebuffer.h
+include/parrot/%%PARROT_VER%%/pmc/pmc_callback.h
include/parrot/%%PARROT_VER%%/pmc/pmc_callcontext.h
include/parrot/%%PARROT_VER%%/pmc/pmc_capture.h
include/parrot/%%PARROT_VER%%/pmc/pmc_class.h
@@ -143,6 +147,7 @@ include/parrot/%%PARROT_VER%%/pmc/pmc_packfilesegment.h
include/parrot/%%PARROT_VER%%/pmc/pmc_packfileview.h
include/parrot/%%PARROT_VER%%/pmc/pmc_parrotinterpreter.h
include/parrot/%%PARROT_VER%%/pmc/pmc_parrotlibrary.h
+include/parrot/%%PARROT_VER%%/pmc/pmc_pmclist.h
include/parrot/%%PARROT_VER%%/pmc/pmc_pmcproxy.h
include/parrot/%%PARROT_VER%%/pmc/pmc_pointer.h
include/parrot/%%PARROT_VER%%/pmc/pmc_ptr.h
@@ -196,6 +201,7 @@ lib/parrot/%%PARROT_VER%%/include/errors.pasm
lib/parrot/%%PARROT_VER%%/include/except_severity.pasm
lib/parrot/%%PARROT_VER%%/include/except_types.pasm
lib/parrot/%%PARROT_VER%%/include/fp_equality.pasm
+lib/parrot/%%PARROT_VER%%/include/green_threads.pir
lib/parrot/%%PARROT_VER%%/include/hash_key_type.pasm
lib/parrot/%%PARROT_VER%%/include/hllmacros.pir
lib/parrot/%%PARROT_VER%%/include/iglobals.pasm
@@ -499,6 +505,7 @@ lib/parrot/%%PARROT_VER%%/tools/lib/Parrot/H2inc.pm
lib/parrot/%%PARROT_VER%%/tools/lib/Parrot/Harness/DefaultTests.pm
lib/parrot/%%PARROT_VER%%/tools/lib/Parrot/Harness/Options.pm
lib/parrot/%%PARROT_VER%%/tools/lib/Parrot/Harness/Smoke.pm
+lib/parrot/%%PARROT_VER%%/tools/lib/Parrot/Harness/TestSets.pm
lib/parrot/%%PARROT_VER%%/tools/lib/Parrot/Headerizer.pm
lib/parrot/%%PARROT_VER%%/tools/lib/Parrot/Headerizer/Functions.pm
lib/parrot/%%PARROT_VER%%/tools/lib/Parrot/IO/Directory.pm
@@ -548,11 +555,13 @@ lib/parrot/%%PARROT_VER%%/tools/lib/Parrot/Vtable.pm
%%PARROT_DOCS%%/RESPONSIBLE_PARTIES
%%PARROT_DOCS%%/TODO
src/parrot/%%PARROT_VER%%/pmc/addrregistry.dump
+src/parrot/%%PARROT_VER%%/pmc/alarm.dump
src/parrot/%%PARROT_VER%%/pmc/arrayiterator.dump
src/parrot/%%PARROT_VER%%/pmc/bigint.dump
src/parrot/%%PARROT_VER%%/pmc/bignum.dump
src/parrot/%%PARROT_VER%%/pmc/boolean.dump
src/parrot/%%PARROT_VER%%/pmc/bytebuffer.dump
+src/parrot/%%PARROT_VER%%/pmc/callback.dump
src/parrot/%%PARROT_VER%%/pmc/callcontext.dump
src/parrot/%%PARROT_VER%%/pmc/capture.dump
src/parrot/%%PARROT_VER%%/pmc/class.dump
@@ -612,6 +621,7 @@ src/parrot/%%PARROT_VER%%/pmc/packfilesegment.dump
src/parrot/%%PARROT_VER%%/pmc/packfileview.dump
src/parrot/%%PARROT_VER%%/pmc/parrotinterpreter.dump
src/parrot/%%PARROT_VER%%/pmc/parrotlibrary.dump
+src/parrot/%%PARROT_VER%%/pmc/pmclist.dump
src/parrot/%%PARROT_VER%%/pmc/pmcproxy.dump
src/parrot/%%PARROT_VER%%/pmc/pointer.dump
src/parrot/%%PARROT_VER%%/pmc/ptr.dump