aboutsummaryrefslogtreecommitdiff
path: root/lang/pbasic/Makefile
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1995-08-24 01:43:47 +0000
committerSatoshi Asami <asami@FreeBSD.org>1995-08-24 01:43:47 +0000
commitacd1bd01055598144b8bc14750f0f6082b65b9b6 (patch)
treeac6c79a04d7558ab1f90788ccccf4a1f43b4229d /lang/pbasic/Makefile
parentcfc59907359f040294d24b625b1f1b4a90729d09 (diff)
Notes
Diffstat (limited to 'lang/pbasic/Makefile')
-rw-r--r--lang/pbasic/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/lang/pbasic/Makefile b/lang/pbasic/Makefile
new file mode 100644
index 000000000000..3fbd725f62b0
--- /dev/null
+++ b/lang/pbasic/Makefile
@@ -0,0 +1,33 @@
+# ports collection makefile for: pbasic
+# Version required: 2.0-950813
+# Date created: 13th August 1995
+# Whom: Julian Stacey <jhs@freebsd.org>
+#
+# $Id$
+#
+
+DISTNAME= pbasic-2.0-950813
+PKGNAME= pbasic-2.0
+CATEGORIES+= languages
+KEYWORDS+= basic interpreter
+MASTER_SITES= ftp://freefall.freebsd.org/pub/FreeBSD/LOCAL_PORTS/
+
+MAINTAINER= asami@FreeBSD.ORG
+# Ask jhs@freebsd.org if you want newer sources or author's latest e-mail
+# (which is currently "phil@gmrs.isar.de" but changes a lot)
+
+ALL_TARGET= freebsd
+MAKEFILE= makefile
+
+do-configure:
+ -cd ${WRKSRC} ; rm -rf termio m68000 msdos vax pyramid ns32000 \
+ pdp11 cursor/cursor.dos cursor/cursor.ukc
+
+do-install:
+ install -c -s -m 775 ${WRKSRC}/basic ${PREFIX}/bin/pbasic
+ install -c -m 644 ${WRKSRC}/docs/basic.1 ${PREFIX}/man/man1/pbasic.1
+.if !defined(NOMANCOMPRESS)
+ gzip -9nf ${PREFIX}/man/man1/pbasic.1
+.endif
+
+.include <bsd.port.mk>