aboutsummaryrefslogtreecommitdiff
path: root/lang/pdss/Makefile
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2002-09-19 11:16:58 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2002-09-19 11:16:58 +0000
commitf5dba9dba079ac004aa2ef326f49cc780b167904 (patch)
tree448062e109d6b85abb7e43a7cf45e11eb3a3964e /lang/pdss/Makefile
parent88cf70450578885b63dfea8117592a14eb9533b4 (diff)
downloadports-f5dba9dba079ac004aa2ef326f49cc780b167904.tar.gz
ports-f5dba9dba079ac004aa2ef326f49cc780b167904.zip
Notes
Diffstat (limited to 'lang/pdss/Makefile')
-rw-r--r--lang/pdss/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/lang/pdss/Makefile b/lang/pdss/Makefile
new file mode 100644
index 000000000000..d5c3b9e4d25a
--- /dev/null
+++ b/lang/pdss/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: PDSS-KL1
+# Date created: 07 Sep 2002
+# Whom: NINOMIYA Hideyuki <nin@Jp.FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pdss
+PORTVERSION= 2.52.21
+#PORTREVISION= 1
+CATEGORIES= lang
+MASTER_SITES= ftp://ftp.icot.or.jp/ifs/symbolic-proc/unix/
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX= .tar.Z
+
+MAINTAINER= nin@Jp.FreeBSD.org
+
+USE_REINPLACE= YES
+
+EMACS_FILES= kl1-mode.el pdss-init.e.el pdss-init.j.el \
+ pdss-kl1cmp.el pdss-manual.el pdss.el
+
+INSTALL_DIR= ${INSTALL} -d ${_SHROWNGRP} -m 0755
+
+WRKSRC= ${WRKDIR}
+MAKE_ENV+= BSD_INSTALL_DIR="${INSTALL_DIR}"
+SCRIPTS_ENV+= BSD_INSTALL_DIR="${INSTALL_DIR}"
+
+do-configure:
+ @${CP} ${FILESDIR}/Makefile.bsd ${WRKSRC}/Makefile
+.for f in pdsscmp emulator/config.h emacs/pdss-init.el
+ @${REINPLACE_CMD} -e "s:%%PREFIX%%:${PREFIX}:" ${WRKSRC}/${f}
+.endfor
+
+post-build:
+ @${CP} ${WRKSRC}/emacs/pdss-init.el ${WRKSRC}/emacs/pdss-init.e.el
+ @${CP} ${WRKSRC}/emacs/pdss-init.el ${WRKSRC}/emacs/pdss-init.j.el
+ @${REINPLACE_CMD} -e "s:%%DOCDIR%%:doc.e:" ${WRKSRC}/emacs/pdss-init.e.el
+ @${REINPLACE_CMD} -e "s:%%DOCDIR%%:doc.j:" ${WRKSRC}/emacs/pdss-init.j.el
+
+post-install:
+ @${INSTALL_DIR} ${DATADIR}/emacs
+.for f in ${EMACS_FILES}
+ ${INSTALL_DATA} ${WRKSRC}/emacs/${f} ${DATADIR}/emacs
+.endfor
+
+.include <bsd.port.mk>