aboutsummaryrefslogtreecommitdiff
path: root/lang/pdss/files
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2002-09-19 11:16:58 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2002-09-19 11:16:58 +0000
commitf5dba9dba079ac004aa2ef326f49cc780b167904 (patch)
tree448062e109d6b85abb7e43a7cf45e11eb3a3964e /lang/pdss/files
parent88cf70450578885b63dfea8117592a14eb9533b4 (diff)
Notes
Diffstat (limited to 'lang/pdss/files')
-rw-r--r--lang/pdss/files/Makefile.bsd75
-rw-r--r--lang/pdss/files/patch-compiler:Makefile23
-rw-r--r--lang/pdss/files/patch-debug_utl:Makefile27
-rw-r--r--lang/pdss/files/patch-emacs:pdss-init.el49
-rw-r--r--lang/pdss/files/patch-emulator:Makefile65
-rw-r--r--lang/pdss/files/patch-emulator:config.h60
-rw-r--r--lang/pdss/files/patch-mpimos:Makefile26
-rw-r--r--lang/pdss/files/patch-pdsscmp33
-rw-r--r--lang/pdss/files/patch-pimos_utl:Makefile26
-rw-r--r--lang/pdss/files/patch-runtime:Makefile26
10 files changed, 410 insertions, 0 deletions
diff --git a/lang/pdss/files/Makefile.bsd b/lang/pdss/files/Makefile.bsd
new file mode 100644
index 000000000000..3ba947f452ea
--- /dev/null
+++ b/lang/pdss/files/Makefile.bsd
@@ -0,0 +1,75 @@
+#
+# ports/lang/pdss/Makefile
+#
+
+BINDIR?= ${PREFIX}/bin
+PDSSROOT?= ${PREFIX}/libexec/pdss
+PDSSSHARE?= ${PREFIX}/share/pdss
+
+MAKE_SUB= ${MAKE} PDSSROOT=${PDSSROOT} PDSSSHARE=${PDSSSHARE}
+
+SUBDIRS= emulator runtime mpimos compiler \
+ debug_utl pimos_utl
+
+SUBDIRS_SHARE= macro compiler_pl doc.e doc.j \
+ sample test
+
+FILES= CONTENTS COPYRIGHT COPYRIGHT.J INSTALL \
+ INSTALL.J README README.J
+
+MACRO_FILES= pdss pimos
+
+COMPILER_PL_FILES= \
+ Makefile aux2.pl code_opt2.pl comp2.pl \
+ convert.pl gen_kl1cmp.pl index2.pl libdir.pl \
+ macro2.pl mrb4.pl norm3.pl pdss_blt.pl \
+ pdss_sys.pl pdsstrans.pl read.pl reg.pl \
+ top2.pl write2.pl
+
+DOC.E_FILES= pdss.dvi pdss.sty pdss.tex
+
+DOC.J_FILES= jmakeindex.c pdss.dvi pdss.sty pdss.tex
+
+SAMPLE_FILES= append.kl1 bestpath.kl1 bup.kl1 check.kl1 \
+ dead.kl1 espascal.kl1 etsmall.kl1 kl1cmp1.kl1 \
+ kl1cmp2.kl1 prime.kl1 prime_dd.kl1 qlay.kl1 \
+ queen.kl1 semi.kl1 tri.kl1
+
+TEST_FILES= b_arith.kl1 b_arith_e.kl1 b_arith_s.kl1 b_atom.kl1 \
+ b_atom_e.kl1 b_atom_s.kl1 b_code.kl1 b_code_e.kl1 \
+ b_code_s.kl1 b_f_arith.kl1 b_f_arith_e.kl1 b_f_arith_s.kl1 \
+ b_f_func1.kl1 b_f_func1_e.kl1 b_f_func1_s.kl1 b_f_func2.kl1 \
+ b_f_func2_e.kl1 b_f_func2_s.kl1 b_f_tfunc.kl1 b_f_tfunc_e.kl1 \
+ b_f_tfunc_s.kl1 b_func.kl1 b_func_e.kl1 b_func_s.kl1 \
+ b_logic.kl1 b_logic_e.kl1 b_logic_s.kl1 b_merge.kl1 \
+ b_pri_e.kl1 b_pri_pro.kl1 b_pri_s.kl1 b_raise_e.kl1 \
+ b_raise_s.kl1 b_string.kl1 b_string_e.kl1 b_string_s.kl1 \
+ b_type.kl1 b_type_s.kl1 b_vector.kl1 b_vector_e.kl1 \
+ b_vector_s.kl1 br_cnst.kl1 check_cnst.kl1 g_arith.kl1 \
+ g_comp.kl1 g_diff.kl1 g_f_arith.kl1 g_f_comp.kl1 \
+ g_f_func1.kl1 g_f_func2.kl1 g_f_tfunc.kl1 g_func.kl1 \
+ g_logic.kl1 g_vec_str.kl1 get_cnst.kl1 get_cnst_e.kl1 \
+ get_val.kl1 get_val_e.kl1 is_type.kl1 jnon_type.kl1 \
+ jnon_type_s.kl1 put_cnst.kl1 put_val.kl1 put_var.kl1 \
+ read_var.kl1 reuse.kl1 set_cnst.kl1 set_val.kl1 \
+ set_var.kl1 sw_type.kl1 test_cnst.kl1 type.kl1 \
+ type_s.kl1 wait_cnst.kl1 wait_cnst_s.kl1 wait_val.kl1 \
+ wait_val_s.kl1 write_cnst.kl1 write_val.kl1 write_var.kl1
+
+all:
+.for dir in ${SUBDIRS}
+ cd ${dir}; ${MAKE_SUB} all
+.endfor
+
+install:
+ ${BSD_INSTALL_DIR} ${PDSSROOT}
+.for dir in ${SUBDIRS}
+ cd ${dir}; ${MAKE_SUB} install
+.endfor
+ ${BSD_INSTALL_SCRIPT} pdsscmp ${BINDIR}
+ ${BSD_INSTALL_DIR} ${PDSSSHARE}
+ ${BSD_INSTALL_DATA} ${FILES} ${PDSSSHARE}
+.for dir in ${SUBDIRS_SHARE}
+ ${BSD_INSTALL_DIR} ${PDSSSHARE}/${dir}
+ cd ${dir} ; ${BSD_INSTALL_DATA} ${${dir:U:C/(.*)/\1_FILES/}} ${PDSSSHARE}/${dir}/
+.endfor
diff --git a/lang/pdss/files/patch-compiler:Makefile b/lang/pdss/files/patch-compiler:Makefile
new file mode 100644
index 000000000000..8cb88b533877
--- /dev/null
+++ b/lang/pdss/files/patch-compiler:Makefile
@@ -0,0 +1,23 @@
+Index: compiler/Makefile
+===================================================================
+RCS file: /ext/cvs/PDSS/compiler/Makefile,v
+retrieving revision 1.1.1.1
+retrieving revision 1.1.1.1.2.2
+diff -u -r1.1.1.1 -r1.1.1.1.2.2
+--- compiler/Makefile 11 Jun 2002 16:11:13 -0000 1.1.1.1
++++ compiler/Makefile 5 Sep 2002 08:26:56 -0000 1.1.1.1.2.2
+@@ -1,3 +1,5 @@
++COMPILERDIR = ${PDSSROOT}/compiler
++
+ PDSSCMP = ../pdsscmp +s
+ PDSSASM = ../emulator/pdssasm
+ PARA =
+@@ -8,6 +10,8 @@
+ all: $(PARA) $(COMPILER)
+
+ install:
++ ${BSD_INSTALL_DIR} ${COMPILERDIR}
++ ${BSD_INSTALL_SCRIPT} ${COMPILER} ${COMPILERDIR}
+
+ clean:
+
diff --git a/lang/pdss/files/patch-debug_utl:Makefile b/lang/pdss/files/patch-debug_utl:Makefile
new file mode 100644
index 000000000000..3cff4ac010be
--- /dev/null
+++ b/lang/pdss/files/patch-debug_utl:Makefile
@@ -0,0 +1,27 @@
+Index: debug_utl/Makefile
+===================================================================
+RCS file: /ext/cvs/PDSS/debug_utl/Makefile,v
+retrieving revision 1.1.1.1
+retrieving revision 1.1.1.1.2.2
+diff -u -r1.1.1.1 -r1.1.1.1.2.2
+--- debug_utl/Makefile 11 Jun 2002 16:11:12 -0000 1.1.1.1
++++ debug_utl/Makefile 5 Sep 2002 08:26:56 -0000 1.1.1.1.2.2
+@@ -1,3 +1,6 @@
++DUTLDIR = ${PDSSROOT}/debug_utl
++DUTLSRCDIR = ${PDSSSHARE}/debug_utl
++
+ PDSSCMP = ../pdsscmp
+ PDSSASM = ../emulator/pdssasm
+ PARA =
+@@ -8,7 +11,10 @@
+ all: $(PARA) $(DUTIL)
+
+ install:
+-
++ ${BSD_INSTALL_DIR} ${DUTLDIR}
++ ${BSD_INSTALL_SCRIPT} ${DUTIL} ${DUTLDIR}
++ ${BSD_INSTALL_DIR} ${DUTLSRCDIR}
++ ${BSD_INSTALL_DATA} *.kl1 ${DUTLSRCDIR}
+ clean:
+
+ reassm:
diff --git a/lang/pdss/files/patch-emacs:pdss-init.el b/lang/pdss/files/patch-emacs:pdss-init.el
new file mode 100644
index 000000000000..54759cef9abf
--- /dev/null
+++ b/lang/pdss/files/patch-emacs:pdss-init.el
@@ -0,0 +1,49 @@
+Index: emacs/pdss-init.el
+===================================================================
+RCS file: /ext/cvs/PDSS/emacs/pdss-init.el,v
+retrieving revision 1.1.1.1
+retrieving revision 1.1.1.1.2.2
+diff -u -r1.1.1.1 -r1.1.1.1.2.2
+--- emacs/pdss-init.el 11 Jun 2002 16:11:14 -0000 1.1.1.1
++++ emacs/pdss-init.el 1 Aug 2002 12:54:23 -0000 1.1.1.1.2.2
+@@ -1,21 +1,21 @@
+ ;; GNU Emacs initiation file for PDSS V2.5 (89.09.13)
+ ;; Copy this file to emacs/lisp directory (see Makefile),
+ ;; and insert following command into user's .emacs file.
+-;; (load "pdss-init")
++;; (require "pdss-init")
+
+ ;;-----------------------------------------------------------------------------
+ ;; Path Names.
+
+ (defconst pdss-directory-name
+- "/usr/local/src/pdss/"
++ "%%PREFIX%%/libexec/pdss/"
+ "Directory path name of PDSS.")
+
+ (defconst pdss-emacs-directory-name
+- "/usr/local/src/pdss/emacs/"
++ "%%PREFIX%%/libexec/pdss/emacs/"
+ "Directory path name of PDSS.")
+
+ (defconst pdss-command-name
+- (concat pdss-directory-name "emulator/pdss")
++ "pdss"
+ "Command path name of PDSS emulator.")
+
+ (defconst pdss-kl1cmp-compiler
+@@ -39,7 +39,7 @@
+ "Command path name of PDSS assembler.")
+
+ (defconst pdss-manual-file-name
+- (concat pdss-directory-name "doc.j/pdss.tex")
++ "%%PREFIX%%/share/pdss/%%DOCDIR%%/pdss.tex"
+ "Path name of PDSS manual file.")
+
+ ;;-----------------------------------------------------------------------------
+@@ -60,3 +60,5 @@
+
+ (setq auto-mode-alist
+ (cons '("\\.kl1$" . kl1-mode) auto-mode-alist))
++
++(provide 'pdss-init)
diff --git a/lang/pdss/files/patch-emulator:Makefile b/lang/pdss/files/patch-emulator:Makefile
new file mode 100644
index 000000000000..80e7e5059f5f
--- /dev/null
+++ b/lang/pdss/files/patch-emulator:Makefile
@@ -0,0 +1,65 @@
+Index: emulator/Makefile
+===================================================================
+RCS file: /ext/cvs/PDSS/emulator/Makefile,v
+retrieving revision 1.1.1.1
+retrieving revision 1.1.1.1.2.2
+diff -u -r1.1.1.1 -r1.1.1.1.2.2
+--- emulator/Makefile 11 Jun 2002 16:11:11 -0000 1.1.1.1
++++ emulator/Makefile 5 Sep 2002 08:26:56 -0000 1.1.1.1.2.2
+@@ -5,11 +5,12 @@
+ # ALL RIGHTS RESERVED. #
+ ##########################################################################
+
+-BINDIR = /usr/local/bin
++BINDIR ?= ${PREFIX}/bin
++EMULATORDIR = ${PDSSROOT}/emulator
+
+ #CFLAGS = -g -DDEBUG
+ #CFLAGS = -g -DDEBUG -J
+-CFLAGS = -O
++CFLAGS ?= -O
+ #CFLAGS = -p
+
+ PARA =
+@@ -29,21 +30,23 @@
+ INV = pdssinv.o memory.o atom.o module.o instr.o\
+ invassm.o saveload.o float.o ctype.o
+ MERGE = pdssmerge.o
++PROG = pdssasm pdssmerge
++DATA = KL1CMP RUNTIME STARTUP
+
+-all: pdss pdssasm pdssmerge
++all: pdss ${PROG}
+
+ pdss: $(PARA) $(KL1)
+- $(CC) $(CFLAGS) -o pdss.x -D"MAKEDATE=\"`date`\"" version.c $(KL1) -lm
++ ${SETENV} LC_ALL=C $(CC) $(CFLAGS) -o pdss.x -D"MAKEDATE=\"`date`\"" version.c $(KL1) -lcompat -lm
+ mv -f pdss.x pdss
+ rm -f version.o
+
+ pdssasm: $(PARA) $(ASM)
+- $(CC) $(CFLAGS) -o pdssasm.x -D"MAKEDATE=\"`date`\"" version.c $(ASM) -lm
++ ${SETENV} LC_ALL=C $(CC) $(CFLAGS) -o pdssasm.x -D"MAKEDATE=\"`date`\"" version.c $(ASM) -lm
+ mv -f pdssasm.x pdssasm
+ rm -f version.o
+
+ pdssinv: $(PARA) $(INV)
+- $(CC) $(CFLAGS) -o pdssinv.x -D"MAKEDATE=\"`date`\"" version.c $(INV) -lm
++ ${SETENV} LC_ALL=C $(CC) $(CFLAGS) -o pdssinv.x -D"MAKEDATE=\"`date`\"" version.c $(INV) -lm
+ mv -f pdssinv.x pdssinv
+ rm -f version.o
+
+@@ -52,9 +55,10 @@
+ mv -f pdssmerge.x pdssmerge
+
+ install:
+- cp pdss $(BINDIR)/pdss.x
+- strip $(BINDIR)/pdss.x
+- mv -f $(BINDIR)/pdss.x $(BINDIR)/pdss
++ ${BSD_INSTALL_PROGRAM} pdss ${BINDIR}
++ ${BSD_INSTALL_DIR} ${EMULATORDIR}
++ ${BSD_INSTALL_PROGRAM} ${PROG} ${EMULATORDIR}
++ ${BSD_INSTALL_DATA} ${DATA} ${EMULATORDIR}
+
+ clean:
+ rm -f $(KL1) $(ASM) $(INV) $(MERGE)
diff --git a/lang/pdss/files/patch-emulator:config.h b/lang/pdss/files/patch-emulator:config.h
new file mode 100644
index 000000000000..d3e6ed58c199
--- /dev/null
+++ b/lang/pdss/files/patch-emulator:config.h
@@ -0,0 +1,60 @@
+Index: emulator/config.h
+===================================================================
+RCS file: /ext/cvs/PDSS/emulator/config.h,v
+retrieving revision 1.1.1.1
+retrieving revision 1.1.1.1.2.1
+diff -u -r1.1.1.1 -r1.1.1.1.2.1
+--- emulator/config.h 11 Jun 2002 16:11:11 -0000 1.1.1.1
++++ emulator/config.h 20 Jul 2002 08:30:53 -0000 1.1.1.1.2.1
+@@ -28,9 +28,12 @@
+ object. It is uesd by dynamic native code module linker.
+ (But, native code generator is not supported yet.)
+ *************************************************************************/
+-#define PDSS_LIBDIR "/usr/local/src/pdss"
+-#define PDSS_SUPDIR "/usr/local/src/pdss/emulator"
+-#define PDSS_OBJECT_FILE "/usr/local/src/pdss/emulator/pdss"
++/* #define PDSS_LIBDIR "/usr/local/src/pdss" */
++#define PDSS_LIBDIR "%%PREFIX%%/libexec/pdss"
++/* #define PDSS_SUPDIR "/usr/local/src/pdss/emulator" */
++#define PDSS_SUPDIR "%%PREFIX%%/libexec/pdss/emulator"
++/* #define PDSS_OBJECT_FILE "/usr/local/src/pdss/emulator/pdss" */
++#define PDSS_OBJECT_FILE "%%PREFIX%%/libexec/pdss/emulator/pdss"
+
+
+ /*************************************************************************
+@@ -69,8 +72,10 @@
+ area at initial startup time, then PDSS divide code area into 2
+ parts and use divided one for user codes.
+ *************************************************************************/
+-#define HEAP_SIZE 200000
+-#define CODE_SIZE 1000000
++/* #define HEAP_SIZE 200000 */
++#define HEAP_SIZE 625000
++/* #define CODE_SIZE 1000000 */
++#define CODE_SIZE 5000000
+
+
+ /*************************************************************************
+@@ -169,7 +174,8 @@
+ Configuration for atom table.
+ >> MAX_ATOMS: Maximum number of atoms.
+ *************************************************************************/
+-#define MAX_ATOMS 20000
++/* #define MAX_ATOMS 20000 */
++#define MAX_ATOMS 50000
+
+
+ /*************************************************************************
+@@ -251,6 +257,9 @@
+ INSTRUCTION_COUNT's value are `YES', PDSS counts the number of
+ branches in each KL1-B instuction.
+ *************************************************************************/
+-#define INSTRUCTION_TRACE NO
+-#define INSTRUCTION_COUNT NO
+-#define INSTRUCTION_BRANCH_COUNT NO
++/* #define INSTRUCTION_TRACE NO */
++#define INSTRUCTION_TRACE YES
++/* #define INSTRUCTION_COUNT NO */
++#define INSTRUCTION_COUNT YES
++/* #define INSTRUCTION_BRANCH_COUNT NO */
++#define INSTRUCTION_BRANCH_COUNT YES
diff --git a/lang/pdss/files/patch-mpimos:Makefile b/lang/pdss/files/patch-mpimos:Makefile
new file mode 100644
index 000000000000..2301fffbb7ba
--- /dev/null
+++ b/lang/pdss/files/patch-mpimos:Makefile
@@ -0,0 +1,26 @@
+Index: mpimos/Makefile
+===================================================================
+RCS file: /ext/cvs/PDSS/mpimos/Makefile,v
+retrieving revision 1.1.1.1
+retrieving revision 1.1.1.1.2.2
+diff -u -r1.1.1.1 -r1.1.1.1.2.2
+--- mpimos/Makefile 11 Jun 2002 16:11:11 -0000 1.1.1.1
++++ mpimos/Makefile 5 Sep 2002 08:26:56 -0000 1.1.1.1.2.2
+@@ -1,3 +1,6 @@
++MPIMOSDIR = ${PDSSROOT}/mpimos
++MPIMOSSRCDIR= ${PDSSSHARE}/mpimos
++
+ PDSSCMP = ../pdsscmp +s
+ PDSSASM = ../emulator/pdssasm
+ PARA =
+@@ -17,6 +20,10 @@
+ all: $(PARA) $(MPIMOS)
+
+ install:
++ ${BSD_INSTALL_DIR} ${MPIMOSDIR}
++ ${BSD_INSTALL_SCRIPT} ${MPIMOS} ${MPIMOSDIR}
++ ${BSD_INSTALL_DIR} ${MPIMOSSRCDIR}
++ ${BSD_INSTALL_DATA} *.kl1 ${MPIMOSSRCDIR}
+
+ clean:
+
diff --git a/lang/pdss/files/patch-pdsscmp b/lang/pdss/files/patch-pdsscmp
new file mode 100644
index 000000000000..2ee2d48ad3e2
--- /dev/null
+++ b/lang/pdss/files/patch-pdsscmp
@@ -0,0 +1,33 @@
+Index: pdsscmp
+===================================================================
+RCS file: /ext/cvs/PDSS/pdsscmp,v
+retrieving revision 1.1.1.1
+retrieving revision 1.1.1.1.2.1
+diff -u -r1.1.1.1 -r1.1.1.1.2.1
+--- pdsscmp 11 Jun 2002 16:11:11 -0000 1.1.1.1
++++ pdsscmp 20 Jul 2002 08:30:53 -0000 1.1.1.1.2.1
+@@ -1,8 +1,19 @@
+-comp=/usr/local/src/pdss/compiler_pl/kl1cmp
+-tran=/usr/local/src/pdss/compiler_pl/pdsstrans
+-save=/usr/local/src/pdss/emulator/pdssasm
+-pdss=/usr/local/src/pdss/emulator/pdss
+-stup=/usr/local/src/pdss/emulator/KL1CMP
++#!/bin/sh
++# pdsscmp
++#
++# $Id: patch-pdsscmp,v 1.1 2002/09/07 16:33:39 nin Exp $
++
++pdssroot=%%PREFIX%%/libexec/pdss
++#comp=/usr/local/src/pdss/compiler_pl/kl1cmp
++comp=${pdssroot}/compiler_pl/kl1cmp
++#tran=/usr/local/src/pdss/compiler_pl/pdsstrans
++tran=${pdssroot}/compiler_pl/pdsstrans
++#save=/usr/local/src/pdss/emulator/pdssasm
++save=${pdssroot}/emulator/pdssasm
++#pdss=/usr/local/src/pdss/emulator/pdss
++pdss=%%PREFIX%%/bin/pdss
++#stup=/usr/local/src/pdss/emulator/KL1CMP
++stup=${pdssroot}/emulator/KL1CMP
+
+ mode=user
+ indx=1
diff --git a/lang/pdss/files/patch-pimos_utl:Makefile b/lang/pdss/files/patch-pimos_utl:Makefile
new file mode 100644
index 000000000000..79bcf0966ee1
--- /dev/null
+++ b/lang/pdss/files/patch-pimos_utl:Makefile
@@ -0,0 +1,26 @@
+Index: pimos_utl/Makefile
+===================================================================
+RCS file: /ext/cvs/PDSS/pimos_utl/Makefile,v
+retrieving revision 1.1.1.1
+retrieving revision 1.1.1.1.2.2
+diff -u -r1.1.1.1 -r1.1.1.1.2.2
+--- pimos_utl/Makefile 11 Jun 2002 16:11:13 -0000 1.1.1.1
++++ pimos_utl/Makefile 5 Sep 2002 08:26:56 -0000 1.1.1.1.2.2
+@@ -1,3 +1,6 @@
++PUTILDIR = ${PDSSROOT}/pimos_utl
++PUTILSRCDIR = ${PDSSSHARE}/pimos_utl
++
+ PDSSCMP = ../pdsscmp
+ PDSSASM = ../emulator/pdssasm
+ PARA =
+@@ -9,6 +12,10 @@
+ all: $(PARA) $(PUTIL)
+
+ install:
++ ${BSD_INSTALL_DIR} ${PUTILDIR}
++ ${BSD_INSTALL_SCRIPT} ${PUTIL} ${PUTILDIR}
++ ${BSD_INSTALL_DIR} ${PUTILSRCDIR}
++ ${BSD_INSTALL_DATA} *.kl1 ${PUTILSRCDIR}
+
+ clean:
+
diff --git a/lang/pdss/files/patch-runtime:Makefile b/lang/pdss/files/patch-runtime:Makefile
new file mode 100644
index 000000000000..611418ea7ca8
--- /dev/null
+++ b/lang/pdss/files/patch-runtime:Makefile
@@ -0,0 +1,26 @@
+Index: runtime/Makefile
+===================================================================
+RCS file: /ext/cvs/PDSS/runtime/Makefile,v
+retrieving revision 1.1.1.1
+retrieving revision 1.1.1.1.2.2
+diff -u -r1.1.1.1 -r1.1.1.1.2.2
+--- runtime/Makefile 11 Jun 2002 16:11:11 -0000 1.1.1.1
++++ runtime/Makefile 5 Sep 2002 08:26:56 -0000 1.1.1.1.2.2
+@@ -1,3 +1,6 @@
++RUNTIMEDIR = ${PDSSROOT}/runtime
++RUNTIMESRCDIR = ${PDSSSHARE}/runtime
++
+ PDSSCMP = ../pdsscmp +s
+ PDSSASM = ../emulator/pdssasm
+ PARA =
+@@ -7,6 +10,10 @@
+ all: $(PARA) $(RUNTIME)
+
+ install:
++ ${BSD_INSTALL_DIR} ${RUNTIMEDIR}
++ ${BSD_INSTALL_SCRIPT} ${RUNTIME} ${RUNTIMEDIR}
++ ${BSD_INSTALL_DIR} ${RUNTIMESRCDIR}
++ ${BSD_INSTALL_SCRIPT} *.kl1 ${RUNTIMESRCDIR}
+
+ clean:
+