aboutsummaryrefslogtreecommitdiff
path: root/lang/perl5.10
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2012-02-15 02:03:29 +0000
committerSteve Wills <swills@FreeBSD.org>2012-02-15 02:03:29 +0000
commit24e120163b5b501092e0129425b3128fdd34331c (patch)
tree3768d51189bcc9ad68d42a08b8a74081e839a692 /lang/perl5.10
parent19f927ddd925f2d3c0e8f1bacbca4b6e9664e925 (diff)
downloadports-24e120163b5b501092e0129425b3128fdd34331c.tar.gz
ports-24e120163b5b501092e0129425b3128fdd34331c.zip
Notes
Diffstat (limited to 'lang/perl5.10')
-rw-r--r--lang/perl5.10/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/lang/perl5.10/Makefile b/lang/perl5.10/Makefile
index a9ec9de2de29..fc3eab540b2a 100644
--- a/lang/perl5.10/Makefile
+++ b/lang/perl5.10/Makefile
@@ -7,7 +7,7 @@
PORTNAME= perl
PORTVERSION= ${PERL_VERSION}
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= lang devel perl5
MASTER_SITES= CPAN \
${MASTER_SITE_LOCAL:S/$/:local/} \
@@ -34,6 +34,7 @@ OPTIONS= DEBUGGING "Build with debugging support" off \
PERL_MALLOC "Use Perl malloc" off \
PERL_64BITINT "Use 64 bit integers (on i386)" on \
THREADS "Build threaded perl" off \
+ PTHREAD "Build with -pthread" on \
MULTIPLICITY "Use multiplicity" off \
SUIDPERL "Build set-user-id suidperl binary" off \
SITECUSTOMIZE "Run-time customization of @INC" off \
@@ -129,6 +130,7 @@ WITH_PERL_MALLOC= yes
#XXX .endif
CONFIGURE_ARGS+= -Dusethreads=y
PKGNAMESUFFIX= -threaded
+WITH_PTHREAD= yes
# it seems perl malloc has problems with threaded perl on FreeBSD
.undef WITH_PERL_MALLOC
.else
@@ -199,7 +201,7 @@ post-patch:
${BSDPAN_WRKSRC}/ExtUtils/*.pm
${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
${WRKSRC}/Configure ${WRKSRC}/hints/freebsd.sh
-.if defined(WITH_THREADS)
+.if defined(WITH_PTHREAD)
${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|g;' \
-e 's|%%PTHREAD_CFLAGS%%|${PTHREAD_CFLAGS}|g;' \
${WRKSRC}/hints/freebsd.sh