aboutsummaryrefslogtreecommitdiff
path: root/lang/perl5.12/Makefile
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2009-07-06 12:16:08 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2009-07-06 12:16:08 +0000
commit6c6ebb91412d9815cda5b22f537b78dcc9ecc7ad (patch)
treecc3c0f2deeedca0e6b7e8770b1e60015f243043c /lang/perl5.12/Makefile
parent65362df6ed4bda7058f9df00dc0a4d800f458f9b (diff)
downloadports-6c6ebb91412d9815cda5b22f537b78dcc9ecc7ad.tar.gz
ports-6c6ebb91412d9815cda5b22f537b78dcc9ecc7ad.zip
Notes
Diffstat (limited to 'lang/perl5.12/Makefile')
-rw-r--r--lang/perl5.12/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/lang/perl5.12/Makefile b/lang/perl5.12/Makefile
index 429d5003a610..31378ddb7a11 100644
--- a/lang/perl5.12/Makefile
+++ b/lang/perl5.12/Makefile
@@ -7,7 +7,7 @@
PORTNAME= perl
PORTVERSION= ${PERL_VERSION}
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= lang devel perl5
MASTER_SITES= CPAN \
${MASTER_SITE_LOCAL:S/$/:local/} \
@@ -28,6 +28,7 @@ OPTIONS= DEBUGGING "Build with debugging support" off \
PERL_MALLOC "Use Perl malloc" off \
PERL_64BITINT "Use 64 bit integers (on i386)" on \
THREADS "Build threaded perl" off \
+ MULTIPLICITY "Use multiplicity" off \
SUIDPERL "Build set-user-id suidperl binary" off \
SITECUSTOMIZE "Run-time customization of @INC" off \
USE_PERL "Rewrite links in /usr/bin" on
@@ -130,6 +131,10 @@ CONFIGURE_ARGS+= -Dusemymalloc=n
CONFIGURE_ARGS+= -Duse64bitint
.endif
+.if defined(WITH_MULTIPLICITY)
+CONFIGURE_ARGS+= -Dusemultiplicity=y
+.endif
+
.if defined(WITH_SITECUSTOMIZE)
CONFIGURE_ARGS+= -Dusesitecustomize
.endif