aboutsummaryrefslogtreecommitdiff
path: root/lang/perl5.12/Makefile
diff options
context:
space:
mode:
authorGordon Tetlow <gordon@FreeBSD.org>2010-11-05 05:41:37 +0000
committerGordon Tetlow <gordon@FreeBSD.org>2010-11-05 05:41:37 +0000
commitaad4dc8ca8295bbbbd7cccec4e1afecc93e5a2f8 (patch)
tree6f5f2e38840a389446d83fb5e6adb181ad2b7395 /lang/perl5.12/Makefile
parent891e7d921fbf5d3fda7af8ccb78dcc50566c158b (diff)
downloadports-aad4dc8ca8295bbbbd7cccec4e1afecc93e5a2f8.tar.gz
ports-aad4dc8ca8295bbbbd7cccec4e1afecc93e5a2f8.zip
Notes
Diffstat (limited to 'lang/perl5.12/Makefile')
-rw-r--r--lang/perl5.12/Makefile15
1 files changed, 14 insertions, 1 deletions
diff --git a/lang/perl5.12/Makefile b/lang/perl5.12/Makefile
index f85502c6505e..1abe6f16da5f 100644
--- a/lang/perl5.12/Makefile
+++ b/lang/perl5.12/Makefile
@@ -7,7 +7,7 @@
PORTNAME= perl
PORTVERSION= ${PERL_VERSION}
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= lang devel perl5
MASTER_SITES= CPAN \
${MASTER_SITE_LOCAL:S/$/:local/} \
@@ -97,6 +97,12 @@ CONFIGURE_ARGS+= -Ui_gdbm
PLIST_SUB+= GDBM="@comment "
.endif
+.if ${OSVERSION} >= 900022
+PLIST_SUB+= MANCONF=""
+.else
+PLIST_SUB+= MANCONF="@comment "
+.endif
+
.if defined(WITHOUT_PERL_MALLOC)
.undef WITH_PERL_MALLOC
.else
@@ -165,6 +171,10 @@ post-patch:
-e 's|%%LINK_USRBIN%%|${LINK_USRBIN}|g;' \
${FILESDIR}/use.perl \
> ${WRKDIR}/use.perl
+ ${SED} -e 's|%%PREFIX%%|${PREFIX}|g;' \
+ -e 's|%%PERL_VERSION%%|${PERL_VERSION}|g;' \
+ ${FILESDIR}/perl-man.conf \
+ > ${WRKDIR}/perl-man.conf
${SED} -e 's|%%PERL%%|${PERL}|g; s|%%PERL_VERSION%%|${PERL_VERSION}|g; s|%%PKGNAME%%|${PKGNAME}|g' \
${FILESDIR}/perl-after-upgrade \
> ${WRKDIR}/perl-after-upgrade
@@ -196,6 +206,9 @@ post-install:
@${INSTALL_SCRIPT} ${WRKDIR}/perl-after-upgrade ${PREFIX}/bin/perl-after-upgrade
@${INSTALL_MAN} ${WRKDIR}/perl-after-upgrade.1 ${MAN1PREFIX}/man/man1/perl-after-upgrade.1
@${LN} -sf ${PREFIX}/bin/perl${PERL_VERSION} ${PREFIX}/bin/perl5
+.if ${OSVERSION} >= 900022
+ @${INSTALL_DATA} ${WRKDIR}/perl-man.conf ${PREFIX}/etc/man.d/perl${PERL_VERSION}.conf
+.endif
.for files in ${BSDPAN_FILES}
${MKDIR} ${BSDPAN_DEST}/${files:H}
${INSTALL} ${COPY} -o ${BINOWN} -g ${BINGRP} -m ${NOBINMODE} \