aboutsummaryrefslogtreecommitdiff
path: root/lang/perl5.14/Makefile
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2008-11-20 16:24:37 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2008-11-20 16:24:37 +0000
commit6abecdadfc3303f5b9bb644a9aaf9d9df6b7edd3 (patch)
tree08310fcf7c7d448d87b772fd81f5d332538fe439 /lang/perl5.14/Makefile
parent952fabc738133ff58b015ea204aee9dc129054b9 (diff)
downloadports-6abecdadfc3303f5b9bb644a9aaf9d9df6b7edd3.tar.gz
ports-6abecdadfc3303f5b9bb644a9aaf9d9df6b7edd3.zip
Notes
Diffstat (limited to 'lang/perl5.14/Makefile')
-rw-r--r--lang/perl5.14/Makefile39
1 files changed, 17 insertions, 22 deletions
diff --git a/lang/perl5.14/Makefile b/lang/perl5.14/Makefile
index 00fdf85e2c6c..efbdb029438f 100644
--- a/lang/perl5.14/Makefile
+++ b/lang/perl5.14/Makefile
@@ -21,9 +21,19 @@ PATCH_SITES= ${MASTER_SITE_LOCAL:S/$/tobez\//} \
http://www.tobez.org/download/port-mirrors/lang/perl58/
PATCHFILES= defined-or-5.8.8.bz2
-MAINTAINER= tobez@FreeBSD.org
+MAINTAINER= skv@FreeBSD.org
COMMENT= Practical Extraction and Report Language
+CONFLICTS= perl-5.6.* perl-5.10.*
+
+OPTIONS= DEBUGGING "Build with debugging support" off \
+ GDBM "Build GDBM_File extension" off \
+ PERL_MALLOC "Use Perl malloc" on \
+ PERL_64BITINT "Use 64 bit integers (on i386)" on \
+ THREADS "Build threaded perl" off \
+ SUIDPERL "Build set-user-id suidperl binary" off \
+ USE_PERL "Rewrite links in /usr/bin" on
+
PERL_VER= 5.8.8
PERL_ARCH= mach
PERL_VERSION= ${PERL_VER}
@@ -67,12 +77,12 @@ STRIP_CMD= ${TRUE}
CONFIGURE_ARGS+= -Doptimize="${CFLAGS}"
.endif
-.if defined(ENABLE_SUIDPERL)
+.if defined(ENABLE_SUIDPERL) || defined(WITH_SUIDPERL)
CONFIGURE_ARGS+= -Dd_dosuid=define
-PLIST_SUB+= ENABLE_SUIDPERL=""
+PLIST_SUB+= SUIDPERL=""
.else
CONFIGURE_ARGS+= -Ud_dosuid
-PLIST_SUB+= ENABLE_SUIDPERL="@comment "
+PLIST_SUB+= SUIDPERL="@comment "
.endif
.if defined(WITH_GDBM)
@@ -108,7 +118,7 @@ CONFIGURE_ARGS+= -Dusemymalloc=y
CONFIGURE_ARGS+= -Dusemymalloc=n
.endif
-.if !defined(WITHOUT_PERL_64BITINT)
+.if defined(WITH_PERL_64BITINT)
CONFIGURE_ARGS+= -Duse64bitint
.endif
@@ -139,21 +149,6 @@ BSDPAN_WRKSRC= ${WRKDIR}/BSDPAN-${PORTVERSION}
PKGINSTALL= ${WRKDIR}/pkg-install
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
-pre-fetch:
- @${ECHO} ""
- @${ECHO} "You may use the following build options:"
- @${ECHO} ""
- @${ECHO} " WITH_DEBUGGING=yes Build perl with debugging support."
- @${ECHO} " WITH_GDBM=yes Build GDBM_File extension."
- @${ECHO} " WITHOUT_PERL_MALLOC=yes Use FreeBSD system malloc"
- @${ECHO} " (uses less memory, but slower)."
- @${ECHO} " WITHOUT_PERL_64BITINT=yes Disable 64 bit integers"
- @${ECHO} " (affects only 32-bit platforms)."
- @${ECHO} " WITH_THREADS=yes Build threaded perl."
- @${ECHO} " ENABLE_SUIDPERL=yes Also build set-user-id suidperl binary."
- @${ECHO} " WITHOUT_USE_PERL=yes Do not rewrite links in /usr/bin"
- @${ECHO} ""
-
post-patch:
${SED} -e 's|%%PREFIX%%|${PREFIX}|g;' \
-e 's|%%PERL_VER%%|${PERL_VER}|g;' \
@@ -177,7 +172,7 @@ post-patch:
${WRKSRC}/hints/freebsd.sh
.endif
-pre-install:
+pre-su-install:
@${RM} -f ${PREFIX}/bin/perl${PERL_VER}
@${RM} -f ${PREFIX}/bin/perl
@@ -193,7 +188,7 @@ post-install:
${INSTALL} ${COPY} -o ${BINOWN} -g ${BINGRP} -m ${NOBINMODE} \
${BSDPAN_WRKSRC}/${files} ${BSDPAN_DEST}/${files}
.endfor
-.ifndef WITHOUT_USE_PERL
+.if defined(WITH_USE_PERL)
PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
.if ${OSVERSION} < 500036
${INSTALL_SCRIPT} ${WRKDIR}/use.perl ${PREFIX}/bin/use.perl