aboutsummaryrefslogtreecommitdiff
path: root/lang/perl5.14/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2014-11-29 14:56:26 +0000
committerMathieu Arnold <mat@FreeBSD.org>2014-11-29 14:56:26 +0000
commit84a0cdc20eaa215476bc482849a6eaa17c920691 (patch)
tree72f3a975219144110504aea3b5abe810b1c4ca7e /lang/perl5.14/Makefile
parentcdb630c7f4a0b69437d67a41ffcc178fd08b18a6 (diff)
Really disable MULTIPLICITY if disabled in OPTIONS, and as it was always on
before, add it to the OPTIONS_DEFAULT to not change the default behavior. Noticed by: ache Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=373622
Diffstat (limited to 'lang/perl5.14/Makefile')
-rw-r--r--lang/perl5.14/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/lang/perl5.14/Makefile b/lang/perl5.14/Makefile
index 7fb19d7b9cdf..a2f06442063c 100644
--- a/lang/perl5.14/Makefile
+++ b/lang/perl5.14/Makefile
@@ -3,7 +3,7 @@
PORTNAME= perl
PORTVERSION= ${PERL_VERSION}
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= lang devel perl5
MASTER_SITES= CPAN \
${MASTER_SITE_LOCAL:S/$/:local/} \
@@ -29,7 +29,7 @@ CONFLICTS_INSTALL= perl5.*-*
OPTIONS_DEFINE= DEBUG GDBM PERL_MALLOC PERL_64BITINT THREADS PTHREAD \
MULTIPLICITY SITECUSTOMIZE USE_PERL
-OPTIONS_DEFAULT= PERL_64BITINT THREADS PTHREAD USE_PERL
+OPTIONS_DEFAULT= PERL_64BITINT THREADS PTHREAD USE_PERL MULTIPLICITY
OPTIONS_SUB=
GDBM_DESC= GDBM_File extension
PERL_MALLOC_DESC= Use Perl malloc
@@ -175,6 +175,8 @@ CONFIGURE_ARGS+= -Duse64bitint
.if ${PORT_OPTIONS:MMULTIPLICITY}
CONFIGURE_ARGS+= -Dusemultiplicity=y
+.else
+CONFIGURE_ARGS+= -Dusemultiplicity=n
.endif
.if ${PORT_OPTIONS:MSITECUSTOMIZE}