aboutsummaryrefslogtreecommitdiff
path: root/lang/perl5.14
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2005-02-02 09:34:05 +0000
committerAnton Berezin <tobez@FreeBSD.org>2005-02-02 09:34:05 +0000
commite2611e24e061b6fd7fdececed33cd8361b900f81 (patch)
tree4540b2498bf39c544d72184831ae0e04fdd6680d /lang/perl5.14
parentbdc7d6ab9074f42ce535ec147aaa8658b65cad1d (diff)
downloadports-e2611e24e061b6fd7fdececed33cd8361b900f81.tar.gz
ports-e2611e24e061b6fd7fdececed33cd8361b900f81.zip
Notes
Diffstat (limited to 'lang/perl5.14')
-rw-r--r--lang/perl5.14/Makefile6
-rw-r--r--lang/perl5.14/files/use.perl2
2 files changed, 5 insertions, 3 deletions
diff --git a/lang/perl5.14/Makefile b/lang/perl5.14/Makefile
index feb908223f83..4b23c9f21a6f 100644
--- a/lang/perl5.14/Makefile
+++ b/lang/perl5.14/Makefile
@@ -7,6 +7,7 @@
PORTNAME= perl
PORTVERSION= ${PERL_VER}
+PORTREVISION= 1
CATEGORIES= lang devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN} \
${MASTER_SITE_LOCAL:S/$/:local/} \
@@ -90,8 +91,9 @@ CONFIGURE_ARGS+= -Dusemymalloc=n
CONFIGURE_ARGS+= -Duse64bitint
.endif
-.if ${OSVERSION} < 502100
LATEST_LINK= perl5.8
+
+.if ${OSVERSION} < 500036
PLIST_SUB+= NEED_USE_PERL=""
.else
PKGMESSAGE= ${PKGDIR}/.not-here
@@ -151,7 +153,7 @@ post-install:
${BSDPAN_WRKSRC}/${files} ${BSDPAN_DEST}/${files}
.endfor
PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.if ${OSVERSION} < 502100
+.if ${OSVERSION} < 500036
${INSTALL_SCRIPT} ${WRKDIR}/use.perl ${PREFIX}/bin/use.perl
@fmt ${PKGMESSAGE}
.endif
diff --git a/lang/perl5.14/files/use.perl b/lang/perl5.14/files/use.perl
index c20a441b65da..57e1acde0bc8 100644
--- a/lang/perl5.14/files/use.perl
+++ b/lang/perl5.14/files/use.perl
@@ -42,7 +42,7 @@ if [ "x$this" = "xuse.perl" ]; then
else
if [ "$2" = "POST-INSTALL" ] ; then
need_remove_links=yes
- if [ $osreldate -ge 502100 ] ; then
+ if [ $osreldate -ge 500036 ] ; then
need_create_links=yes
need_cleanup_make_conf=yes
need_cleanup_manpath=yes