aboutsummaryrefslogtreecommitdiff
path: root/lang/perl5.18/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-04-11 15:05:09 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-04-11 15:05:09 +0000
commitb6809df66927c4674bb19b11b201ca56b7871f2c (patch)
tree8547b3d64cd5d9968b114a9480c0b4ca3ece5913 /lang/perl5.18/Makefile
parent7b11121421f8170ef67288a475bbfdec8fbc5aa5 (diff)
Notes
Diffstat (limited to 'lang/perl5.18/Makefile')
-rw-r--r--lang/perl5.18/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/lang/perl5.18/Makefile b/lang/perl5.18/Makefile
index 591580102de3..515899ed90bc 100644
--- a/lang/perl5.18/Makefile
+++ b/lang/perl5.18/Makefile
@@ -3,7 +3,7 @@
PORTNAME= perl
PORTVERSION= ${PERL_VERSION}
-PORTREVISION= 19
+PORTREVISION= 20
CATEGORIES= lang devel perl5
MASTER_SITES= CPAN/../../src/5.0
DIST_SUBDIR= perl
@@ -201,6 +201,7 @@ PLIST_SUB+= PERL_VERSION=${PERL_VERSION} \
SITE_PERL=${SITE_PERL_REL} \
SITE_ARCH=${SITE_ARCH_REL} \
PRIV_LIB=${_PRIV_LIB} \
+ PKGNAMESUFFIX=${PKGNAMESUFFIX} \
ARCH_LIB=${_ARCH_LIB}
# Put a symlink to the future libperl.so.x.yy so that -lperl works.
@@ -272,6 +273,6 @@ post-install:
${STRIP_CMD} $$f; \
${CHMOD} 444 $$f; \
done
- ${INSTALL_DATA} ${WRKDIR}/perl-man.conf ${STAGEDIR}${PREFIX}/etc/man.d/perl${PERL_VER}.conf
+ ${INSTALL_DATA} ${WRKDIR}/perl-man.conf ${STAGEDIR}${PREFIX}/etc/man.d/perl${PKGNAMESUFFIX}.conf
.include <bsd.port.mk>