aboutsummaryrefslogtreecommitdiff
path: root/lang/perl5.24
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2017-01-18 13:20:31 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2017-01-18 13:20:31 +0000
commit02f27a83b44d4566fd409edc60570ac0734eb63e (patch)
tree62d2805fd9c9c4285034b54a2ccb3f498f302811 /lang/perl5.24
parentbddf1289efd81317364118eb60cdc28cc766c3c2 (diff)
downloadports-02f27a83b44d4566fd409edc60570ac0734eb63e.tar.gz
ports-02f27a83b44d4566fd409edc60570ac0734eb63e.zip
Notes
Diffstat (limited to 'lang/perl5.24')
-rw-r--r--lang/perl5.24/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/lang/perl5.24/Makefile b/lang/perl5.24/Makefile
index 651de0614b49..4291a60b7a38 100644
--- a/lang/perl5.24/Makefile
+++ b/lang/perl5.24/Makefile
@@ -97,7 +97,7 @@ CONFIGURE_ARGS= -sde -Dprefix=${PREFIX} \
-Ui_malloc -Ui_iconv -Uinstallusrbinperl -Dusenm=n \
-Dcc="${CC}" -Duseshrplib -Dinc_version_list=none \
-Dcf_by=${MAINTAINER:C,@.*,,} -Dcf_email=${MAINTAINER} \
- -Dcf_time="`env LANG=C ${STAT} -t \"%a %b %d %T %Z %Y\" -f %Sm ${_DISTDIR}/${DISTNAME}${EXTRACT_SUFX}`"
+ -Dcf_time="`${STAT} -t \"%a %b %d %T %Z %Y\" -f %Sm ${_DISTDIR}/${DISTNAME}${EXTRACT_SUFX}`"
# Keep the following two in sync.
# lddlflags is used for all .so linking
# shrpldflags is used for libperl.so, so remove all the extra bits inherited from lddlflags.
@@ -108,11 +108,7 @@ CONFIGURE_ARGS+= \
# Give a hint of where libperl.so can be found.
USE_LDCONFIG= ${PREFIX}/${_ARCH_LIB}/CORE
-LOCALE_CLEANUP= LANG="" LC_ALL="" LC_COLLATE="" LC_CTYPE="" \
- LC_MESSAGES="" LC_MONETARY="" LC_NUMERIC="" \
- LC_TIME=""
-CONFIGURE_ENV+= ${LOCALE_CLEANUP} UNAME_v="$$(uname -v | sed 'y/=/ /')"
-MAKE_ENV+= ${LOCALE_CLEANUP}
+CONFIGURE_ENV+= UNAME_v="$$(uname -v | sed 'y/=/ /')"
SUB_LIST+= PERL_VERSION=${PERL_VERSION} \
PERL_VER=${PERL_VER} \