aboutsummaryrefslogtreecommitdiff
path: root/lang/perl5.6/Makefile
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2005-02-02 09:34:05 +0000
committerAnton Berezin <tobez@FreeBSD.org>2005-02-02 09:34:05 +0000
commite2611e24e061b6fd7fdececed33cd8361b900f81 (patch)
tree4540b2498bf39c544d72184831ae0e04fdd6680d /lang/perl5.6/Makefile
parentbdc7d6ab9074f42ce535ec147aaa8658b65cad1d (diff)
downloadports-e2611e24e061b6fd7fdececed33cd8361b900f81.tar.gz
ports-e2611e24e061b6fd7fdececed33cd8361b900f81.zip
Notes
Diffstat (limited to 'lang/perl5.6/Makefile')
-rw-r--r--lang/perl5.6/Makefile14
1 files changed, 1 insertions, 13 deletions
diff --git a/lang/perl5.6/Makefile b/lang/perl5.6/Makefile
index 45a1d93c8625..f697736dda8d 100644
--- a/lang/perl5.6/Makefile
+++ b/lang/perl5.6/Makefile
@@ -7,7 +7,7 @@
PORTNAME= perl
PORTVERSION= ${PERL_VER}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN} \
${MASTER_SITE_LOCAL:S/$/:local/} \
@@ -79,23 +79,13 @@ CONFIGURE_ARGS+= -Dusemymalloc=n
.error You have `USE_PERL5' variable defined either in environment or in make(1) arguments. Please undefine and try again.
.endif
-.if ${OSVERSION} >= 502100
-LATEST_LINK= perl5.8
-.endif
-
.if ${OSVERSION} < 500036
PKGMESSAGE= ${PKGDIR}/pkg-message-sysperl
-.elif ${OSVERSION} < 502100
-PKGMESSAGE= ${PKGDIR}/.not-here
.else
PKGMESSAGE= ${PKGDIR}/pkg-message-prefer58
.endif
-.if ${OSVERSION} >= 500036 && ${OSVERSION} < 502100
-PLIST_SUB+= NEED_USE_PERL="@comment "
-.else
PLIST_SUB+= NEED_USE_PERL=""
-.endif
.if defined(WITH_GDBM)
MAN3+= GDBM_File.3
@@ -140,9 +130,7 @@ post-install:
${BSDPAN_WRKSRC}/${file} ${BSDPAN_DEST}/${file}
.endfor
PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.if ${OSVERSION} < 500036 || ${OSVERSION} >= 502100
${INSTALL_SCRIPT} ${WRKDIR}/use.perl ${PREFIX}/bin/use.perl
@fmt ${PKGMESSAGE}
-.endif
.include <bsd.port.post.mk>