aboutsummaryrefslogtreecommitdiff
path: root/lang/perl5.8
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2009-11-02 16:50:41 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2009-11-02 16:50:41 +0000
commit4d12d4ea700067ee5024837a45966338df8afbde (patch)
tree73a95f70d28af9a9ecf26b76af316c10678130f8 /lang/perl5.8
parent678f55bcf983489b5c47188a95054fd47036e04b (diff)
downloadports-4d12d4ea700067ee5024837a45966338df8afbde.tar.gz
ports-4d12d4ea700067ee5024837a45966338df8afbde.zip
Notes
Diffstat (limited to 'lang/perl5.8')
-rw-r--r--lang/perl5.8/Makefile11
-rw-r--r--lang/perl5.8/files/use.perl6
2 files changed, 12 insertions, 5 deletions
diff --git a/lang/perl5.8/Makefile b/lang/perl5.8/Makefile
index 16a6253b8831..8e88a66a83e2 100644
--- a/lang/perl5.8/Makefile
+++ b/lang/perl5.8/Makefile
@@ -36,6 +36,8 @@ OPTIONS= DEBUGGING "Build with debugging support" off \
SITECUSTOMIZE "Run-time customization of @INC" off \
USE_PERL "Rewrite links in /usr/bin" on
+PORTSCOUT= limitw:1,even
+
PERL_VERSION= 5.8.9
PERL_ARCH= mach
SITE_PERL_REL?= lib/perl5/site_perl/${PERL_VERSION}
@@ -138,6 +140,12 @@ CONFIGURE_ARGS+= -Duse64bitint
CONFIGURE_ARGS+= -Dusesitecustomize
.endif
+.if defined(WITH_USE_PERL)
+LINK_USRBIN= yes
+.else
+LINK_USRBIN= no
+.endif
+
LATEST_LINK= perl
PLIST_SUB+= NEED_USE_PERL="@comment "
@@ -163,6 +171,7 @@ post-patch:
-e 's|%%PERL_VERSION%%|${PERL_VERSION}|g;' \
-e 's|%%PERL_ARCH%%|${PERL_ARCH}|g;' \
-e 's|%%MAKE_CONF%%|${__MAKE_CONF}|g;' \
+ -e 's|%%LINK_USRBIN%%|${LINK_USRBIN}|g;' \
${FILESDIR}/use.perl \
> ${WRKDIR}/use.perl
${SED} -e 's|%%PERL%%|${PERL}|g; s|%%PERL_VERSION%%|${PERL_VERSION}|g; s|%%PKGNAME%%|${PKGNAME}|g' \
@@ -200,9 +209,7 @@ post-install:
${INSTALL} ${COPY} -o ${BINOWN} -g ${BINGRP} -m ${NOBINMODE} \
${BSDPAN_WRKSRC}/${files} ${BSDPAN_DEST}/${files}
.endfor
-.if defined(WITH_USE_PERL)
PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.endif
test: build
@(cd ${WRKSRC}; make test)
diff --git a/lang/perl5.8/files/use.perl b/lang/perl5.8/files/use.perl
index 55b7f51ed148..23e21002eb80 100644
--- a/lang/perl5.8/files/use.perl
+++ b/lang/perl5.8/files/use.perl
@@ -20,14 +20,14 @@ fi
if [ "x$this" = "xuse.perl" ]; then
PKG_PREFIX="%%PREFIX%%"
if [ "$1" = "port" ] ; then
- need_remove_links=yes
- need_create_links=yes
+ need_remove_links=%%LINK_USRBIN%%
+ need_create_links=%%LINK_USRBIN%%
need_cleanup_make_conf=yes
need_cleanup_manpath=yes
need_spam_make_conf=yes
need_spam_manpath=yes
elif [ "$1" = "system" ] ; then
- need_remove_links=yes
+ need_remove_links=%%LINK_USRBIN%%
need_cleanup_make_conf=yes
need_cleanup_manpath=yes
else