aboutsummaryrefslogtreecommitdiff
path: root/lang/pexts/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-02-12 09:17:41 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-02-12 09:17:41 +0000
commite662fd7e73ea898e8f96b58cbe0c35a298e5c01c (patch)
treeea48ac7cedaa3778bda61af8491ed36359e142c9 /lang/pexts/Makefile
parent0bf04dc9761a9398426303950db9ee36d5dc9a7a (diff)
downloadports-e662fd7e73ea898e8f96b58cbe0c35a298e5c01c.tar.gz
ports-e662fd7e73ea898e8f96b58cbe0c35a298e5c01c.zip
Notes
Diffstat (limited to 'lang/pexts/Makefile')
-rw-r--r--lang/pexts/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/lang/pexts/Makefile b/lang/pexts/Makefile
new file mode 100644
index 000000000000..2de2e3a711d6
--- /dev/null
+++ b/lang/pexts/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: pike
+# Date created: 21 Jan 2002
+# Whom: kiwi@oav.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= pexts
+PORTVERSION= 20020121
+CATEGORIES= lang
+MASTER_SITES= ftp://ftp.oav.net/pkg_freebsd/distfiles/ \
+ http://ftp.oav.net/pkg_freebsd/distfiles/ \
+ http://grendel.firewall.com/caudium-pkg/
+DISTNAME= pexts-snapshot-${PORTVERSION}
+
+MAINTAINER= kiwi@oav.net
+COMMENT= Third party Pike 7.2 extensions
+
+BUILD_DEPENDS= pike:${PORTSDIR}/lang/pike72/
+LIB_DEPENDS= mhash.2:${PORTSDIR}/security/mhash/ \
+ mcrypt.8:${PORTSDIR}/security/libmcrypt/
+
+WRKSRC= ${WRKDIR}/pexts
+
+GNU_CONFIGURE= yes
+
+CONFIGURE_ARGS+= --without-debug
+
+USE_GMAKE= yes
+
+pre-configure:
+ @${ECHO} ${CONFIGURE_ARGS}
+
+.include <bsd.port.mk>