aboutsummaryrefslogtreecommitdiff
path: root/lang/pgcc
diff options
context:
space:
mode:
authorAndreas Klemm <andreas@FreeBSD.org>1996-12-18 16:40:16 +0000
committerAndreas Klemm <andreas@FreeBSD.org>1996-12-18 16:40:16 +0000
commit9a84e6bfb5996ed0c55764056d20e30212fce7b1 (patch)
tree03a72c8b37a95d50a56d26e1970666160acc41d7 /lang/pgcc
parent46c9119e2626047c6c7bf3a170d0e3b11188b1bb (diff)
downloadports-9a84e6bfb5996ed0c55764056d20e30212fce7b1.tar.gz
ports-9a84e6bfb5996ed0c55764056d20e30212fce7b1.zip
Notes
Diffstat (limited to 'lang/pgcc')
-rw-r--r--lang/pgcc/Makefile32
-rw-r--r--lang/pgcc/distinfo2
-rw-r--r--lang/pgcc/files/patch-aa12
-rw-r--r--lang/pgcc/files/patch-ab20
-rw-r--r--lang/pgcc/pkg-comment1
-rw-r--r--lang/pgcc/pkg-descr24
6 files changed, 91 insertions, 0 deletions
diff --git a/lang/pgcc/Makefile b/lang/pgcc/Makefile
new file mode 100644
index 000000000000..801aacb74dba
--- /dev/null
+++ b/lang/pgcc/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: pgcc-current - Pentium gcc
+# Version required: gcc-2.7.2 + Pentium patches current developement
+# Date created: Mi 18 Dez 1996 00:26:20 MET
+# Whom: Andreas Klemm <andreas@klemm.gtn.com>
+#
+# $Id$
+#
+
+DISTNAME= gcc-2.7.2
+PKGNAME= pgcc-2.7.2-current
+CATEGORIES= lang
+MASTER_SITES= ${MASTER_SITE_GNU}
+
+# note this is an http site
+PATCH_SITES= http://www.nightflight.com/~pcg/data/
+PATCHFILES= gcc-2.7.2-961122.diff.gz
+
+MAINTAINER= andreas@klemm.gtn.com
+
+WRKSRC= ${WRKDIR}/${DISTNAME}
+PATCH_DIST_STRIP= -p1 -N -E
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${PREFIX} --with-gnu-as --with-gnu-ld pentium-freebsd
+MAN1= gcc.1 g++.1 cccp.1
+
+do-build:
+ cd ${WRKSRC} && ${MAKE} bootstrap
+
+do-install:
+ cd ${WRKSRC} && ${MAKE} install CC="stage2/xgcc -Bstage2/" CFLAGS="-pipe -O2"
+
+.include <bsd.port.mk>
diff --git a/lang/pgcc/distinfo b/lang/pgcc/distinfo
new file mode 100644
index 000000000000..2bab2825c6b1
--- /dev/null
+++ b/lang/pgcc/distinfo
@@ -0,0 +1,2 @@
+MD5 (gcc-2.7.2.tar.gz) = d32bb8fd2fc1d575a4f8b812ff77ec22
+MD5 (gcc-2.7.2-961122.diff.gz) = a09492319af6ea4974e032f1cb75de05
diff --git a/lang/pgcc/files/patch-aa b/lang/pgcc/files/patch-aa
new file mode 100644
index 000000000000..13097d723151
--- /dev/null
+++ b/lang/pgcc/files/patch-aa
@@ -0,0 +1,12 @@
+--- config/i386/freebsd.h.orig Tue Dec 17 22:43:42 1996
++++ config/i386/freebsd.h Tue Dec 17 22:44:35 1996
+@@ -21,7 +21,9 @@
+ Boston, MA 02111-1307, USA. */
+
+ /* This goes away when the math-emulator is fixed */
++#ifndef TARGET_CPU_DEFAULT
+ #define TARGET_CPU_DEFAULT 0400 /* TARGET_NO_FANCY_MATH_387 */
++#endif
+
+ /* This is tested by i386gas.h. */
+ #define YES_UNDERSCORES
diff --git a/lang/pgcc/files/patch-ab b/lang/pgcc/files/patch-ab
new file mode 100644
index 000000000000..32aa00bc552e
--- /dev/null
+++ b/lang/pgcc/files/patch-ab
@@ -0,0 +1,20 @@
+--- Makefile.in.orig Wed Dec 18 00:15:45 1996
++++ Makefile.in Wed Dec 18 00:24:31 1996
+@@ -53,7 +53,7 @@
+ # TCFLAGS is used for compilations with the GCC just built.
+ XCFLAGS =
+ TCFLAGS =
+-CFLAGS = -g
++CFLAGS = -pipe -O2
+ BOOT_CFLAGS = -O $(CFLAGS)
+ # These exists to be overridden by the x-* and t-* files, respectively.
+ X_CFLAGS =
+@@ -460,7 +460,7 @@
+ # Both . and srcdir are used, in that order,
+ # so that tm.h and config.h will be found in the compilation
+ # subdirectory rather than in the source directory.
+-INCLUDES = -I. -I$(srcdir) -I$(srcdir)/config
++INCLUDES = -I. -I$(srcdir) -I$(srcdir)/config -I$(srcdir)/cp/inc
+
+ # Always use -I$(srcdir)/config when compiling.
+ .c.o:
diff --git a/lang/pgcc/pkg-comment b/lang/pgcc/pkg-comment
new file mode 100644
index 000000000000..15dee678736a
--- /dev/null
+++ b/lang/pgcc/pkg-comment
@@ -0,0 +1 @@
+gcc optimized for INTEL Pentium CPU - Developer (alpha) Release
diff --git a/lang/pgcc/pkg-descr b/lang/pgcc/pkg-descr
new file mode 100644
index 000000000000..a95e4bc0ef7f
--- /dev/null
+++ b/lang/pgcc/pkg-descr
@@ -0,0 +1,24 @@
+ The Pentium Compiler GROUP
+
+Mail me at marc@cerebro.inka.de for anything concerning this FAQ.
+
+ What is the Pentium GCC Workgroup for?
+
+The PCG was created because all the patched GCC's are somewhat unstable
+(i.e. they cannot compile some programs) and somewhat insecure (they
+sometimes generate wrong code, although this goes unnoticed in many cases!).
+
+The PWG wants to
+
+ o improve the stability of the compiler
+ o enhance the quality of the generated code (better optimizations)
+ o get cygnus and/or gnu to include some optimizations in the
+ "official" GNU cc
+
+More Info:
+
+ http://www-iss.mach.uni-karlsruhe.de/pcg/
+
+--
+Andreas Klemm <andreas@klemm.gtn.com>
+ Wed Jan 31 00:55:04 MET 1996