aboutsummaryrefslogtreecommitdiff
path: root/lang/phantomjs/Makefile
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2016-09-17 14:37:36 +0000
committerMark Felder <feld@FreeBSD.org>2016-09-17 14:37:36 +0000
commit04fdb95cc85a084fc61db8023ecb892dfe275f09 (patch)
treef97e066256824c9f1201b1469524dc90ea7cbf3e /lang/phantomjs/Makefile
parent817329d3d04559de253198aa9e5271f3742d8694 (diff)
lang/phantomjs: Fix build on 9.3 and 11.0
- Take maintainership (maintainer timeouts previously) - Remove no-op patch - Remove work related to GCC build profiles as we enforce clang - Add patch to fix building with clang in 11.0 - Add hack to enforce CC and CXX for 9.3 Partway through the build the compiler was switching from clang++ to c++ which is GCC in base system. This was causing build failures. MFH: 2016Q3
Notes
Notes: svn path=/head/; revision=422327
Diffstat (limited to 'lang/phantomjs/Makefile')
-rw-r--r--lang/phantomjs/Makefile15
1 files changed, 9 insertions, 6 deletions
diff --git a/lang/phantomjs/Makefile b/lang/phantomjs/Makefile
index a12a5b3ebb22..c837ab1de13c 100644
--- a/lang/phantomjs/Makefile
+++ b/lang/phantomjs/Makefile
@@ -2,12 +2,12 @@
PORTNAME= phantomjs
PORTVERSION= 2.0.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= lang
MASTER_SITES= https://bitbucket.org/ariya/phantomjs/downloads/
DISTNAME= ${PORTNAME}-${PORTVERSION}-source
-MAINTAINER= kuriyama@FreeBSD.org
+MAINTAINER= feld@FreeBSD.org
COMMENT= Minimalistic, headless, WebKit-based, JavaScript-driven tool
LICENSE= BSD3CLAUSE
@@ -29,16 +29,19 @@ PLIST_FILES= bin/phantomjs
#PATCH_DEBUG= yes
NO_CCACHE= yes
+USE_XORG= x11
+
+# Hack for FreeBSD 9. Without it mysteriously switches from
+# clang++ to c++ which ends in build failure.
+CC=clang
+CXX=clang++
+
# NOTE:
# build.sh --qtwebkit=system requires Qt 5.3.x. We cannot use it.
# qmake.conf detection is in src/qt/qtbase/configure script.
SPEC= ${WRKSRC}/src/qt/qtbase/mkspecs
post-extract:
- cd ${SPEC} && ${CP} -r freebsd-g++46 freebsd-g++48
- cd ${SPEC} && ${CP} -r freebsd-g++46 freebsd-g++49
- cd ${SPEC} && ${REINPLACE_CMD} -e 's|46|48|' freebsd-g++48/qmake.conf
- cd ${SPEC} && ${REINPLACE_CMD} -e 's|46|49|' freebsd-g++49/qmake.conf
${MKDIR} ${SPEC}/freebsd-clang
cd ${SPEC} && ${SED} -e 's|\.\./\.\./|../|g' unsupported/freebsd-clang/qmake.conf > freebsd-clang/qmake.conf
cd ${SPEC} && ${SED} -e 's|\.\./\.\./|../|g' unsupported/freebsd-clang/qplatformdefs.h > freebsd-clang/qplatformdefs.h