aboutsummaryrefslogtreecommitdiff
path: root/lang/phantomjs/Makefile
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2015-04-16 15:39:43 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2015-04-16 15:39:43 +0000
commitaf663bd3f23956b31e732b9fef5dc3e0d1485fb7 (patch)
treee78d035a49b881a742558e1d2b7f6eaf6250c806 /lang/phantomjs/Makefile
parente78a6af418454e5f2809c9d0b079121007faf156 (diff)
Fix build with GCC on recent head kernel by disabling PCH for GCC
With hat: portmgr
Notes
Notes: svn path=/head/; revision=384116
Diffstat (limited to 'lang/phantomjs/Makefile')
-rw-r--r--lang/phantomjs/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/lang/phantomjs/Makefile b/lang/phantomjs/Makefile
index a3595fae0f34..46c3e68c5a89 100644
--- a/lang/phantomjs/Makefile
+++ b/lang/phantomjs/Makefile
@@ -25,7 +25,8 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
PLIST_FILES= bin/phantomjs
do-build:
- cd ${WRKSRC} && ${SETENV} CC=${CC} CXX=${CXX} OSTYPE=freebsd MAKEFLAGS= PATH=${PATH} bash -x build.sh --jobs ${MAKE_JOBS_NUMBER} --confirm
+ cd ${WRKSRC} && ${SETENV} CC=${CC} CXX=${CXX} OSTYPE=freebsd MAKEFLAGS= PATH=${PATH} bash -x build.sh --jobs ${MAKE_JOBS_NUMBER} --confirm \
+ --qt-config '-no-pch'
do-install:
cd ${WRKSRC} && ${INSTALL_PROGRAM} bin/phantomjs ${STAGEDIR}${PREFIX}/bin/