aboutsummaryrefslogtreecommitdiff
path: root/lang/php4/Makefile
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2003-12-14 11:04:50 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2003-12-14 11:04:50 +0000
commita095f28ad048bea3c93f6900fc9d0ef2c3105a51 (patch)
tree21887ebd0b683d8d6fc35b48685e99f8a61ff1aa /lang/php4/Makefile
parentbc6d44c89501b677909068d824816cf4f93adcde (diff)
Notes
Diffstat (limited to 'lang/php4/Makefile')
-rw-r--r--lang/php4/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/lang/php4/Makefile b/lang/php4/Makefile
index 2f24f3ebeb92..c66d937b6112 100644
--- a/lang/php4/Makefile
+++ b/lang/php4/Makefile
@@ -21,7 +21,7 @@
PORTNAME= php4
PORTVERSION= 4.3.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES?= lang devel www
MASTER_SITES= http://www.php.net/distributions/:release \
http://it.php.net/distributions/:release \
@@ -48,7 +48,7 @@ DISTNAME= php-${PORTVERSION:S/.r/RC/}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:release
MAINTAINER?= sysadmin@alexdupre.com
-COMMENT= PHP Scripting Language (Apache Module and CLI)
+COMMENT?= PHP Scripting Language (Apache Module and CLI)
.if defined(WITHOUT_APACHE)
.if defined(WITHOUT_CLI)
COMMENT= PHP Common Gateway Interface
@@ -178,6 +178,12 @@ SCRIPTS_ENV+= SEL_OPTIONS="${SEL_OPTIONS}" \
.include "${WRKDIR}/Makefile.inc"
.endif
+.if !defined(WITHOUT_CLI) && !defined(WITHOUT_PEAR)
+WITH_PCRE= yes
+WITH_XML= yes
+WITH_XMLRPC= yes
+.endif
+
.if defined(WITH_CDB) || defined(WITH_DB4) || defined(WITH_GDBM) || defined(WITH_INIFILE)
WITH_DBA= yes
.endif