aboutsummaryrefslogtreecommitdiff
path: root/lang/php4
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2005-06-14 20:38:26 +0000
committerAlex Dupre <ale@FreeBSD.org>2005-06-14 20:38:26 +0000
commit4107b871cac107a1e42b4411664be22e8a2ea6da (patch)
tree4dd818d445b7a6de71bdc2379ada5eec533e2c10 /lang/php4
parente2cce2e62c890fbb09c73c1fb12d86da219dfa75 (diff)
downloadports-4107b871cac107a1e42b4411664be22e8a2ea6da.tar.gz
ports-4107b871cac107a1e42b4411664be22e8a2ea6da.zip
Notes
Diffstat (limited to 'lang/php4')
-rw-r--r--lang/php4/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/lang/php4/Makefile b/lang/php4/Makefile
index a186ceed8e68..8c567b270463 100644
--- a/lang/php4/Makefile
+++ b/lang/php4/Makefile
@@ -71,6 +71,7 @@ OPTIONS= REDIRECT "Enable force-cgi-redirect support" off \
OPTIONS= APACHE2 "Use apache 2.x instead of apache 1.3.x" off
.endif
OPTIONS+= DEBUG "Enable debug" off \
+ MULTIBYTE "Enable zend multibyte support" off \
IPV6 "Enable ipv6 support" on \
OPENSSL "Build static OpenSSL extension" off
@@ -144,6 +145,10 @@ CONFIGURE_ARGS+=--enable-debug
EXT_DIR:= ${EXT_DIR}-debug
.endif
+.if defined(WITH_MULTIBYTE)
+CONFIGURE_ARGS+=--enable-zend-multibyte
+.endif
+
PLIST_SUB+= SAPI_FILE=${SAPI_FILE}
.if ${OSVERSION} < 400014 || defined(WITHOUT_IPV6)