aboutsummaryrefslogtreecommitdiff
path: root/lang/php4
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2004-01-10 16:53:01 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2004-01-10 16:53:01 +0000
commit4668c3f6c0230cc48e19c9148aec5325d3586fb1 (patch)
treeda1894a053e9b7827e193f86fd4c63a5aa811a6f /lang/php4
parentde6276d033d2821eea6e4328cc65a1b8bac1c780 (diff)
downloadports-4668c3f6c0230cc48e19c9148aec5325d3586fb1.tar.gz
ports-4668c3f6c0230cc48e19c9148aec5325d3586fb1.zip
Notes
Diffstat (limited to 'lang/php4')
-rw-r--r--lang/php4/Makefile16
-rw-r--r--lang/php4/bsd.php.mk19
-rw-r--r--lang/php4/pkg-plist2
3 files changed, 26 insertions, 11 deletions
diff --git a/lang/php4/Makefile b/lang/php4/Makefile
index 1bcf7022e9d2..507ff908739c 100644
--- a/lang/php4/Makefile
+++ b/lang/php4/Makefile
@@ -87,11 +87,6 @@ CONFIGURE_ARGS+=--with-regex=apache
EXT_DIR= 20020429
SAPI_FILE= "@comment "
-.if defined(WITH_DEBUG)
-CONFIGURE_ARGS+=--enable-debug
-EXT_DIR:= ${EXT_DIR}-debug
-.endif
-
CONFLICTS= php4-cli-4* mod_php4-4* php4-cgi-4*
.if defined(WITHOUT_APACHE)
.if defined(WITHOUT_CLI)
@@ -535,11 +530,16 @@ CONFIGURE_ARGS+=--with-zlib=yes
.if !defined(WITHOUT_APACHE)
.if exists(${LOCALBASE}/include/apache2/apr.h)
WITH_APACHE2= yes
+APACHE_MPM!= ${APXS} -q MPM_NAME
.endif
.if defined(WITH_APACHE2)
+APACHE_MPM?= ${WITH_MPM}
APACHE_PORT?= www/apache2
CONFIGURE_ARGS+=--with-apxs2=${APXS}
SAPI_FILE= libexec/apache2/libphp4.so
+.if ${APACHE_MPM} == "worker"
+EXT_DIR:= ${EXT_DIR}-zts
+.endif
.else
APACHE_PORT?= www/apache13
CONFIGURE_ARGS+=--with-apxs=${APXS}
@@ -549,6 +549,11 @@ BUILD_DEPENDS+= ${APXS}:${PORTSDIR}/${APACHE_PORT}
RUN_DEPENDS+= ${APXS}:${PORTSDIR}/${APACHE_PORT}
.endif
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+=--enable-debug
+EXT_DIR:= ${EXT_DIR}-debug
+.endif
+
PLIST_SUB+= SAPI_FILE=${SAPI_FILE} \
EXT_DIR=${EXT_DIR}
@@ -675,7 +680,6 @@ post-install:
@${INSTALL_DATA} ${WRKSRC}/php.ini-dist ${PREFIX}/etc
@${INSTALL_DATA} ${WRKSRC}/php.ini-recommended ${PREFIX}/etc
@${INSTALL_DATA} ${WRKDIR}/php.conf ${PREFIX}/etc
- @${TOUCH} ${PREFIX}/lib/php/${EXT_DIR}/.php
.if !defined(WITHOUT_APACHE)
@${ECHO_CMD} "*****************************************************************************"
@${ECHO_CMD} ""
diff --git a/lang/php4/bsd.php.mk b/lang/php4/bsd.php.mk
index 1d3f971c0dce..aa7181b105ec 100644
--- a/lang/php4/bsd.php.mk
+++ b/lang/php4/bsd.php.mk
@@ -18,10 +18,21 @@
.endif
PHP_VER?= 4
-.if !defined(WITH_DEBUG)
-PHP_EXT_DIR?= 20020429
+.if !defined(PHP_EXT_DIR)
+PHP_EXT_DIR= 20020429
+.if exists(${LOCALBASE}/include/apache2/apr.h)
+APACHE_MPM!= ${APXS} -q MPM_NAME
+.if ${APACHE_MPM} == "worker"
+PHP_EXT_DIR:= ${PHP_EXT_DIR}-zts
+.endif
.else
-PHP_EXT_DIR?= 20020429-debug
+.if defined(WITH_APACHE2) && defined(WITH_MPM) && ${WITH_MPM} == "worker"
+PHP_EXT_DIR:= ${PHP_EXT_DIR}-zts
+.endif
+.endif
+.if defined(WITH_DEBUG)
+PHP_EXT_DIR:= ${PHP_EXT_DIR}-debug
+.endif
.endif
.if !defined(WITHOUT_PEAR)
PHP_PEAR?= yes
@@ -32,7 +43,7 @@ PHP_SAPI?= ""
.if defined(BROKEN_WITH_PHP)
. for VER in ${BROKEN_WITH_PHP}
-. if (${PHP_VER} == "${VER}")
+. if ${PHP_VER} == "${VER}"
BROKEN= "Doesn't work with PHP version : ${PHP_VER} (Doesn't support PHP ${BROKEN_WITH_PHP})"
. endif
. endfor
diff --git a/lang/php4/pkg-plist b/lang/php4/pkg-plist
index 9c99cdb71ce2..9cce21b9950b 100644
--- a/lang/php4/pkg-plist
+++ b/lang/php4/pkg-plist
@@ -193,7 +193,6 @@ include/php/regex/regex.h
include/php/regex/regex2.h
include/php/regex/regex_extra.h
include/php/regex/utils.h
-lib/php/%%EXT_DIR%%/.php
lib/php/build/Makefile.global
lib/php/build/acinclude.m4
lib/php/build/mkdep.awk
@@ -242,6 +241,7 @@ lib/php/build/shtool
@dirrm include/php/main
@dirrm include/php/regex
@dirrm include/php/
+@exec mkdir %D/lib/php/%%EXT_DIR%%
@unexec rmdir %D/lib/php/%%EXT_DIR%% 2> /dev/null || true
@dirrm lib/php/build
@unexec rmdir %D/lib/php 2> /dev/null || true