aboutsummaryrefslogtreecommitdiff
path: root/lang/php4
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2005-12-09 19:36:40 +0000
committerAlex Dupre <ale@FreeBSD.org>2005-12-09 19:36:40 +0000
commit0f8717ab0455f549c551844ecb1930beeb45d437 (patch)
tree6f41ad24d60d9b0ed04378718710535a52cab1ec /lang/php4
parent4e3717ee4f0ddc854af6193ae45f72c6664750bc (diff)
downloadports-0f8717ab0455f549c551844ecb1930beeb45d437.tar.gz
ports-0f8717ab0455f549c551844ecb1930beeb45d437.zip
Notes
Diffstat (limited to 'lang/php4')
-rw-r--r--lang/php4/Makefile51
-rw-r--r--lang/php4/Makefile.pear36
-rw-r--r--lang/php4/distinfo1
-rw-r--r--lang/php4/files/patch-pear::Makefile.frag35
-rw-r--r--lang/php4/files/patch-pear::scripts::pearcmd.php21
-rw-r--r--lang/php4/pkg-message.pear8
-rw-r--r--lang/php4/pkg-plist8
-rw-r--r--lang/php4/pkg-plist.pear70
8 files changed, 14 insertions, 216 deletions
diff --git a/lang/php4/Makefile b/lang/php4/Makefile
index 8abd4e26b7cd..896d54810ec8 100644
--- a/lang/php4/Makefile
+++ b/lang/php4/Makefile
@@ -24,7 +24,6 @@ LATEST_LINK= ${PKGNAMEPREFIX}${PORTNAME}${PKGNAMESUFFIX}
USE_BZIP2= yes
.if !defined(PKGNAMESUFFIX) || ${PKGNAMESUFFIX} == "-cgi" || ${PKGNAMESUFFIX} == "-cli"
GNU_CONFIGURE= yes
-USE_BISON= yes
USE_REINPLACE= yes
CONFIGURE_ARGS= --enable-versioning \
@@ -59,7 +58,9 @@ WITH_APACHE= yes
.if defined(WITH_APACHE)
PKGMESSAGE= ${PKGDIR}/pkg-message.mod
-APACHE_COMPAT= yes
+USE_APACHE= 1.3+
+MODULENAME= lib${PORTNAME}
+SHORTMODNAME= ${PORTNAME}
.endif
.if ${PHP_SAPI} == "cgi"
@@ -68,20 +69,11 @@ OPTIONS= REDIRECT "Enable force-cgi-redirect support" off \
FASTCGI "Enable fastcgi support" off \
PATHINFO "Enable path-info-check support" on
.endif
-.if defined(WITH_APACHE)
-.if defined(WITH_APACHE2)
-OPTIONS= APACHE2 "Use apache 2.x instead of apache 1.3.x" on
-.else
-OPTIONS= APACHE2 "Use apache 2.x instead of apache 1.3.x" off
-.endif
-.endif
OPTIONS+= DEBUG "Enable debug" off \
MULTIBYTE "Enable zend multibyte support" off \
IPV6 "Enable ipv6 support" on \
OPENSSL "Build static OpenSSL extension" off
-EXT_DIR= 20020429
-
CONFLICTS?= php4-cli-4* mod_php4-4* php4-cgi-4*
CONFLICTS+= php5-5* php5-cli-5* mod_php5-5* php5-cgi-5*
@@ -90,11 +82,13 @@ CONFIGURE_ARGS+=--disable-cli
.endif
MAN1= php-config.1 phpize.1
-.if ${PHP_SAPI} == "full" || ${PHP_SAPI} == "cli"
-PLIST_SUB+= CLI=""
+.if ${PHP_SAPI} != "mod"
+PLIST_SUB+= CLICGI=""
+.if ${PHP_SAPI} != "cgi"
MAN1+= php.1
+.endif
.else
-PLIST_SUB+= CLI="@comment "
+PLIST_SUB+= CLICGI="@comment "
.endif
.if defined(WITH_APACHE)
@@ -105,11 +99,6 @@ PLIST_SUB+= APACHE="@comment "
.if ${PHP_SAPI} == "cli"
CONFIGURE_ARGS+=--disable-cgi
-SAPI_FILE= "@comment "
-.endif
-
-.if ${PHP_SAPI} == "cgi"
-SAPI_FILE= bin/php
.endif
.include <bsd.port.pre.mk>
@@ -125,38 +114,21 @@ LDFLAGS+= -L${OPENSSLLIB} -lcrypto -lssl
.endif
.if defined(WITH_APACHE)
-.if exists(${LOCALBASE}/include/apache2/httpd.h)
-WITH_APACHE2= yes
-APACHE_MPM!= ${APXS} -q MPM_NAME
-.endif
-.if defined(WITH_APACHE2)
-APACHE_MPM?= ${WITH_MPM}
-APACHE_PORT= www/apache20
+.if ${APACHE_VERSION} > 13
CONFIGURE_ARGS+=--with-apxs2=${APXS}
-SAPI_FILE= libexec/apache2/libphp4.so
-.if ${APACHE_MPM} == "worker"
-EXT_DIR:= ${EXT_DIR}-zts
-.endif
.else
-APACHE_PORT?= www/apache13
CONFIGURE_ARGS+=--with-apxs=${APXS}
-SAPI_FILE= libexec/apache/libphp4.so
.endif
-BUILD_DEPENDS+= ${APXS}:${PORTSDIR}/${APACHE_PORT}
-RUN_DEPENDS+= ${APXS}:${PORTSDIR}/${APACHE_PORT}
.endif
.if defined(WITH_DEBUG)
CONFIGURE_ARGS+=--enable-debug
-EXT_DIR:= ${EXT_DIR}-debug
.endif
.if defined(WITH_MULTIBYTE)
CONFIGURE_ARGS+=--enable-zend-multibyte
.endif
-PLIST_SUB+= SAPI_FILE=${SAPI_FILE}
-
.if ${OSVERSION} < 400014 || defined(WITHOUT_IPV6)
CONFIGURE_ARGS+=--disable-ipv6
.endif
@@ -198,7 +170,6 @@ pre-configure:
post-build:
@${ECHO_CMD} "PHP_VER=4" > ${WRKDIR}/php.conf
@${ECHO_CMD} "PHP_VERSION=${PORTVERSION}" >> ${WRKDIR}/php.conf
- @${ECHO_CMD} "PHP_EXT_DIR=${EXT_DIR}" >> ${WRKDIR}/php.conf
@${ECHO_CMD} "PHP_PORT=\$${PORTSDIR}/${PHP_PORT}" >> ${WRKDIR}/php.conf
@${ECHO_CMD} "PHP_SAPI=${PHP_SAPI}" >> ${WRKDIR}/php.conf
.if defined(WITH_OPENSSL)
@@ -215,10 +186,6 @@ post-install:
.endif
.else
-.if ${PKGNAMESUFFIX} == "-pear"
-.include "${MASTERDIR}/Makefile.pear"
-.else
.include "${MASTERDIR}/Makefile.ext"
.endif
-.endif
.include <bsd.port.post.mk>
diff --git a/lang/php4/Makefile.pear b/lang/php4/Makefile.pear
deleted file mode 100644
index f4480e1d0936..000000000000
--- a/lang/php4/Makefile.pear
+++ /dev/null
@@ -1,36 +0,0 @@
-PORTREVISION= 1
-
-LIB_DEPENDS+= expat.5:${PORTSDIR}/textproc/expat2
-
-GNU_CONFIGURE= yes
-
-CONFIGURE_ARGS= --with-layout=GNU \
- --disable-cgi \
- --disable-all \
- --with-pcre-regex=yes \
- --enable-xml \
- --with-expat-dir=${LOCALBASE} \
- --with-zlib-dir=/usr \
- --with-pear
-
-NO_BUILD= yes
-
-INSTALL_TARGET= install-pear
-
-USE_PHP= pcre xml
-WANT_PHP_SCR= yes
-DEFAULT_PHP_VER=4
-BROKEN_WITH_PHP=5
-
-.include <bsd.port.pre.mk>
-
-post-patch:
- @${SED} "s|%%PREFIX%%|${PREFIX}|g" \
- ${WRKSRC}/pear/scripts/pearcmd.php > ${WRKSRC}/pear/scripts/pear
-
-post-install:
- @${INSTALL_SCRIPT} ${WRKSRC}/pear/scripts/pear ${PREFIX}/bin
- @${MKDIR} ${PREFIX}/lib/php/pear/.registry
- @${TOUCH} ${PREFIX}/lib/php/pear/.filemap
- @${TOUCH} ${PREFIX}/lib/php/pear/.lock
- @${SED} "s|\$${LOCALBASE}|${LOCALBASE}|g;s|\$${PREFIX}|${PREFIX}|g" < ${PKGMESSAGE}
diff --git a/lang/php4/distinfo b/lang/php4/distinfo
index c87c050c363c..be246decd081 100644
--- a/lang/php4/distinfo
+++ b/lang/php4/distinfo
@@ -1,2 +1,3 @@
MD5 (php-4.4.1.tar.bz2) = 6b5726471189f8a1f26dd7cc5e19b442
+SHA256 (php-4.4.1.tar.bz2) = c3010a85089bd464d5bbdda63dd253e0cf779db9670accf1ea5355de7ba448f8
SIZE (php-4.4.1.tar.bz2) = 4157749
diff --git a/lang/php4/files/patch-pear::Makefile.frag b/lang/php4/files/patch-pear::Makefile.frag
deleted file mode 100644
index 41b525b28a7c..000000000000
--- a/lang/php4/files/patch-pear::Makefile.frag
+++ /dev/null
@@ -1,35 +0,0 @@
---- pear/Makefile.frag.orig Tue Sep 2 03:30:13 2003
-+++ pear/Makefile.frag Thu Apr 22 23:52:40 2004
-@@ -1,6 +1,7 @@
- # -*- makefile -*-
-
- peardir=$(PEAR_INSTALLDIR)
-+XML_RPC_ver=1.4.0
-
- # Skip all php.ini files altogether
- PEAR_INSTALL_FLAGS = -n -dshort_open_tag=0 -dsafe_mode=0
-@@ -13,10 +14,18 @@
-
- install-pear:
- @echo "Installing PEAR environment: $(INSTALL_ROOT)$(peardir)/"
-- @if $(mkinstalldirs) $(INSTALL_ROOT)$(peardir); then \
-- $(MAKE) -s install-pear-installer install-pear-packages; \
-- else \
-- cat $(srcdir)/install-pear.txt; \
-- exit 5; \
-- fi
-+ @$(mkinstalldirs) $(INSTALL_ROOT)$(peardir)/bootstrap \
-+ $(INSTALL_ROOT)$(peardir)/bootstrap/Archive \
-+ $(INSTALL_ROOT)$(peardir)/bootstrap/Console \
-+ $(INSTALL_ROOT)$(peardir)/bootstrap/XML \
-+ $(INSTALL_ROOT)$(peardir)/bootstrap/XML/RPC
-+ @cp $(srcdir)/PEAR.php $(srcdir)/System.php \
-+ $(INSTALL_ROOT)$(peardir)/bootstrap
-+ @cp $(srcdir)/Archive/*.php $(INSTALL_ROOT)$(peardir)/bootstrap/Archive
-+ @cp $(srcdir)/Console/*.php $(INSTALL_ROOT)$(peardir)/bootstrap/Console
-+ @cp -R $(srcdir)/OS $(INSTALL_ROOT)$(peardir)/bootstrap
-+ @cp -R $(srcdir)/PEAR $(INSTALL_ROOT)$(peardir)/bootstrap
-+ @tar xf $(srcdir)/packages/XML_RPC-$(XML_RPC_ver).tar
-+ @cp XML_RPC-$(XML_RPC_ver)/RPC.php $(INSTALL_ROOT)$(peardir)/bootstrap/XML
-+ @cp XML_RPC-$(XML_RPC_ver)/Server.php $(INSTALL_ROOT)$(peardir)/bootstrap/XML/RPC
-
diff --git a/lang/php4/files/patch-pear::scripts::pearcmd.php b/lang/php4/files/patch-pear::scripts::pearcmd.php
deleted file mode 100644
index b3b74f72f147..000000000000
--- a/lang/php4/files/patch-pear::scripts::pearcmd.php
+++ /dev/null
@@ -1,21 +0,0 @@
---- pear/scripts/pearcmd.php.orig Mon Mar 28 18:57:01 2005
-+++ pear/scripts/pearcmd.php Tue Nov 15 23:25:55 2005
-@@ -1,3 +1,4 @@
-+#!%%PREFIX%%/bin/php -nq
- <?php
- //
- // +----------------------------------------------------------------------+
-@@ -24,9 +25,10 @@
- /**
- * @nodep Gtk
- */
--if ('@include_path@' != '@'.'include_path'.'@') {
-- ini_set('include_path', '@include_path@');
--}
-+dl('pcre.so');
-+dl('xml.so');
-+ini_set('include_path', '%%PREFIX%%/share/pear:%%PREFIX%%/share/pear/bootstrap');
-+ini_set('memory_limit', '16M');
- ini_set('allow_url_fopen', true);
- if (!ini_get('safe_mode')) {
- @set_time_limit(0);
diff --git a/lang/php4/pkg-message.pear b/lang/php4/pkg-message.pear
deleted file mode 100644
index 53827dba00cc..000000000000
--- a/lang/php4/pkg-message.pear
+++ /dev/null
@@ -1,8 +0,0 @@
-*********************************************************
-
-To use PEAR you have to add the correct include path into
-your ${LOCALBASE}/etc/php.ini configuration file, like:
-
-include_path = ".:${PREFIX}/share/pear"
-
-*********************************************************
diff --git a/lang/php4/pkg-plist b/lang/php4/pkg-plist
index e1f1a33724c3..754571e14918 100644
--- a/lang/php4/pkg-plist
+++ b/lang/php4/pkg-plist
@@ -1,4 +1,4 @@
-%%CLI%%bin/php
+%%CLICGI%%bin/php
bin/php-config
bin/phpize
etc/php.conf
@@ -166,9 +166,9 @@ lib/php/build/mkdep.awk
lib/php/build/phpize.m4
lib/php/build/scan_makefile_in.awk
lib/php/build/shtool
-%%SAPI_FILE%%
-%%APACHE%%@exec %D/sbin/apxs -e -a -n php4 %f
-%%APACHE%%@unexec %D/sbin/apxs -e -A -n php4 %f
+%%APACHE%%%%APACHEMODDIR%%/%%AP_MODULE%%
+%%APACHE%%@exec %D/sbin/apxs -e -a -n %%AP_NAME%% %f
+%%APACHE%%@unexec %D/sbin/apxs -e -A -n %%AP_NAME%% %f
@dirrm include/php/TSRM
@dirrm include/php/Zend
@dirrm include/php/ext/standard
diff --git a/lang/php4/pkg-plist.pear b/lang/php4/pkg-plist.pear
deleted file mode 100644
index 17253c65649a..000000000000
--- a/lang/php4/pkg-plist.pear
+++ /dev/null
@@ -1,70 +0,0 @@
-bin/pear
-@exec mkdir -p %D/lib/php/pear/.channels/.alias
-@exec mkdir -p %D/lib/php/pear/.registry/.channel.__uri
-@exec mkdir -p %D/lib/php/pear/.registry/.channel.pecl.php.net
-@exec touch %D/lib/php/pear/.channels/.alias/pear.txt
-@exec touch %D/lib/php/pear/.channels/.alias/pecl.txt
-@exec touch %D/lib/php/pear/.channels/__uri.reg
-@exec touch %D/lib/php/pear/.channels/pear.php.net.reg
-@exec touch %D/lib/php/pear/.channels/pecl.php.net.reg
-@exec touch %D/lib/php/pear/.depdb
-@exec touch %D/lib/php/pear/.depdblock
-@exec touch %D/lib/php/pear/.filemap
-@exec touch %D/lib/php/pear/.lock
-share/pear/bootstrap/Archive/Tar.php
-share/pear/bootstrap/PEAR.php
-share/pear/bootstrap/System.php
-share/pear/bootstrap/Console/Getopt.php
-share/pear/bootstrap/OS/Guess.php
-share/pear/bootstrap/PEAR/Autoloader.php
-share/pear/bootstrap/PEAR/Builder.php
-share/pear/bootstrap/PEAR/Command.php
-share/pear/bootstrap/PEAR/Command/Auth.php
-share/pear/bootstrap/PEAR/Command/Build.php
-share/pear/bootstrap/PEAR/Command/Common.php
-share/pear/bootstrap/PEAR/Command/Config.php
-share/pear/bootstrap/PEAR/Command/Install.php
-share/pear/bootstrap/PEAR/Command/Mirror.php
-share/pear/bootstrap/PEAR/Command/Package.php
-share/pear/bootstrap/PEAR/Command/Registry.php
-share/pear/bootstrap/PEAR/Command/Remote.php
-share/pear/bootstrap/PEAR/Common.php
-share/pear/bootstrap/PEAR/Config.php
-share/pear/bootstrap/PEAR/Dependency.php
-share/pear/bootstrap/PEAR/Downloader.php
-share/pear/bootstrap/PEAR/ErrorStack.php
-share/pear/bootstrap/PEAR/Exception.php
-share/pear/bootstrap/PEAR/Frontend/CLI.php
-share/pear/bootstrap/PEAR/Installer.php
-share/pear/bootstrap/PEAR/Packager.php
-share/pear/bootstrap/PEAR/Registry.php
-share/pear/bootstrap/PEAR/Remote.php
-share/pear/bootstrap/PEAR/RunTest.php
-share/pear/bootstrap/XML/RPC.php
-share/pear/bootstrap/XML/RPC/Server.php
-@unexec rm %D/lib/php/pear/.channels/.alias/pear.txt 2> /dev/null || true
-@unexec rm %D/lib/php/pear/.channels/.alias/pecl.txt 2> /dev/null || true
-@unexec rm %D/lib/php/pear/.channels/__uri.reg 2> /dev/null || true
-@unexec rm %D/lib/php/pear/.channels/pear.php.net.reg 2> /dev/null || true
-@unexec rm %D/lib/php/pear/.channels/pecl.php.net.reg 2> /dev/null || true
-@unexec rm %D/lib/php/pear/.depdb 2> /dev/null || true
-@unexec rm %D/lib/php/pear/.depdblock 2> /dev/null || true
-@unexec rm %D/lib/php/pear/.filemap 2> /dev/null || true
-@unexec rm %D/lib/php/pear/.lock 2> /dev/null || true
-@unexec rmdir %D/lib/php/pear/.channels/.alias 2> /dev/null || true
-@unexec rmdir %D/lib/php/pear/.channels 2> /dev/null || true
-@unexec rmdir %D/lib/php/pear/.registry/.channel.__uri 2> /dev/null || true
-@unexec rmdir %D/lib/php/pear/.registry/.channel.pecl.php.net 2> /dev/null || true
-@unexec rmdir %D/lib/php/pear/.registry 2> /dev/null || true
-@unexec rmdir %D/lib/php/pear 2> /dev/null || true
-@unexec rmdir %D/lib/php 2> /dev/null || true
-@dirrm share/pear/bootstrap/Archive
-@dirrm share/pear/bootstrap/Console
-@dirrm share/pear/bootstrap/OS
-@dirrm share/pear/bootstrap/PEAR/Command
-@dirrm share/pear/bootstrap/PEAR/Frontend
-@dirrm share/pear/bootstrap/PEAR
-@dirrm share/pear/bootstrap/XML/RPC
-@dirrm share/pear/bootstrap/XML
-@dirrm share/pear/bootstrap
-@unexec rmdir %D/share/pear 2> /dev/null || true