aboutsummaryrefslogtreecommitdiff
path: root/lang/php4
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2004-04-16 07:44:34 +0000
committerAlex Dupre <ale@FreeBSD.org>2004-04-16 07:44:34 +0000
commit02020776c8aeba9b80382f3e2ba426bb7f20da4e (patch)
tree9df7b007e01147f2cc38bc16a823cb875efd5912 /lang/php4
parentd0624ee2f241d417e3c7c3c6a5960532b4422a4a (diff)
downloadports-02020776c8aeba9b80382f3e2ba426bb7f20da4e.tar.gz
ports-02020776c8aeba9b80382f3e2ba426bb7f20da4e.zip
Notes
Diffstat (limited to 'lang/php4')
-rw-r--r--lang/php4/Makefile3
-rw-r--r--lang/php4/distinfo4
-rw-r--r--lang/php4/files/patch-ext::pcre::php_pcre.c44
3 files changed, 47 insertions, 4 deletions
diff --git a/lang/php4/Makefile b/lang/php4/Makefile
index 06f4a9cf35b1..4a47600a5c5f 100644
--- a/lang/php4/Makefile
+++ b/lang/php4/Makefile
@@ -20,8 +20,7 @@
#
PORTNAME= php4
-PORTVERSION= 4.3.5
-PORTREVISION= 7
+PORTVERSION= 4.3.6
CATEGORIES?= lang devel www
MASTER_SITES= http://www.php.net/distributions/:release \
http://it.php.net/distributions/:release \
diff --git a/lang/php4/distinfo b/lang/php4/distinfo
index 233516635d31..0cd6ea768bc7 100644
--- a/lang/php4/distinfo
+++ b/lang/php4/distinfo
@@ -1,2 +1,2 @@
-MD5 (php-4.3.5.tar.bz2) = 29e61c125ac6278897c6c219f5d100d1
-SIZE (php-4.3.5.tar.bz2) = 3947414
+MD5 (php-4.3.6.tar.bz2) = 79cde484e31871176137eb78014657fa
+SIZE (php-4.3.6.tar.bz2) = 3957796
diff --git a/lang/php4/files/patch-ext::pcre::php_pcre.c b/lang/php4/files/patch-ext::pcre::php_pcre.c
new file mode 100644
index 000000000000..c9efc2e0d480
--- /dev/null
+++ b/lang/php4/files/patch-ext::pcre::php_pcre.c
@@ -0,0 +1,44 @@
+--- ext/pcre/php_pcre.c.orig Fri Apr 16 09:21:14 2004
++++ ext/pcre/php_pcre.c Fri Apr 16 09:23:36 2004
+@@ -106,15 +106,6 @@
+ REGISTER_LONG_CONSTANT("PREG_SPLIT_DELIM_CAPTURE", PREG_SPLIT_DELIM_CAPTURE, CONST_CS | CONST_PERSISTENT);
+ REGISTER_LONG_CONSTANT("PREG_SPLIT_OFFSET_CAPTURE", PREG_SPLIT_OFFSET_CAPTURE, CONST_CS | CONST_PERSISTENT);
+ REGISTER_LONG_CONSTANT("PREG_GREP_INVERT", PREG_GREP_INVERT, CONST_CS | CONST_PERSISTENT);
+-
+- pcre_malloc = php_pcre_malloc;
+- pcre_free = php_pcre_free;
+-
+-#ifdef NO_RECURSE
+- pcre_stack_malloc = php_pcre_malloc;
+- pcre_stack_free = php_pcre_free;
+-#endif
+-
+ return SUCCESS;
+ }
+ /* }}} */
+@@ -130,6 +121,16 @@
+ }
+ /* }}} */
+
++/* {{{ PHP_RINIT_FUNCTION(pcre) */
++static PHP_RINIT_FUNCTION(pcre)
++{
++ pcre_malloc = php_pcre_malloc;
++ pcre_free = php_pcre_free;
++
++ return SUCCESS;
++}
++/* }}} */
++
+ /* {{{ pcre_get_compiled_regex
+ */
+ PHPAPI pcre* pcre_get_compiled_regex(char *regex, pcre_extra **extra, int *preg_options) {
+@@ -1527,7 +1528,7 @@
+ pcre_functions,
+ PHP_MINIT(pcre),
+ PHP_MSHUTDOWN(pcre),
+- NULL,
++ PHP_RINIT(pcre),
+ NULL,
+ PHP_MINFO(pcre),
+ NO_VERSION_YET,