aboutsummaryrefslogtreecommitdiff
path: root/lang/php4
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2006-01-16 09:40:31 +0000
committerAlex Dupre <ale@FreeBSD.org>2006-01-16 09:40:31 +0000
commit9eb17499b378fdff1481a9337d4aa9ab7fe76e26 (patch)
tree606ec464e7d2f5097a07fb1fe401c8f67fa02c74 /lang/php4
parentd844b3df99008bd06dac428e3e1d2f4d304b40a2 (diff)
downloadports-9eb17499b378fdff1481a9337d4aa9ab7fe76e26.tar.gz
ports-9eb17499b378fdff1481a9337d4aa9ab7fe76e26.zip
Notes
Diffstat (limited to 'lang/php4')
-rw-r--r--lang/php4/Makefile4
-rw-r--r--lang/php4/Makefile.ext5
-rw-r--r--lang/php4/distinfo6
-rw-r--r--lang/php4/files/patch-ext_standard_basic_functions.c13
-rw-r--r--lang/php4/files/patch-sapi_apache2handler_sapi_apache2.c118
5 files changed, 10 insertions, 136 deletions
diff --git a/lang/php4/Makefile b/lang/php4/Makefile
index 896d54810ec8..1f887a5f015c 100644
--- a/lang/php4/Makefile
+++ b/lang/php4/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= php4
-PORTVERSION= 4.4.1
-PORTREVISION?= 3
+PORTVERSION= 4.4.2
+PORTREVISION?= 0
CATEGORIES?= lang devel www
MASTER_SITES= ${MASTER_SITE_PHP:S,$,:release,} \
http://downloads.php.net/ilia/:rc \
diff --git a/lang/php4/Makefile.ext b/lang/php4/Makefile.ext
index 726cadb2fcde..b614022741c3 100644
--- a/lang/php4/Makefile.ext
+++ b/lang/php4/Makefile.ext
@@ -457,6 +457,11 @@ pre-configure:
/usr/bin/ar rcs liboracle.a *.o
.endif
+.if ${PHP_MODNAME} == "pcre"
+post-extract:
+ @${MV} ${WRKSRC}/config0.m4 ${WRKSRC}/config.m4
+.endif
+
.if ${PHP_MODNAME} == "snmp"
. if defined(WITH_SNMP4) || exists(${LOCALBASE}/lib/libsnmp.so.4)
LIB_DEPENDS+= snmp.4:${PORTSDIR}/net-mgmt/net-snmp4
diff --git a/lang/php4/distinfo b/lang/php4/distinfo
index be246decd081..4f69b64bd6b1 100644
--- a/lang/php4/distinfo
+++ b/lang/php4/distinfo
@@ -1,3 +1,3 @@
-MD5 (php-4.4.1.tar.bz2) = 6b5726471189f8a1f26dd7cc5e19b442
-SHA256 (php-4.4.1.tar.bz2) = c3010a85089bd464d5bbdda63dd253e0cf779db9670accf1ea5355de7ba448f8
-SIZE (php-4.4.1.tar.bz2) = 4157749
+MD5 (php-4.4.2.tar.bz2) = 28051cd9ef43490dd9727a4d442011b5
+SHA256 (php-4.4.2.tar.bz2) = a2024d665125a41611eb64451648d37a81e3579594c8810bb41ac8b2b63f81eb
+SIZE (php-4.4.2.tar.bz2) = 4371185
diff --git a/lang/php4/files/patch-ext_standard_basic_functions.c b/lang/php4/files/patch-ext_standard_basic_functions.c
deleted file mode 100644
index 272a066ec51e..000000000000
--- a/lang/php4/files/patch-ext_standard_basic_functions.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- ext/standard/basic_functions.c.orig Fri Nov 4 09:30:04 2005
-+++ ext/standard/basic_functions.c Fri Nov 4 09:30:56 2005
-@@ -802,8 +802,8 @@
- PHP_FE(prev, first_arg_force_ref)
- PHP_FE(next, first_arg_force_ref)
- PHP_FE(reset, first_arg_force_ref)
-- PHP_FE(current, NULL)
-- PHP_FE(key, NULL)
-+ PHP_FE(current, first_arg_force_ref)
-+ PHP_FE(key, first_arg_force_ref)
- PHP_FE(min, NULL)
- PHP_FE(max, NULL)
- PHP_FE(in_array, NULL)
diff --git a/lang/php4/files/patch-sapi_apache2handler_sapi_apache2.c b/lang/php4/files/patch-sapi_apache2handler_sapi_apache2.c
deleted file mode 100644
index cf9340073f07..000000000000
--- a/lang/php4/files/patch-sapi_apache2handler_sapi_apache2.c
+++ /dev/null
@@ -1,118 +0,0 @@
---- sapi/apache2handler/sapi_apache2.c.orig Wed Oct 12 23:41:36 2005
-+++ sapi/apache2handler/sapi_apache2.c Tue Nov 15 23:27:16 2005
-@@ -453,34 +453,15 @@
- request_rec *parent_req = NULL;
- TSRMLS_FETCH();
-
--#define PHPAP_INI_OFF \
-- if (strcmp(r->protocol, "INCLUDED")) { \
-- zend_try { zend_ini_deactivate(TSRMLS_C); } zend_end_try(); \
-- } \
--
- conf = ap_get_module_config(r->per_dir_config, &php4_module);
--
-- /* apply_config() needs r in some cases, so allocate server_context early */
-- ctx = SG(server_context);
-- if (ctx == NULL) {
-- ctx = SG(server_context) = apr_pcalloc(r->pool, sizeof(*ctx));
-- /* register a cleanup so we clear out the SG(server_context)
-- * after each request. Note: We pass in the pointer to the
-- * server_context in case this is handled by a different thread.
-- */
-- apr_pool_cleanup_register(r->pool, (void *)&SG(server_context), php_server_context_cleanup, apr_pool_cleanup_null);
-- ctx->r = r;
-- ctx = NULL; /* May look weird to null it here, but it is to catch the right case in the first_try later on */
-- } else {
-- parent_req = ctx->r;
-- ctx->r = r;
-- }
- apply_config(conf);
-
- if (strcmp(r->handler, PHP_MAGIC_TYPE) && strcmp(r->handler, PHP_SOURCE_MAGIC_TYPE) && strcmp(r->handler, PHP_SCRIPT)) {
- /* Check for xbithack in this case. */
- if (!AP2(xbithack) || strcmp(r->handler, "text/html") || !(r->finfo.protection & APR_UEXECUTE)) {
-- PHPAP_INI_OFF;
-+ zend_try {
-+ zend_ini_deactivate(TSRMLS_C);
-+ } zend_end_try();
- return DECLINED;
- }
- }
-@@ -489,24 +470,32 @@
- * the configuration; default behaviour is to accept. */
- if (r->used_path_info == AP_REQ_REJECT_PATH_INFO
- && r->path_info && r->path_info[0]) {
-- PHPAP_INI_OFF;
-+ zend_try {
-+ zend_ini_deactivate(TSRMLS_C);
-+ } zend_end_try();
- return HTTP_NOT_FOUND;
- }
-
- /* handle situations where user turns the engine off */
- if (!AP2(engine)) {
-- PHPAP_INI_OFF;
-+ zend_try {
-+ zend_ini_deactivate(TSRMLS_C);
-+ } zend_end_try();
- return DECLINED;
- }
-
- if (r->finfo.filetype == 0) {
- php_apache_sapi_log_message_ex("script '%s' not found or unable to stat", r);
-- PHPAP_INI_OFF;
-+ zend_try {
-+ zend_ini_deactivate(TSRMLS_C);
-+ } zend_end_try();
- return HTTP_NOT_FOUND;
- }
- if (r->finfo.filetype == APR_DIR) {
- php_apache_sapi_log_message_ex("attempt to invoke directory '%s' as script", r);
-- PHPAP_INI_OFF;
-+ zend_try {
-+ zend_ini_deactivate(TSRMLS_C);
-+ } zend_end_try();
- return HTTP_FORBIDDEN;
- }
-
-@@ -522,30 +511,24 @@
-
- zend_first_try {
-
-+ ctx = SG(server_context);
- if (ctx == NULL) {
--normal:
-+ ctx = SG(server_context) = apr_pcalloc(r->pool, sizeof(*ctx));
-+ /* register a cleanup so we clear out the SG(server_context)
-+ * after each request. Note: We pass in the pointer to the
-+ * server_context in case this is handled by a different thread.
-+ */
-+ apr_pool_cleanup_register(r->pool, (void *)&SG(server_context), php_server_context_cleanup, apr_pool_cleanup_null);
-+
-+ ctx->r = r;
- brigade = apr_brigade_create(r->pool, r->connection->bucket_alloc);
-- ctx = SG(server_context);
- ctx->brigade = brigade;
-
- if (php_apache_request_ctor(r, ctx TSRMLS_CC)!=SUCCESS) {
- zend_bailout();
- }
- } else {
-- if (!parent_req) {
-- parent_req = ctx->r;
-- }
-- if (parent_req && strcmp(parent_req->handler, PHP_MAGIC_TYPE) && strcmp(parent_req->handler, PHP_SOURCE_MAGIC_TYPE) && strcmp(parent_req->handler, PHP_SCRIPT)) {
-- if (php_apache_request_ctor(r, ctx TSRMLS_CC)!=SUCCESS) {
-- zend_bailout();
-- }
-- }
--
-- /* check if comming due to ErrorDocument */
-- if (parent_req && parent_req->status != HTTP_OK) {
-- parent_req = NULL;
-- goto normal;
-- }
-+ parent_req = ctx->r;
- ctx->r = r;
- brigade = ctx->brigade;
- }