aboutsummaryrefslogtreecommitdiff
path: root/lang/php5/Makefile.ext
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-07-11 13:21:54 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-07-11 13:21:54 +0000
commitbc04aff0957bd46cd4265a42f6974054c53fdcef (patch)
treeff035cfb8cdbe6438b20ba3be50e35daac4eae85 /lang/php5/Makefile.ext
parenta06cfd887501912a8a4f77f93ac5cdfa1b8859c9 (diff)
downloadports-bc04aff0957bd46cd4265a42f6974054c53fdcef.tar.gz
ports-bc04aff0957bd46cd4265a42f6974054c53fdcef.zip
Notes
Diffstat (limited to 'lang/php5/Makefile.ext')
-rw-r--r--lang/php5/Makefile.ext21
1 files changed, 21 insertions, 0 deletions
diff --git a/lang/php5/Makefile.ext b/lang/php5/Makefile.ext
index 796a7b19df53..02aadbc30f08 100644
--- a/lang/php5/Makefile.ext
+++ b/lang/php5/Makefile.ext
@@ -204,6 +204,14 @@ BROKEN_WITH_MYSQL= 323 40
CONFIGURE_ARGS+=--with-ncurses=/usr
.endif
+.if ${PHP_MODNAME} == "oci8"
+BUILD_DEPENDS+= ${LOCALBASE}/oracle8-client/lib/libclntsh.a:${PORTSDIR}/databases/oracle8-client
+
+RUN_DEPENDS+= ${BUILD_DEPENDS}
+
+CONFIGURE_ARGS+=--with-oci8=${LOCALBASE}/oracle8-client
+.endif
+
.if ${PHP_MODNAME} == "odbc"
LIB_DEPENDS+= odbc.1:${PORTSDIR}/databases/unixODBC
@@ -459,6 +467,19 @@ post-extract:
@${MV} ${WRKSRC}/config0.m4 ${WRKSRC}/config.m4
.endif
+.if ${PHP_MODNAME} == "oci8"
+. if ${OSVERSION} < 500000
+BROKEN= Doesn't work on FreeBSD 4.x
+. endif
+
+pre-configure:
+ @cd ${WRKSRC}; \
+ for lib in ${LOCALBASE}/oracle8-client/lib/libclntsh /usr/lib/libpthread; do \
+ /usr/bin/ar x $${lib}.a; \
+ done; \
+ /usr/bin/ar rcs liboci8.a *.o
+.endif
+
.if ${PHP_MODNAME} == "snmp"
. if defined(WITH_SNMP4) || exists(${LOCALBASE}/lib/libsnmp.so.4)
LIB_DEPENDS+= snmp.4:${PORTSDIR}/net-mgmt/net-snmp4