aboutsummaryrefslogtreecommitdiff
path: root/lang/php5/Makefile
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2005-12-09 19:41:41 +0000
committerAlex Dupre <ale@FreeBSD.org>2005-12-09 19:41:41 +0000
commit0edcc400292e872cca3456e62be5cffc5ef26333 (patch)
treecc6c372c23a2ece9493d977bfe87c7c39e5e2cf8 /lang/php5/Makefile
parentc3d2f3bcb42813b5ef1ae55a0c32dffb30abf67a (diff)
Finally update to PHP 5.1.1 release! (And remove unsupported extensions)
Notes
Notes: svn path=/head/; revision=150749
Diffstat (limited to 'lang/php5/Makefile')
-rw-r--r--lang/php5/Makefile55
1 files changed, 11 insertions, 44 deletions
diff --git a/lang/php5/Makefile b/lang/php5/Makefile
index 77c8c1e5e793..d192cdc78474 100644
--- a/lang/php5/Makefile
+++ b/lang/php5/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= php5
-PORTVERSION= 5.0.5
-PORTREVISION?= 2
+PORTVERSION= 5.1.1
+PORTREVISION?= 0
CATEGORIES?= lang devel www
MASTER_SITES= ${MASTER_SITE_PHP:S,$,:release,} \
http://downloads.php.net/ilia/:rc \
@@ -24,7 +24,6 @@ LATEST_LINK= ${PKGNAMEPREFIX}${PORTNAME}${PKGNAMESUFFIX}
USE_BZIP2= yes
.if !defined(PKGNAMESUFFIX) || ${PKGNAMESUFFIX} == "-cgi" || ${PKGNAMESUFFIX} == "-cli"
GNU_CONFIGURE= yes
-USE_BISON= yes
USE_REINPLACE= yes
CONFIGURE_ARGS= --enable-versioning \
@@ -64,7 +63,9 @@ WITH_APACHE= yes
.if defined(WITH_APACHE)
PKGMESSAGE= ${PKGDIR}/pkg-message.mod
-APACHE_COMPAT= yes
+USE_APACHE= 1.3+
+MODULENAME= lib${PORTNAME}
+SHORTMODNAME= ${PORTNAME}
.endif
.if ${PHP_SAPI} == "cgi"
@@ -73,19 +74,10 @@ OPTIONS= REDIRECT "Enable force-cgi-redirect support" off \
FASTCGI "Enable fastcgi support" off \
PATHINFO "Enable path-info-check support" on
.endif
-.if defined(WITH_APACHE)
-.if defined(WITH_APACHE2)
-OPTIONS= APACHE2 "Use apache 2.x instead of apache 1.3.x" on
-.else
-OPTIONS= APACHE2 "Use apache 2.x instead of apache 1.3.x" off
-.endif
-.endif
OPTIONS+= DEBUG "Enable debug" off \
MULTIBYTE "Enable zend multibyte support" off \
IPV6 "Enable ipv6 support" on
-EXT_DIR= 20041030
-
CONFLICTS?= php5-cli-5* mod_php5-5* php5-cgi-5*
CONFLICTS+= php4-4* php4-cli-4* mod_php4-4* php4-cgi-4*
@@ -94,11 +86,13 @@ CONFIGURE_ARGS+=--disable-cli
.endif
MAN1= php-config.1 phpize.1
-.if ${PHP_SAPI} == "full" || ${PHP_SAPI} == "cli"
-PLIST_SUB+= CLI=""
+.if ${PHP_SAPI} != "mod"
+PLIST_SUB+= CLICGI=""
+.if ${PHP_SAPI} != "cgi"
MAN1+= php.1
+.endif
.else
-PLIST_SUB+= CLI="@comment "
+PLIST_SUB+= CLICGI="@comment "
.endif
.if defined(WITH_APACHE)
@@ -109,11 +103,6 @@ PLIST_SUB+= APACHE="@comment "
.if ${PHP_SAPI} == "cli"
CONFIGURE_ARGS+=--disable-cgi
-SAPI_FILE= "@comment "
-.endif
-
-.if ${PHP_SAPI} == "cgi"
-SAPI_FILE= bin/php
.endif
.include <bsd.port.pre.mk>
@@ -122,38 +111,21 @@ CONFIGURE_ENV= ac_cv_pthreads_lib=${PTHREAD_LIBS} \
ac_cv_pthreads_cflags=${PTHREAD_CFLAGS}
.if defined(WITH_APACHE)
-.if exists(${LOCALBASE}/include/apache2/httpd.h)
-WITH_APACHE2= yes
-APACHE_MPM!= ${APXS} -q MPM_NAME
-.endif
-.if defined(WITH_APACHE2)
-APACHE_MPM?= ${WITH_MPM}
-APACHE_PORT= www/apache20
+.if ${APACHE_VERSION} > 13
CONFIGURE_ARGS+=--with-apxs2=${APXS}
-SAPI_FILE= libexec/apache2/libphp5.so
-.if ${APACHE_MPM} == "worker"
-EXT_DIR:= ${EXT_DIR}-zts
-.endif
.else
-APACHE_PORT?= www/apache13
CONFIGURE_ARGS+=--with-apxs=${APXS}
-SAPI_FILE= libexec/apache/libphp5.so
.endif
-BUILD_DEPENDS+= ${APXS}:${PORTSDIR}/${APACHE_PORT}
-RUN_DEPENDS+= ${APXS}:${PORTSDIR}/${APACHE_PORT}
.endif
.if defined(WITH_DEBUG)
CONFIGURE_ARGS+=--enable-debug
-EXT_DIR:= ${EXT_DIR}-debug
.endif
.if defined(WITH_MULTIBYTE)
CONFIGURE_ARGS+=--enable-zend-multibyte
.endif
-PLIST_SUB+= SAPI_FILE=${SAPI_FILE}
-
.if ${OSVERSION} < 400014 || defined(WITHOUT_IPV6)
CONFIGURE_ARGS+=--disable-ipv6
.endif
@@ -195,7 +167,6 @@ pre-configure:
post-build:
@${ECHO_CMD} "PHP_VER=5" > ${WRKDIR}/php.conf
@${ECHO_CMD} "PHP_VERSION=${PORTVERSION}" >> ${WRKDIR}/php.conf
- @${ECHO_CMD} "PHP_EXT_DIR=${EXT_DIR}" >> ${WRKDIR}/php.conf
@${ECHO_CMD} "PHP_PORT=\$${PORTSDIR}/${PHP_PORT}" >> ${WRKDIR}/php.conf
@${ECHO_CMD} "PHP_SAPI=${PHP_SAPI}" >> ${WRKDIR}/php.conf
@@ -209,10 +180,6 @@ post-install:
.endif
.else
-.if ${PKGNAMESUFFIX} == "-pear"
-.include "${MASTERDIR}/Makefile.pear"
-.else
.include "${MASTERDIR}/Makefile.ext"
.endif
-.endif
.include <bsd.port.post.mk>