aboutsummaryrefslogtreecommitdiff
path: root/lang/php52
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2013-09-04 18:06:07 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2013-09-04 18:06:07 +0000
commit642be1b81d8342d3a3323f43bcf5a0bd87a5d363 (patch)
treef71b3671c7729b9cbc9368cea2f2fede7b20d5c8 /lang/php52
parentbcaced2c93b58d27ca266602f4049df6ba6becb3 (diff)
- Make ports use the libc provided iconv implementation on 10-CURRENT
after r254273 - Fix a bunch of ports to properly work after this - Mark converters/libiconv as IGNORE for systems with iconv in libc Reviewed by: bapt Approved by: portmgr (bapt) Discussed with: bapt, bsam (who both contributed ideas and code)
Notes
Notes: svn path=/head/; revision=326307
Diffstat (limited to 'lang/php52')
-rw-r--r--lang/php52/Makefile.ext6
1 files changed, 2 insertions, 4 deletions
diff --git a/lang/php52/Makefile.ext b/lang/php52/Makefile.ext
index ae1c4a11e001..af2a744054e9 100644
--- a/lang/php52/Makefile.ext
+++ b/lang/php52/Makefile.ext
@@ -135,8 +135,7 @@ CONFIGURE_ARGS+=--enable-hash
.endif
.if ${PHP_MODNAME} == "iconv"
-CONFIGURE_ARGS+=--with-iconv=${LOCALBASE} \
- --with-iconv-dir=${LOCALBASE}
+CONFIGURE_ARGS+=--with-iconv
USES+= iconv
.endif
@@ -482,8 +481,7 @@ USE_PHP_BUILD= yes
.if ${PHP_MODNAME} == "xmlrpc"
CONFIGURE_ARGS+=--with-xmlrpc \
- --with-libxml-dir=${LOCALBASE} \
- --with-iconv-dir=${LOCALBASE}
+ --with-libxml-dir=${LOCALBASE}
USES+= iconv
USE_GNOME= libxml2