aboutsummaryrefslogtreecommitdiff
path: root/lang/php52
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2012-05-05 15:18:09 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2012-05-05 15:18:09 +0000
commit76ea697dacaf70ce7375be9c3623b1bc61c01c11 (patch)
tree85130903d086474d23571421dc5fa66fbf8f0563 /lang/php52
parentd2c2c21c94c946f1922a3b87f1b055816a42f5e7 (diff)
downloadports-76ea697dacaf70ce7375be9c3623b1bc61c01c11.tar.gz
ports-76ea697dacaf70ce7375be9c3623b1bc61c01c11.zip
Notes
Diffstat (limited to 'lang/php52')
-rw-r--r--lang/php52/Makefile17
-rw-r--r--lang/php52/Makefile.ext18
2 files changed, 17 insertions, 18 deletions
diff --git a/lang/php52/Makefile b/lang/php52/Makefile
index 90adf191ce85..6367af7d0013 100644
--- a/lang/php52/Makefile
+++ b/lang/php52/Makefile
@@ -7,7 +7,7 @@
PORTNAME= php52
PORTVERSION= 5.2.17
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES?= lang devel www
MASTER_SITES= ${MASTER_SITE_PHP}
MASTER_SITE_SUBDIR= distributions
@@ -24,6 +24,11 @@ LATEST_LINK= ${PKGNAMEPREFIX}${PORTNAME}${PKGNAMESUFFIX}
USE_BZIP2= yes
MAKE_JOBS_SAFE= yes
+
+# BACKPORTS patch for lang/php52 and all php52-extensions
+PATCHFILES= php52-backports-security-20120504.patch
+PATCH_SITES= http://php52-backports.googlecode.com/files/
+
.if !defined(PKGNAMESUFFIX)
USE_AUTOTOOLS= autoconf
AUTOTOOLSFILES= scripts/phpize.in
@@ -52,8 +57,7 @@ OPTIONS= CLI "Build CLI version" on \
FASTCGI "Enable fastcgi support (CGI only)" on \
FPM "Enable fastcgi process manager (CGI only)" off \
PATHINFO "Enable path-info-check support (CGI only)" on \
- LINKTHR "Link thread lib (for threaded extensions)" off \
- BACKPORTS "Enable backported security and bugfix patches" on
+ LINKTHR "Link thread lib (for threaded extensions)" off
CONFLICTS= php4-4* php5-5.3*
@@ -187,13 +191,6 @@ CONFIGURE_ARGS+=--enable-zend-multibyte
CONFIGURE_ARGS+=--disable-ipv6
.endif
-.if defined(WITH_BACKPORTS)
-PATCHFILES+= php52-backports-security-20120117.patch
-PATCH_SITES+= http://php52-backports.googlecode.com/files/
-.else
-FORBIDDEN= Vulnerable since 2011-01-13, http://portaudit.freebsd.org/3761df02-0f9c-11e0-becc-0022156e8794.html
-.endif
-
post-patch:
@${TOUCH} ${WRKSRC}/ext/php_config.h
@${REINPLACE_CMD} "s|^\(extension_dir\)|; \1|" ${WRKSRC}/php.ini-*
diff --git a/lang/php52/Makefile.ext b/lang/php52/Makefile.ext
index a5734ef35223..010dd9806492 100644
--- a/lang/php52/Makefile.ext
+++ b/lang/php52/Makefile.ext
@@ -11,7 +11,9 @@ WRKSRC= ${WRKDIR}/${EXTSUBDIR}
PATCHDIR= ${.CURDIR}/files
PLIST= ${NONEXISTENT}
-EXTRACT_AFTER_ARGS?= | ${TAR} -xf - ${EXTSUBDIR}
+#EXTRACT_AFTER_ARGS?= | ${TAR} -xf - ${EXTSUBDIR}
+PATCH_WRKSRC= ${WRKDIR}/${DISTNAME}
+PATCH_DIST_STRIP+= -p1
.if ${PHP_MODNAME} == "bcmath"
CONFIGURE_ARGS+=--enable-bcmath
@@ -248,7 +250,7 @@ USE_OPENSSL= yes
CONFIGURE_ARGS+=--enable-pcntl
.endif
-.if ${PHP_MODNAME} == "pcre"
+.if ${PHP_MODNAME} == "pcre"
OPTIONS= BUNDLED_PCRE "Select if you use apache 2.0.x" off
.endif
@@ -315,7 +317,7 @@ USE_PHP_BUILD= yes
.if ${PHP_MODNAME} == "pdo_sqlite"
. if defined(WITH_SQLITE_PORT)
-USE_SQLITE= yes
+USE_SQLITE= yes
CONFIGURE_ARGS+=--with-pdo-sqlite=${LOCALBASE}
. else
CONFIGURE_ARGS+=--with-pdo-sqlite
@@ -377,7 +379,7 @@ CONFIGURE_ARGS+=--with-snmp=${LOCALBASE} \
--with-openssl-dir=${OPENSSLBASE} \
--enable-ucd-snmp-hack
-LIB_DEPENDS+= netsnmp.30:${PORTSDIR}/net-mgmt/net-snmp
+LIB_DEPENDS+= netsnmp.30:${PORTSDIR}/net-mgmt/net-snmp
LDFLAGS+= -L${OPENSSLLIB} -lcrypto -lssl
USE_OPENSSL= yes
.endif
@@ -490,9 +492,9 @@ USE_PHP_BUILD= yes
.if ${PHP_MODNAME} == "xmlwriter"
CONFIGURE_ARGS+=--enable-xmlwriter \
- --with-libxml-dir=${LOCALBASE}
+ --with-libxml-dir=${LOCALBASE}
-USE_GNOME= libxml2
+USE_GNOME= libxml2
.endif
.if ${PHP_MODNAME} == "xsl"
@@ -576,7 +578,7 @@ pre-configure:
/usr/bin/ar rcs liboci8.a *.o
.endif
-.if ${PHP_MODNAME} == "pcre"
+.if ${PHP_MODNAME} == "pcre"
. if defined(WITH_BUNDLED_PCRE)
CONFIGURE_ARGS+=--with-pcre-regex=yes
@@ -587,7 +589,7 @@ LIB_DEPENDS+= pcre.1:${PORTSDIR}/devel/pcre
CONFIGURE_ARGS+=--with-pcre-regex=${LOCALBASE}
. endif
-post-extract:
+post-extract:
@${MV} ${WRKSRC}/config0.m4 ${WRKSRC}/config.m4
.endif