aboutsummaryrefslogtreecommitdiff
path: root/lang/php53/files
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2006-05-06 13:26:49 +0000
committerAlex Dupre <ale@FreeBSD.org>2006-05-06 13:26:49 +0000
commitf12d3a0ccb6b5f12408152f1e699e0d91ebfe909 (patch)
tree7e77ab1846eeb19035bf34f40c8aa72a0f2fd4db /lang/php53/files
parentc98b5156448cba566825c999725c2c7f544414a5 (diff)
Notes
Diffstat (limited to 'lang/php53/files')
-rw-r--r--lang/php53/files/patch-TSRM_threads.m411
-rw-r--r--lang/php53/files/patch-acinclude.m433
-rw-r--r--lang/php53/files/patch-configure47
-rw-r--r--lang/php53/files/patch-configure.in50
-rw-r--r--lang/php53/files/patch-main::php_config.h.in6
-rw-r--r--lang/php53/files/patch-main_SAPI.c8
-rw-r--r--lang/php53/files/patch-sapi_cgi_Makefile.frag9
-rw-r--r--lang/php53/files/patch-sapi_cgi_config9.m455
-rw-r--r--lang/php53/files/patch-scripts::phpize.in8
9 files changed, 164 insertions, 63 deletions
diff --git a/lang/php53/files/patch-TSRM_threads.m4 b/lang/php53/files/patch-TSRM_threads.m4
new file mode 100644
index 000000000000..6208eac7f79c
--- /dev/null
+++ b/lang/php53/files/patch-TSRM_threads.m4
@@ -0,0 +1,11 @@
+--- TSRM/threads.m4.orig Wed Apr 27 15:22:18 2005
++++ TSRM/threads.m4 Wed May 3 10:02:34 2006
+@@ -164,7 +164,7 @@
+ dnl
+ AC_DEFUN([PTHREADS_ASSIGN_VARS],[
+ if test -n "$ac_cv_pthreads_lib"; then
+- LIBS="$LIBS -l$ac_cv_pthreads_lib"
++ LIBS="$LIBS $ac_cv_pthreads_lib"
+ fi
+
+ if test -n "$ac_cv_pthreads_cflags"; then
diff --git a/lang/php53/files/patch-acinclude.m4 b/lang/php53/files/patch-acinclude.m4
index 14396604f6e6..9c4094b8fd82 100644
--- a/lang/php53/files/patch-acinclude.m4
+++ b/lang/php53/files/patch-acinclude.m4
@@ -1,10 +1,33 @@
---- acinclude.m4.orig Sat Dec 24 12:38:05 2005
-+++ acinclude.m4 Mon Jan 16 12:20:17 2006
-@@ -1021,12 +1021,6 @@
+--- acinclude.m4.orig Mon Apr 10 14:17:36 2006
++++ acinclude.m4 Thu May 4 08:10:56 2006
+@@ -194,7 +194,7 @@
+ dnl
+ dnl which array to append to?
+ AC_DEFUN([PHP_ADD_SOURCES],[
+- PHP_ADD_SOURCES_X($1, $2, $3, ifelse($4,cli,PHP_CLI_OBJS,ifelse($4,sapi,PHP_SAPI_OBJS,PHP_GLOBAL_OBJS)))
++ PHP_ADD_SOURCES_X($1, $2, $3, ifelse($4,cli,PHP_CLI_OBJS,ifelse($4,sapi,PHP_SAPI_OBJS,ifelse($4,cgi,PHP_CGI_OBJS,PHP_GLOBAL_OBJS))))
+ ])
+
+ dnl
+@@ -966,12 +966,8 @@
+ if test "$3" != "shared" && test "$3" != "yes" && test "$4" = "cli"; then
+ dnl ---------------------------------------------- CLI static module
+ [PHP_]translit($1,a-z_-,A-Z__)[_SHARED]=no
+- if test "$PHP_SAPI" = "cgi"; then
+- PHP_ADD_SOURCES(PHP_EXT_DIR($1),$2,$ac_extra,)
+- EXT_STATIC="$EXT_STATIC $1"
+- else
+ PHP_ADD_SOURCES(PHP_EXT_DIR($1),$2,$ac_extra,cli)
+- fi
++ PHP_ADD_SOURCES(PHP_EXT_DIR($1),$2,$ac_extra,cgi)
+ EXT_CLI_STATIC="$EXT_CLI_STATIC $1"
+ fi
+ PHP_ADD_BUILD_DIR($ext_builddir)
+@@ -1021,12 +1017,6 @@
build to be successful.
])
fi
-- if test "x$is_it_shared" = "x" && test "x$3" != "xtrue"; then
+- if test "x$is_it_enabled" = "xno" && test "x$3" != "xtrue"; then
- AC_MSG_ERROR([
-You've configured extension $1, which depends on extension $2,
-but you've either not enabled $2, or have disabled it.
@@ -13,7 +36,7 @@
dnl Some systems require that we link $2 to $1 when building
])
-@@ -2151,9 +2145,9 @@
+@@ -2158,9 +2148,9 @@
test -z "$PHP_IMAP_SSL" && PHP_IMAP_SSL=no
dnl Fallbacks for different configure options
diff --git a/lang/php53/files/patch-configure b/lang/php53/files/patch-configure
deleted file mode 100644
index 1ac8ec049e63..000000000000
--- a/lang/php53/files/patch-configure
+++ /dev/null
@@ -1,47 +0,0 @@
---- configure.orig Wed Nov 23 22:37:49 2005
-+++ configure Fri Nov 25 10:39:54 2005
-@@ -3654,7 +3654,7 @@
- save_LIBS=$LIBS
-
- if test -n "$ac_cv_pthreads_lib"; then
-- LIBS="$LIBS -l$ac_cv_pthreads_lib"
-+ LIBS="$LIBS $ac_cv_pthreads_lib"
- fi
-
- if test -n "$ac_cv_pthreads_cflags"; then
-@@ -12074,7 +12074,7 @@
- if test "$enable_maintainer_zts" = "yes"; then
-
- if test -n "$ac_cv_pthreads_lib"; then
-- LIBS="$LIBS -l$ac_cv_pthreads_lib"
-+ LIBS="$LIBS $ac_cv_pthreads_lib"
- fi
-
- if test -n "$ac_cv_pthreads_cflags"; then
-@@ -12091,8 +12091,6 @@
- case $host_alias in
- *solaris*)
- PTHREAD_FLAGS="-D_POSIX_PTHREAD_SEMANTICS -D_REENTRANT";;
-- *freebsd*)
-- PTHREAD_FLAGS="-D_REENTRANT -D_THREAD_SAFE";;
- *linux*)
- PTHREAD_FLAGS=-D_REENTRANT;;
- *aix*)
-@@ -100076,7 +100074,7 @@
- save_LIBS=$LIBS
-
- if test -n "$ac_cv_pthreads_lib"; then
-- LIBS="$LIBS -l$ac_cv_pthreads_lib"
-+ LIBS="$LIBS $ac_cv_pthreads_lib"
- fi
-
- if test -n "$ac_cv_pthreads_cflags"; then
-@@ -108808,7 +108806,7 @@
-
-
-
-- for header_file in Zend/ TSRM/ include/ main/ main/streams/ regex/; do
-+ for header_file in Zend/ TSRM/ main/ main/streams/ regex/ ext/spl/; do
-
-
- unique=`echo $header_file|$SED 's/[^a-zA-Z0-9]/_/g'`
diff --git a/lang/php53/files/patch-configure.in b/lang/php53/files/patch-configure.in
new file mode 100644
index 000000000000..dc9a457f077c
--- /dev/null
+++ b/lang/php53/files/patch-configure.in
@@ -0,0 +1,50 @@
+--- configure.in.orig Wed Apr 26 16:08:26 2006
++++ configure.in Thu May 4 08:55:35 2006
+@@ -222,7 +222,6 @@
+ dnl .
+ dnl -------------------------------------------------------------------------
+
+-PTHREADS_CHECK
+ PHP_HELP_SEPARATOR([SAPI modules:])
+ PHP_SHLIB_SUFFIX_NAMES
+ PHP_SAPI=default
+@@ -247,7 +246,6 @@
+
+ if test "$enable_maintainer_zts" = "yes"; then
+ PTHREADS_ASSIGN_VARS
+- PTHREADS_FLAGS
+ fi
+
+ if test "$PHP_ENABLE_FASTCGI" = "yes"; then
+@@ -1248,25 +1246,22 @@
+ INLINE_CFLAGS="$INLINE_CFLAGS $standard_libtool_flag"
+ CXXFLAGS="$CXXFLAGS $standard_libtool_flag"
+
+-all_targets="$lcov_target \$(OVERALL_TARGET) \$(PHP_MODULES) \$(PHP_CLI_TARGET)"
+-install_targets="$install_modules install-build install-headers install-programs $install_pear"
++all_targets="$lcov_target \$(OVERALL_TARGET) \$(PHP_MODULES) \$(PHP_CLI_TARGET) \$(PHP_CGI_TARGET)"
++install_targets="$PHP_INSTALL_CLI_TARGET $PHP_INSTALL_CGI_TARGET $install_modules install-build install-headers install-programs $install_pear"
+
+ case $PHP_SAPI in
+- cgi)
++ apache)
+ install_targets="install-sapi $install_targets"
+ ;;
+- cli)
+- install_targets="$PHP_INSTALL_CLI_TARGET $install_targets"
+- ;;
+- *)
+- install_targets="install-sapi $PHP_INSTALL_CLI_TARGET $install_targets"
++ apache2handler)
++ install_targets="install-sapi $install_targets"
+ ;;
+ esac
+
+ PHP_SUBST(all_targets)
+ PHP_SUBST(install_targets)
+
+-PHP_INSTALL_HEADERS([Zend/ TSRM/ include/ main/ main/streams/ regex/])
++PHP_INSTALL_HEADERS([Zend/ TSRM/ main/ main/streams/ regex/ ext/spl/])
+
+ PHP_ADD_SOURCES(TSRM, TSRM.c tsrm_strtok_r.c tsrm_virtual_cwd.c)
+
diff --git a/lang/php53/files/patch-main::php_config.h.in b/lang/php53/files/patch-main::php_config.h.in
index 9c92108b381e..8e9938876421 100644
--- a/lang/php53/files/patch-main::php_config.h.in
+++ b/lang/php53/files/patch-main::php_config.h.in
@@ -1,6 +1,6 @@
---- main/php_config.h.in.orig Mon Sep 5 13:16:27 2005
-+++ main/php_config.h.in Wed Nov 16 09:30:03 2005
-@@ -2454,6 +2454,9 @@
+--- main/php_config.h.in.orig Wed Jan 11 15:25:52 2006
++++ main/php_config.h.in Wed May 3 09:38:09 2006
+@@ -2760,6 +2760,9 @@
/* Define if uint32_t type is present. */
#undef HAVE_UINT32_T
diff --git a/lang/php53/files/patch-main_SAPI.c b/lang/php53/files/patch-main_SAPI.c
index 12744ba48346..1a965ddb778b 100644
--- a/lang/php53/files/patch-main_SAPI.c
+++ b/lang/php53/files/patch-main_SAPI.c
@@ -1,6 +1,6 @@
---- main/SAPI.c.orig Fri Apr 15 10:31:02 2005
-+++ main/SAPI.c Fri Apr 15 10:34:11 2005
-@@ -569,7 +569,7 @@
+--- main/SAPI.c.orig Sun Jan 1 13:50:17 2006
++++ main/SAPI.c Wed May 3 09:38:09 2006
+@@ -602,7 +602,7 @@
ptr++;
len--;
}
@@ -9,7 +9,7 @@
if(!strncmp(ptr, "image/", sizeof("image/")-1)) {
zend_alter_ini_entry("zlib.output_compression", sizeof("zlib.output_compression"), "0", sizeof("0") - 1, PHP_INI_USER, PHP_INI_STAGE_RUNTIME);
}
-@@ -716,7 +716,7 @@
+@@ -756,7 +756,7 @@
return SUCCESS;
}
diff --git a/lang/php53/files/patch-sapi_cgi_Makefile.frag b/lang/php53/files/patch-sapi_cgi_Makefile.frag
new file mode 100644
index 000000000000..26a0e4b1a3ba
--- /dev/null
+++ b/lang/php53/files/patch-sapi_cgi_Makefile.frag
@@ -0,0 +1,9 @@
+--- sapi/cgi/Makefile.frag.orig Wed May 3 10:09:02 2006
++++ sapi/cgi/Makefile.frag Wed May 3 10:08:54 2006
+@@ -1,2 +1,5 @@
+-$(SAPI_CGI_PATH): $(PHP_GLOBAL_OBJS) $(PHP_SAPI_OBJS)
++$(SAPI_CGI_PATH): $(PHP_GLOBAL_OBJS) $(PHP_CGI_OBJS)
+ $(BUILD_CGI)
++
++install-cgi: $(SAPI_CGI_PATH)
++ @$(INSTALL_CGI)
diff --git a/lang/php53/files/patch-sapi_cgi_config9.m4 b/lang/php53/files/patch-sapi_cgi_config9.m4
new file mode 100644
index 000000000000..8677e0e9aa12
--- /dev/null
+++ b/lang/php53/files/patch-sapi_cgi_config9.m4
@@ -0,0 +1,55 @@
+--- sapi/cgi/config9.m4.orig Thu Feb 2 10:59:23 2006
++++ sapi/cgi/config9.m4 Thu May 4 11:19:41 2006
+@@ -80,7 +80,6 @@
+ ])
+
+
+-if test "$PHP_SAPI" = "default"; then
+ AC_MSG_CHECKING(for CGI build)
+ if test "$PHP_SAPI_CGI" != "no"; then
+ AC_MSG_RESULT(yes)
+@@ -145,8 +144,9 @@
+ AC_DEFINE_UNQUOTED(PHP_FCGI_STATIC, $PHP_FCGI_STATIC, [ ])
+ AC_MSG_RESULT($PHP_ENABLE_FASTCGI)
+
+- INSTALL_IT="@echo \"Installing PHP CGI into: \$(INSTALL_ROOT)\$(bindir)/\"; \$(INSTALL) -m 0755 \$(SAPI_CGI_PATH) \$(INSTALL_ROOT)\$(bindir)/\$(program_prefix)php\$(program_suffix)\$(EXEEXT)"
+- PHP_SELECT_SAPI(cgi, program, $PHP_FCGI_FILES cgi_main.c getopt.c, , '$(SAPI_CGI_PATH)')
++ INSTALL_CGI="@echo \"Installing PHP CGI into: \$(INSTALL_ROOT)\$(bindir)/\"; \$(INSTALL) -m 0755 \$(SAPI_CGI_PATH) \$(INSTALL_ROOT)\$(bindir)/\$(program_prefix)php-cgi\$(program_suffix)\$(EXEEXT)"
++ PHP_ADD_SOURCES(sapi/cgi, $PHP_FCGI_FILES cgi_main.c getopt.c,, cgi)
++ PHP_ADD_SOURCES(/main, internal_functions.c,,cgi)
+
+ case $host_alias in
+ *aix*)
+@@ -156,17 +156,29 @@
+ BUILD_CGI="\$(CC) \$(CFLAGS_CLEAN) \$(EXTRA_CFLAGS) \$(EXTRA_LDFLAGS_PROGRAM) \$(LDFLAGS) \$(NATIVE_RPATHS) \$(PHP_GLOBAL_OBJS:.lo=.o) \$(PHP_SAPI_OBJS:.lo=.o) \$(PHP_FRAMEWORKS) \$(EXTRA_LIBS) \$(ZEND_EXTRA_LIBS) -o \$(SAPI_CGI_PATH)"
+ ;;
+ *)
+- BUILD_CGI="\$(LIBTOOL) --mode=link \$(CC) -export-dynamic \$(CFLAGS_CLEAN) \$(EXTRA_CFLAGS) \$(EXTRA_LDFLAGS_PROGRAM) \$(LDFLAGS) \$(PHP_RPATHS) \$(PHP_GLOBAL_OBJS) \$(PHP_SAPI_OBJS) \$(EXTRA_LIBS) \$(ZEND_EXTRA_LIBS) -o \$(SAPI_CGI_PATH)"
++ BUILD_CGI="\$(LIBTOOL) --mode=link \$(CC) -export-dynamic \$(CFLAGS_CLEAN) \$(EXTRA_CFLAGS) \$(EXTRA_LDFLAGS_PROGRAM) \$(LDFLAGS) \$(PHP_RPATHS) \$(PHP_GLOBAL_OBJS) \$(PHP_CGI_OBJS) \$(EXTRA_LIBS) \$(ZEND_EXTRA_LIBS) -o \$(SAPI_CGI_PATH)"
+ ;;
+ esac
+
++ PHP_CGI_TARGET="\$(SAPI_CGI_PATH)"
++ PHP_INSTALL_CGI_TARGET="install-cgi"
+ PHP_SUBST(BUILD_CGI)
++ PHP_SUBST(INSTALL_CGI)
++ PHP_SUBST(PHP_CGI_OBJS)
++ PHP_SUBST(PHP_CGI_TARGET)
++ PHP_SUBST(PHP_INSTALL_CGI_TARGET)
+
+- elif test "$PHP_SAPI_CLI" != "no"; then
+- AC_MSG_RESULT(no)
++ if test "$PHP_SAPI" = "default" ; then
++ PHP_BUILD_PROGRAM($SAPI_CGI_PATH)
++ fi
++ else
++ AC_MSG_RESULT(no)
++ if test "$PHP_SAPI" = "default" ; then
++ if test "$PHP_SAPI_CLI" != "no" ; then
+ OVERALL_TARGET=
+ PHP_SAPI=cli
+ else
+ AC_MSG_ERROR([No SAPIs selected.])
+ fi
++ fi
+ fi
diff --git a/lang/php53/files/patch-scripts::phpize.in b/lang/php53/files/patch-scripts::phpize.in
index e70286dba4a9..4f655b5ae454 100644
--- a/lang/php53/files/patch-scripts::phpize.in
+++ b/lang/php53/files/patch-scripts::phpize.in
@@ -1,6 +1,6 @@
---- scripts/phpize.in.orig Wed Jun 15 19:19:41 2005
-+++ scripts/phpize.in Wed Sep 7 17:52:24 2005
-@@ -94,8 +94,8 @@
+--- scripts/phpize.in.orig Mon Dec 12 12:51:45 2005
++++ scripts/phpize.in Wed May 3 09:38:09 2006
+@@ -99,8 +99,8 @@
phpize_check_autotools()
{
@@ -9,5 +9,5 @@
+ test -z "$PHP_AUTOCONF" && PHP_AUTOCONF=autoconf259
+ test -z "$PHP_AUTOHEADER" && PHP_AUTOHEADER=autoheader259
- if ! test -x "`$php_shtool path $PHP_AUTOCONF`"; then
+ if test ! -x "`$php_shtool path $PHP_AUTOCONF`"; then
cat <<EOF