aboutsummaryrefslogtreecommitdiff
path: root/lang/php53
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2007-05-20 08:27:29 +0000
committerAlex Dupre <ale@FreeBSD.org>2007-05-20 08:27:29 +0000
commitcc137a49e95339da3fffd346f89ebb099489cedc (patch)
treef2bd36f58deff5be870f46f3a1312a1a03c412a4 /lang/php53
parent01693688cc95da008677f8712094b6965309c7d7 (diff)
downloadports-cc137a49e95339da3fffd346f89ebb099489cedc.tar.gz
ports-cc137a49e95339da3fffd346f89ebb099489cedc.zip
Notes
Diffstat (limited to 'lang/php53')
-rw-r--r--lang/php53/Makefile4
-rw-r--r--lang/php53/Makefile.ext3
-rw-r--r--lang/php53/distinfo18
-rw-r--r--lang/php53/files/patch-ext_standard_string.c11
4 files changed, 13 insertions, 23 deletions
diff --git a/lang/php53/Makefile b/lang/php53/Makefile
index f07aa4aa87ca..1c4e337a489a 100644
--- a/lang/php53/Makefile
+++ b/lang/php53/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= php5
-PORTVERSION= 5.2.1
-PORTREVISION?= 3
+PORTVERSION= 5.2.2
+PORTREVISION?= 0
CATEGORIES?= lang devel www
MASTER_SITES= ${MASTER_SITE_PHP:S,$,:release,} \
http://downloads.php.net/ilia/:rc \
diff --git a/lang/php53/Makefile.ext b/lang/php53/Makefile.ext
index 7963d745d379..c248c1dc91dc 100644
--- a/lang/php53/Makefile.ext
+++ b/lang/php53/Makefile.ext
@@ -267,7 +267,8 @@ USE_GCC= 3.4+
.endif
.if ${PHP_MODNAME} == "pdo_mysql"
-CONFIGURE_ARGS+=--with-pdo-mysql=${LOCALBASE}
+CONFIGURE_ARGS+=--with-pdo-mysql=${LOCALBASE} \
+ --with-zlib-dir=/usr
USE_MYSQL= yes
diff --git a/lang/php53/distinfo b/lang/php53/distinfo
index dd2ec0e1ff47..f58f37515752 100644
--- a/lang/php53/distinfo
+++ b/lang/php53/distinfo
@@ -1,9 +1,9 @@
-MD5 (php-5.2.1.tar.bz2) = 261218e3569a777dbd87c16a15f05c8d
-SHA256 (php-5.2.1.tar.bz2) = 4b60fa70969644d193d58dd7cb9f2765e304c6368e98b1551e92e8d4e14d35ed
-SIZE (php-5.2.1.tar.bz2) = 7163383
-MD5 (suhosin-patch-5.2.1-0.9.6.2.patch.gz) = 98cae8ee994df74e3ea1b25c955310e8
-SHA256 (suhosin-patch-5.2.1-0.9.6.2.patch.gz) = 78802a71c35ed2bed2e0e32cb8443f682451989ebe1ed5d5b384b7bb85b90c1b
-SIZE (suhosin-patch-5.2.1-0.9.6.2.patch.gz) = 22679
-MD5 (php-5.2.1-mail-header.patch) = be00d628a43e650e98c45185485100c1
-SHA256 (php-5.2.1-mail-header.patch) = e72c3f0d8d905bf92513bbf858a450469b15ee3c7d4da33feb495100ac7b1cd2
-SIZE (php-5.2.1-mail-header.patch) = 3420
+MD5 (php-5.2.2.tar.bz2) = d084337867d70b50a10322577be0e44e
+SHA256 (php-5.2.2.tar.bz2) = cd69e73c46e1d171ac0cf27b7ee492c3bf8f6b45a763a77fd0cb79d5afa9f407
+SIZE (php-5.2.2.tar.bz2) = 7310926
+MD5 (suhosin-patch-5.2.2-0.9.6.2.patch.gz) = 081fe08d584820a6ece1fe2e8629711f
+SHA256 (suhosin-patch-5.2.2-0.9.6.2.patch.gz) = 932d8155028686b96d3ebf89215dab7cd9353ac72f9ea82c252d0999fb4bd864
+SIZE (suhosin-patch-5.2.2-0.9.6.2.patch.gz) = 22850
+MD5 (php-5.2.2-mail-header.patch) = 6b2562b5230b1f85a2ccb292e124a91a
+SHA256 (php-5.2.2-mail-header.patch) = 5394732be1953c7eedc2de9529d10971d85959af6352c8a67b4561124ddc8df5
+SIZE (php-5.2.2-mail-header.patch) = 3420
diff --git a/lang/php53/files/patch-ext_standard_string.c b/lang/php53/files/patch-ext_standard_string.c
deleted file mode 100644
index 1bf5dc8377eb..000000000000
--- a/lang/php53/files/patch-ext_standard_string.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- ext/standard/string.c.orig Thu Feb 15 07:50:09 2007
-+++ ext/standard/string.c Thu Feb 15 07:50:33 2007
-@@ -3148,7 +3148,7 @@
- }
-
- Z_STRLEN_P(result) = len + (char_count * (to_len - 1));
-- Z_STRVAL_P(result) = target = safe_emalloc(char_count, to_len, len);
-+ Z_STRVAL_P(result) = target = safe_emalloc(char_count, to_len, len + 1);
- Z_TYPE_P(result) = IS_STRING;
-
- if (case_sensitivity) {