aboutsummaryrefslogtreecommitdiff
path: root/lang/php56
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-09-01 14:14:44 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-09-01 14:14:44 +0000
commit870fd9b8faafef3bb3281bf55b40ebe0446c59a1 (patch)
tree654938802b90aba0f3479ec8d05296c3f2e84866 /lang/php56
parent4940776700ec280918660ed877e6f597f5cca2de (diff)
downloadports-870fd9b8faafef3bb3281bf55b40ebe0446c59a1.tar.gz
ports-870fd9b8faafef3bb3281bf55b40ebe0446c59a1.zip
Notes
Diffstat (limited to 'lang/php56')
-rw-r--r--lang/php56/Makefile2
-rw-r--r--lang/php56/files/patch-Makefile.global19
2 files changed, 20 insertions, 1 deletions
diff --git a/lang/php56/Makefile b/lang/php56/Makefile
index 47634b236ef7..25a69851c6d2 100644
--- a/lang/php56/Makefile
+++ b/lang/php56/Makefile
@@ -3,7 +3,7 @@
PORTNAME= php56
PORTVERSION= 5.6.25
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= lang devel www
MASTER_SITES= PHP/distributions
DISTNAME= php-${PORTVERSION}
diff --git a/lang/php56/files/patch-Makefile.global b/lang/php56/files/patch-Makefile.global
new file mode 100644
index 000000000000..5ef5f013a49a
--- /dev/null
+++ b/lang/php56/files/patch-Makefile.global
@@ -0,0 +1,19 @@
+--- Makefile.global.orig 2016-08-18 11:07:46 UTC
++++ Makefile.global
+@@ -89,14 +89,14 @@ test: all
+ @if test ! -z "$(PHP_EXECUTABLE)" && test -x "$(PHP_EXECUTABLE)"; then \
+ INI_FILE=`$(PHP_EXECUTABLE) -d 'display_errors=stderr' -r 'echo php_ini_loaded_file();' 2> /dev/null`; \
+ if test "$$INI_FILE"; then \
+- $(EGREP) -h -v $(PHP_DEPRECATED_DIRECTIVES_REGEX) "$$INI_FILE" > $(top_builddir)/tmp-php.ini; \
++ $(EGREP) -h -v $(PHP_DEPRECATED_DIRECTIVES_REGEX) "$$INI_FILE" > $(top_builddir)/tmp-php.ini || :; \
+ else \
+ echo > $(top_builddir)/tmp-php.ini; \
+ fi; \
+ INI_SCANNED_PATH=`$(PHP_EXECUTABLE) -d 'display_errors=stderr' -r '$$a = explode(",\n", trim(php_ini_scanned_files())); echo $$a[0];' 2> /dev/null`; \
+ if test "$$INI_SCANNED_PATH"; then \
+ INI_SCANNED_PATH=`$(top_srcdir)/build/shtool path -d $$INI_SCANNED_PATH`; \
+- $(EGREP) -h -v $(PHP_DEPRECATED_DIRECTIVES_REGEX) "$$INI_SCANNED_PATH"/*.ini >> $(top_builddir)/tmp-php.ini; \
++ $(EGREP) -h -v $(PHP_DEPRECATED_DIRECTIVES_REGEX) "$$INI_SCANNED_PATH"/*.ini >> $(top_builddir)/tmp-php.ini || :; \
+ fi; \
+ TEST_PHP_EXECUTABLE=$(PHP_EXECUTABLE) \
+ TEST_PHP_SRCDIR=$(top_srcdir) \