aboutsummaryrefslogtreecommitdiff
path: root/lang/php5
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2006-01-30 16:10:57 +0000
committerAlex Dupre <ale@FreeBSD.org>2006-01-30 16:10:57 +0000
commitbc5f4400cab09be72917375134a672241c907dcc (patch)
tree7f8bf8e2cf60008a69fd366284bd6b5401dd1062 /lang/php5
parent3a55c0530cc4f725d340f78f89015f8a95919ce6 (diff)
downloadports-bc5f4400cab09be72917375134a672241c907dcc.tar.gz
ports-bc5f4400cab09be72917375134a672241c907dcc.zip
Notes
Diffstat (limited to 'lang/php5')
-rw-r--r--lang/php5/Makefile3
-rw-r--r--lang/php5/files/patch-ext_standard_basic_functions.c10
2 files changed, 12 insertions, 1 deletions
diff --git a/lang/php5/Makefile b/lang/php5/Makefile
index c3edd2427f86..4e33af8a9dca 100644
--- a/lang/php5/Makefile
+++ b/lang/php5/Makefile
@@ -7,7 +7,7 @@
PORTNAME= php5
PORTVERSION= 5.1.2
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= lang devel www
MASTER_SITES= ${MASTER_SITE_PHP:S,$,:release,} \
http://downloads.php.net/ilia/:rc \
@@ -25,6 +25,7 @@ USE_BZIP2= yes
.if !defined(PKGNAMESUFFIX) || ${PKGNAMESUFFIX} == "-cgi" || ${PKGNAMESUFFIX} == "-cli"
GNU_CONFIGURE= yes
USE_REINPLACE= yes
+USE_GETOPT_LONG=yes
CONFIGURE_ARGS= --enable-versioning \
--enable-memory-limit \
diff --git a/lang/php5/files/patch-ext_standard_basic_functions.c b/lang/php5/files/patch-ext_standard_basic_functions.c
new file mode 100644
index 000000000000..ffb8970fdc80
--- /dev/null
+++ b/lang/php5/files/patch-ext_standard_basic_functions.c
@@ -0,0 +1,10 @@
+--- ext/standard/basic_functions.c.orig Mon Jan 30 16:58:56 2006
++++ ext/standard/basic_functions.c Mon Jan 30 16:59:13 2006
+@@ -78,6 +78,7 @@
+ # include <sys/mman.h>
+ #endif
+
++#define HARTMUT_0
+ #ifdef HARTMUT_0
+ #include <getopt.h>
+ #endif