aboutsummaryrefslogtreecommitdiff
path: root/lang/php5
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2014-01-28 16:39:17 +0000
committerAlex Dupre <ale@FreeBSD.org>2014-01-28 16:39:17 +0000
commit9e8284183d8c13532f297b793f68ecdcb381846f (patch)
treed5203128b0b7e536f87f573e02627fb1f20220be /lang/php5
parent76f4e15643d7045c74725b7755fc3b675a2fee05 (diff)
downloadports-9e8284183d8c13532f297b793f68ecdcb381846f.tar.gz
ports-9e8284183d8c13532f297b793f68ecdcb381846f.zip
Notes
Diffstat (limited to 'lang/php5')
-rw-r--r--lang/php5/Makefile19
-rw-r--r--lang/php5/pkg-plist4
2 files changed, 8 insertions, 15 deletions
diff --git a/lang/php5/Makefile b/lang/php5/Makefile
index fee5a9bb213f..4c3298d77f35 100644
--- a/lang/php5/Makefile
+++ b/lang/php5/Makefile
@@ -39,6 +39,7 @@ USE_GNOME= libxml2
OPTIONS_DEFINE= CLI CGI FPM APACHE AP2FILTER EMBED DEBUG DTRACE IPV6 MAILHEAD LINKTHR ZTS
OPTIONS_DEFAULT=CLI CGI IPV6 LINKTHR
+OPTIONS_SUB= yes
CLI_DESC= Build CLI version
CGI_DESC= Build CGI version
@@ -71,17 +72,13 @@ PATCH_SITES+= http://choon.net/opensource/php/:mail
.if ${PORT_OPTIONS:MCLI}
PHP_SAPI+= cli
-PLIST_SUB+= CLI=""
.else
-PLIST_SUB+= CLI="@comment "
CONFIGURE_ARGS+=--disable-cli
.endif
.if ${PORT_OPTIONS:MCGI}
PHP_SAPI+= cgi
-PLIST_SUB+= CGI=""
.else
-PLIST_SUB+= CGI="@comment "
CONFIGURE_ARGS+=--disable-cgi
.endif
@@ -91,9 +88,6 @@ USE_RC_SUBR+= php-fpm
CONFIGURE_ARGS+=--enable-fpm \
--with-fpm-user=${WWWOWN} \
--with-fpm-group=${WWWGRP}
-PLIST_SUB+= FPM=""
-.else
-PLIST_SUB+= FPM="@comment "
.endif
.if ${PORT_OPTIONS:MAPACHE} && ${PORT_OPTIONS:MEMBED}
@@ -112,17 +106,17 @@ CONFIGURE_ARGS+=--with-apxs2=${APXS}
PKGMESSAGE= ${PKGDIR}/pkg-message.mod
MODULENAME= lib${PORTNAME}
SHORTMODNAME= ${PORTNAME}
-PLIST_SUB+= APACHE=""
-.else
-PLIST_SUB+= APACHE="@comment "
.endif
.if ${PORT_OPTIONS:MEMBED}
PHP_SAPI+= embed
CONFIGURE_ARGS+=--enable-embed
-PLIST_SUB+= EMBED=""
+.endif
+
+.if ${PORT_OPTIONS:MCLI} || ${PORT_OPTIONS:MEMBED}
+PLIST_SUB+= SAPI_INC=""
.else
-PLIST_SUB+= EMBED="@comment "
+PLIST_SUB+= SAPI_INC="@comment "
.endif
.if !defined(WITH_REGEX_TYPE) || ${WITH_REGEX_TYPE} == "php"
@@ -169,7 +163,6 @@ CONFIGURE_ARGS+=--disable-ipv6
post-patch:
@${TOUCH} ${WRKSRC}/ext/php_config.h
-# @${REINPLACE_CMD} -e 's|freetype/||g' ${WRKSRC}/config.m4
@${REINPLACE_CMD} "s|^\(extension_dir\)|; \1|" ${WRKSRC}/php.ini-*
.if ${PORT_OPTIONS:MFPM}
@${REINPLACE_CMD} -e "s|^;\(pid\)|\1|;s|^;\(pm\.[a-z_]*_servers\)|\1|" \
diff --git a/lang/php5/pkg-plist b/lang/php5/pkg-plist
index 3ac31938c8b0..aba12e9c2b83 100644
--- a/lang/php5/pkg-plist
+++ b/lang/php5/pkg-plist
@@ -258,9 +258,9 @@ man/man1/phpize.1.gz
@dirrmtry include/php/ext
@dirrm include/php/main/streams
@dirrm include/php/main
-@dirrm include/php/sapi/cli
+%%CLI%%@dirrm include/php/sapi/cli
%%EMBED%%@dirrm include/php/sapi/embed
-@dirrm include/php/sapi
+%%SAPI_INC%%@dirrmtry include/php/sapi
@dirrmtry include/php
@dirrm lib/php/build
@dirrmtry lib/php