aboutsummaryrefslogtreecommitdiff
path: root/lang/php5
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2013-08-12 12:54:12 +0000
committerAlex Dupre <ale@FreeBSD.org>2013-08-12 12:54:12 +0000
commitbfd6008211233d8ecf265b85765916b4881cc94a (patch)
treeb28502d403f440bdc8e5b74e9e67e5d99f722fa9 /lang/php5
parent745bd6e04bf41adc5f90aaff7c895cc755ad23a9 (diff)
downloadports-bfd6008211233d8ecf265b85765916b4881cc94a.tar.gz
ports-bfd6008211233d8ecf265b85765916b4881cc94a.zip
Notes
Diffstat (limited to 'lang/php5')
-rw-r--r--lang/php5/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/lang/php5/Makefile b/lang/php5/Makefile
index 599157c20d96..3948ce9a0349 100644
--- a/lang/php5/Makefile
+++ b/lang/php5/Makefile
@@ -38,7 +38,7 @@ CONFIGURE_ARGS= \
USE_GNOME= libxml2
-OPTIONS_DEFINE= CLI CGI FPM APACHE AP2FILTER EMBED DEBUG DTRACE IPV6 MAILHEAD LINKTHR
+OPTIONS_DEFINE= CLI CGI FPM APACHE AP2FILTER EMBED DEBUG DTRACE IPV6 MAILHEAD LINKTHR ZTS
OPTIONS_DEFAULT=CLI CGI IPV6 LINKTHR
CLI_DESC= Build CLI version
@@ -52,6 +52,7 @@ DTRACE_DESC= Enable DTrace support
IPV6_DESC= Enable ipv6 support
MAILHEAD_DESC= Enable mail header patch
LINKTHR_DESC= Link thread lib (for threaded extensions)
+ZTS_DESC= Force Zend Thread Safety (ZTS) build
CONFLICTS= php52-5* php53-5* php55-5*
@@ -150,6 +151,10 @@ CONFIGURE_ENV+= ac_cv_pthreads_lib="" \
CONFIGURE_ENV+= LIBS="${LIBS} ${PTHREAD_LIBS}"
.endif
+.if ${PORT_OPTIONS:MZTS}
+CONFIGURE_ARGS+=--enable-maintainer-zts
+.endif
+
.if ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+=--enable-debug
.endif