aboutsummaryrefslogtreecommitdiff
path: root/lang/php5
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2004-01-10 16:49:00 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2004-01-10 16:49:00 +0000
commitde6276d033d2821eea6e4328cc65a1b8bac1c780 (patch)
tree7efe9f82574c8ad0308c3639e0fbe22c723303fe /lang/php5
parent4bffc1044d7f4544f93954e65c985176f5effbe0 (diff)
downloadports-de6276d033d2821eea6e4328cc65a1b8bac1c780.tar.gz
ports-de6276d033d2821eea6e4328cc65a1b8bac1c780.zip
Notes
Diffstat (limited to 'lang/php5')
-rw-r--r--lang/php5/Makefile17
1 files changed, 11 insertions, 6 deletions
diff --git a/lang/php5/Makefile b/lang/php5/Makefile
index e8c890db86ac..72da22c10905 100644
--- a/lang/php5/Makefile
+++ b/lang/php5/Makefile
@@ -21,7 +21,7 @@
PORTNAME= php5
PORTVERSION= 5.0.0.a4
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES?= lang devel www
MASTER_SITES= http://www.php.net/distributions/:release \
http://it.php.net/distributions/:release \
@@ -87,11 +87,6 @@ CONFIGURE_ARGS+=--with-regex=apache
EXT_DIR= 20020429
SAPI_FILE= "@comment "
-.if defined(WITH_DEBUG)
-CONFIGURE_ARGS+=--enable-debug
-EXT_DIR:= ${EXT_DIR}-debug
-.endif
-
CONFLICTS= php5-cli-5* mod_php5-5* php5-cgi-5*
.if defined(WITHOUT_APACHE)
.if defined(WITHOUT_CLI)
@@ -527,11 +522,16 @@ CONFIGURE_ARGS+=--with-zlib
APXS?= ${LOCALBASE}/sbin/apxs
.if exists(${LOCALBASE}/include/apache2/apr.h)
WITH_APACHE2= yes
+APACHE_MPM!= ${APXS} -q MPM_NAME
.endif
.if defined(WITH_APACHE2)
+APACHE_MPM?= ${WITH_MPM}
APACHE_PORT?= www/apache2
CONFIGURE_ARGS+=--with-apxs2=${APXS}
SAPI_FILE= libexec/apache2/libphp5.so
+.if ${APACHE_MPM} == "worker"
+EXT_DIR:= ${EXT_DIR}-zts
+.endif
.else
APACHE_PORT?= www/apache13
CONFIGURE_ARGS+=--with-apxs=${APXS}
@@ -541,6 +541,11 @@ BUILD_DEPENDS+= ${APXS}:${PORTSDIR}/${APACHE_PORT}
RUN_DEPENDS+= ${APXS}:${PORTSDIR}/${APACHE_PORT}
.endif
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+=--enable-debug
+EXT_DIR:= ${EXT_DIR}-debug
+.endif
+
PLIST_SUB+= SAPI_FILE=${SAPI_FILE}
.if ${OSVERSION} < 400014 || defined(WITHOUT_IPV6)