aboutsummaryrefslogtreecommitdiff
path: root/lang/php5
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2010-04-09 09:34:43 +0000
committerAlex Dupre <ale@FreeBSD.org>2010-04-09 09:34:43 +0000
commit538a6d28a2487de32d66420074ba8609f4b2eab1 (patch)
tree54e230d33cb834db8c435ae3432993ffdb5bbd9e /lang/php5
parent4720812c1a87616a90aeeddb8f06a78ced307b32 (diff)
downloadports-538a6d28a2487de32d66420074ba8609f4b2eab1.tar.gz
ports-538a6d28a2487de32d66420074ba8609f4b2eab1.zip
Notes
Diffstat (limited to 'lang/php5')
-rw-r--r--lang/php5/Makefile53
-rw-r--r--lang/php5/Makefile.ext96
-rw-r--r--lang/php5/distinfo18
-rw-r--r--lang/php5/files/patch-Zend::zend.h14
-rw-r--r--lang/php5/files/patch-configure.in20
-rw-r--r--lang/php5/files/patch-ext_standard_array.c33
-rw-r--r--lang/php5/files/patch-ext_standard_basic_functions.c8
-rw-r--r--lang/php5/files/patch-ext_standard_php_dns.h13
-rw-r--r--lang/php5/files/patch-php.ini-development (renamed from lang/php5/files/patch-php.ini-recommended)14
-rw-r--r--lang/php5/files/patch-php.ini-production (renamed from lang/php5/files/patch-php.ini-dist)10
-rw-r--r--lang/php5/files/patch-sapi_cgi_config9.m423
-rw-r--r--lang/php5/pkg-plist56
12 files changed, 131 insertions, 227 deletions
diff --git a/lang/php5/Makefile b/lang/php5/Makefile
index ffa10b498b51..12588c35907f 100644
--- a/lang/php5/Makefile
+++ b/lang/php5/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= php5
-PORTVERSION= 5.2.12
-PORTREVISION?= 2
+PORTVERSION= 5.3.2
+PORTREVISION?= 0
CATEGORIES?= lang devel www
MASTER_SITES= ${MASTER_SITE_PHP}
MASTER_SITE_SUBDIR= distributions
@@ -29,7 +29,6 @@ CONFIGURE_ARGS= \
--disable-all \
--enable-libxml \
--with-libxml-dir=${LOCALBASE} \
- --enable-reflection \
--program-prefix=""
USE_GNOME= libxml2
@@ -38,14 +37,10 @@ OPTIONS= CLI "Build CLI version" on \
CGI "Build CGI version" on \
APACHE "Build Apache module" off \
DEBUG "Enable debug" off \
- SUHOSIN "Enable Suhosin protection system (not for jails)" on \
+ SUHOSIN "Enable Suhosin protection system" on \
MULTIBYTE "Enable zend multibyte support" off \
IPV6 "Enable ipv6 support" on \
- MAILHEAD "Enable mail header patch" off \
- REDIRECT "Enable force-cgi-redirect support (CGI only)" off \
- DISCARD "Enable discard-path support (CGI only)" off \
- FASTCGI "Enable fastcgi support (CGI only)" on \
- PATHINFO "Enable path-info-check support (CGI only)" on
+ MAILHEAD "Enable mail header patch" off
CONFLICTS= php4-4*
@@ -56,8 +51,7 @@ MAN1= php-config.1 phpize.1
PATCH_DIST_STRIP= -p1
.if !defined(WITHOUT_SUHOSIN)
-#PATCHFILES+= suhosin-patch-${PORTVERSION}-0.9.7.patch.gz:suhosin
-PATCHFILES+= suhosin-patch-5.2.11-0.9.7.patch.gz:suhosin
+PATCHFILES+= suhosin-patch-${PORTVERSION}-0.9.9.1.patch.gz:suhosin
PATCH_SITES+= http://download.suhosin.org/:suhosin
PLIST_SUB+= SUHOSIN=""
.else
@@ -65,8 +59,7 @@ PLIST_SUB+= SUHOSIN="@comment "
.endif
.if defined(WITH_MAILHEAD)
-#PATCHFILES+= php-${PORTVERSION}-mail-header.patch:mail
-PATCHFILES+= php-5.2.10-mail-header.patch:mail
+PATCHFILES+= php-${PORTVERSION}-mail-header.patch:mail
PATCH_SITES+= http://choon.net/opensource/php/:mail
.endif
@@ -82,18 +75,6 @@ CONFIGURE_ARGS+=--disable-cli
.if !defined(WITHOUT_CGI)
PHP_SAPI+= cgi
PLIST_SUB+= CGI=""
-.if defined(WITH_REDIRECT)
-CONFIGURE_ARGS+=--enable-force-cgi-redirect
-.endif
-.if defined(WITH_DISCARD)
-CONFIGURE_ARGS+=--enable-discard-path
-.endif
-.if !defined(WITHOUT_FASTCGI)
-CONFIGURE_ARGS+=--enable-fastcgi
-.endif
-.if defined(WITHOUT_PATHINFO)
-CONFIGURE_ARGS+=--disable-path-info-check
-.endif
.else
PLIST_SUB+= CGI="@comment "
CONFIGURE_ARGS+=--disable-cgi
@@ -105,6 +86,9 @@ USE_APACHE= 1.3+
.include "${PORTSDIR}/Mk/bsd.apache.mk"
.if ${APACHE_VERSION} > 13
CONFIGURE_ARGS+=--with-apxs2=${APXS}
+.if ${APACHE_VERSION} == 20
+WITH_BUNDLED_PCRE= yes
+.endif
.else
CONFIGURE_ARGS+=--with-apxs=${APXS}
.endif
@@ -116,12 +100,19 @@ PLIST_SUB+= APACHE=""
PLIST_SUB+= APACHE="@comment "
.endif
+.if defined(WITH_BUNDLED_PCRE)
+CONFIGURE_ARGS+=--with-pcre-regex=yes
+PLIST_SUB+= PCRE=""
+.else
+LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
+CONFIGURE_ARGS+=--with-pcre-regex=${LOCALBASE}
+PLIST_SUB+= PCRE="@comment "
+.endif
+
.if !defined(WITH_REGEX_TYPE) || ${WITH_REGEX_TYPE} == "php"
CONFIGURE_ARGS+=--with-regex=php
.elif defined(WITH_REGEX_TYPE) && ${WITH_REGEX_TYPE} == "system"
CONFIGURE_ARGS+=--with-regex=system
-.elif defined(WITH_REGEX_TYPE) && ${WITH_REGEX_TYPE} == "apache"
-CONFIGURE_ARGS+=--with-regex=apache
.endif
.if !defined(WITH_ZEND_VM) || ${WITH_ZEND_VM} == "CALL"
@@ -162,10 +153,14 @@ post-build:
@${ECHO_CMD} "PHP_VER=5" > ${WRKDIR}/php.conf
@${ECHO_CMD} "PHP_VERSION=${PORTVERSION}" >> ${WRKDIR}/php.conf
@${ECHO_CMD} "PHP_SAPI=${PHP_SAPI}" >> ${WRKDIR}/php.conf
+ @${ECHO_CMD} "PHP_EXT_INC=pcre spl" >> ${WRKDIR}/php.conf
+
+test: build
+ @(cd ${WRKSRC} && ${MAKE} test)
post-install:
- @${INSTALL_DATA} ${WRKSRC}/php.ini-dist ${PREFIX}/etc
- @${INSTALL_DATA} ${WRKSRC}/php.ini-recommended ${PREFIX}/etc
+ @${INSTALL_DATA} ${WRKSRC}/php.ini-development ${PREFIX}/etc
+ @${INSTALL_DATA} ${WRKSRC}/php.ini-production ${PREFIX}/etc
@${INSTALL_DATA} ${WRKDIR}/php.conf ${PREFIX}/etc
@${TOUCH} ${PREFIX}/include/php/ext/php_config.h
.if defined(WITH_APACHE)
diff --git a/lang/php5/Makefile.ext b/lang/php5/Makefile.ext
index 7c04f1338cfb..f5915d4b8018 100644
--- a/lang/php5/Makefile.ext
+++ b/lang/php5/Makefile.ext
@@ -20,13 +20,7 @@ PHP_HEADER_DIRS=libbcmath libbcmath/src
.endif
.if ${PHP_MODNAME} == "bz2"
-.if exists(/usr/bin/bzip2)
-BZ2BASE= /usr
-.else
-BZ2BASE= ${LOCALBASE}
-LIB_DEPENDS+= bz2.1:${PORTSDIR}/archivers/bzip2
-.endif
-CONFIGURE_ARGS+=--with-bz2=${BZ2BASE}
+CONFIGURE_ARGS+=--with-bz2=/usr
.endif
.if ${PHP_MODNAME} == "calendar"
@@ -56,18 +50,11 @@ OPTIONS= CDB "cdb database support" on \
PHP_HEADER_DIRS= libcdb libflatfile libinifile
.endif
-.if ${PHP_MODNAME} == "dbase"
-CONFIGURE_ARGS+=--enable-dbase
-.endif
-
.if ${PHP_MODNAME} == "dom"
CONFIGURE_ARGS+=--enable-dom \
--with-libxml-dir=${LOCALBASE}
USE_GNOME= libxml2
-
-USE_PHP= spl
-USE_PHP_BUILD= yes
.endif
.if ${PHP_MODNAME} == "exif"
@@ -77,9 +64,6 @@ CONFIGURE_ARGS+=--enable-exif
.if ${PHP_MODNAME} == "filter"
CONFIGURE_ARGS+=--enable-filter \
--with-pcre-dir=${LOCALBASE}
-
-USE_PHP= pcre
-USE_PHP_BUILD= yes
.endif
.if ${PHP_MODNAME} == "ftp"
@@ -127,12 +111,12 @@ CONFIGURE_ARGS+=--with-gmp=${LOCALBASE}
.endif
.if ${PHP_MODNAME} == "hash"
-CONFIGURE_ARGS+=--enable-hash
+CONFIGURE_ARGS+=--enable-hash \
+ --with-mhash
.endif
.if ${PHP_MODNAME} == "iconv"
-CONFIGURE_ARGS+=--with-iconv=${LOCALBASE} \
- --with-iconv-dir=${LOCALBASE}
+CONFIGURE_ARGS+=--with-iconv=${LOCALBASE}
USE_ICONV= yes
.endif
@@ -140,7 +124,8 @@ USE_ICONV= yes
.if ${PHP_MODNAME} == "imap"
LIB_DEPENDS+= c-client4.9:${PORTSDIR}/mail/cclient
-CONFIGURE_ARGS+=--with-imap=${LOCALBASE}
+CONFIGURE_ARGS+=--with-imap=${LOCALBASE} \
+ --with-pcre-dir=${LOCALBASE}
.if !defined(WITHOUT_SSL)
CONFIGURE_ARGS+=--with-imap-ssl=${OPENSSLBASE}
@@ -170,11 +155,14 @@ CONFIGURE_ARGS+=--with-ldap-sasl
.endif
.if ${PHP_MODNAME} == "mbstring"
-CONFIGURE_ARGS+=--enable-mbstring
+LIB_DEPENDS+= onig.1:${PORTSDIR}/devel/oniguruma4
+
+CONFIGURE_ARGS+=--enable-mbstring \
+ --with-onig=${LOCALBASE}
OPTIONS= REGEX "Enable multibyte regex support" on
-PHP_HEADER_DIRS=libmbfl libmbfl/filters libmbfl/mbfl libmbfl/nls oniguruma
+PHP_HEADER_DIRS=libmbfl libmbfl/filters libmbfl/mbfl libmbfl/nls
.endif
.if ${PHP_MODNAME} == "mcrypt"
@@ -185,18 +173,6 @@ CONFIGURE_ARGS+=--with-mcrypt=${LOCALBASE}
USE_AUTOTOOLS= libltdl:22
.endif
-.if ${PHP_MODNAME} == "mhash"
-LIB_DEPENDS+= mhash.2:${PORTSDIR}/security/mhash
-
-CONFIGURE_ARGS+=--with-mhash=${LOCALBASE}
-.endif
-
-.if ${PHP_MODNAME} == "ming"
-LIB_DEPENDS+= ming.4:${PORTSDIR}/graphics/ming
-
-CONFIGURE_ARGS+=--with-ming=${LOCALBASE}
-.endif
-
.if ${PHP_MODNAME} == "mssql"
LIB_DEPENDS+= sybdb.5:${PORTSDIR}/databases/freetds-msdblib
@@ -215,13 +191,6 @@ CONFIGURE_ARGS+=--with-mysqli=${LOCALBASE}/bin/mysql_config
USE_MYSQL= yes
BROKEN_WITH_MYSQL= 323 40
-
-USE_PHP= spl
-USE_PHP_BUILD= yes
-.endif
-
-.if ${PHP_MODNAME} == "ncurses"
-CONFIGURE_ARGS+=--with-ncurses=/usr
.endif
.if ${PHP_MODNAME} == "oci8"
@@ -249,10 +218,6 @@ USE_OPENSSL= yes
CONFIGURE_ARGS+=--enable-pcntl
.endif
-.if ${PHP_MODNAME} == "pcre"
-OPTIONS= BUNDLED_PCRE "Select if you use apache 2.0.x" off
-.endif
-
.if ${PHP_MODNAME} == "pdo"
CONFIGURE_ARGS+=--enable-pdo
.endif
@@ -315,19 +280,13 @@ USE_PHP_BUILD= yes
.endif
.if ${PHP_MODNAME} == "pdo_sqlite"
-. if defined(WITH_SQLITE_PORT)
-USE_SQLITE= yes
+USE_SQLITE= yes
CONFIGURE_ARGS+=--with-pdo-sqlite=${LOCALBASE}
-. else
-CONFIGURE_ARGS+=--with-pdo-sqlite
-. endif
USE_PHP= pdo
USE_PHP_BUILD= yes
-PHP_HEADER_DIRS=sqlite/src
.endif
-
.if ${PHP_MODNAME} == "pgsql"
USE_PGSQL= yes
@@ -393,16 +352,6 @@ USE_PHP= session
USE_PHP_BUILD= yes
.endif
-.if ${PHP_MODNAME} == "spl"
-CONFIGURE_ARGS+=--enable-spl \
- --with-libxml-dir=${LOCALBASE}
-
-USE_GNOME= libxml2
-
-USE_PHP= pcre simplexml
-USE_PHP_BUILD= yes
-.endif
-
.if ${PHP_MODNAME} == "sockets"
CONFIGURE_ARGS+=--enable-sockets
.endif
@@ -414,9 +363,6 @@ USE_PHP= session
USE_PHP_BUILD= yes
PHP_HEADER_DIRS=libsqlite/src
-USE_PHP= spl
-USE_PHP_BUILD= yes
-
OPTIONS= UTF8 "Enable UTF-8 support" off
.endif
@@ -506,7 +452,8 @@ USE_PHP_BUILD= yes
.if ${PHP_MODNAME} == "zip"
CONFIGURE_ARGS+=--enable-zip \
- --with-zlib-dir=/usr
+ --with-zlib-dir=/usr \
+ --with-pcre-dir=${LOCALBASE}
.endif
.if ${PHP_MODNAME} == "zlib"
@@ -577,21 +524,6 @@ pre-configure:
/usr/bin/ar rcs liboci8.a *.o
.endif
-.if ${PHP_MODNAME} == "pcre"
-. if defined(WITH_BUNDLED_PCRE)
-CONFIGURE_ARGS+=--with-pcre-regex=yes
-
-PHP_HEADER_DIRS=pcrelib
-. else
-LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
-
-CONFIGURE_ARGS+=--with-pcre-regex=${LOCALBASE}
-. endif
-
-post-extract:
- @${MV} ${WRKSRC}/config0.m4 ${WRKSRC}/config.m4
-.endif
-
.if ${PHP_MODNAME} == "pdo_dblib"
.if defined(WITH_MSSQL)
LIB_DEPENDS+= sybdb.5:${PORTSDIR}/databases/freetds-msdblib
diff --git a/lang/php5/distinfo b/lang/php5/distinfo
index 0f0bbaba1d64..2a2b7d17372a 100644
--- a/lang/php5/distinfo
+++ b/lang/php5/distinfo
@@ -1,9 +1,9 @@
-MD5 (php-5.2.12.tar.bz2) = 5b7077e366c7eeab34da31dd860a1923
-SHA256 (php-5.2.12.tar.bz2) = e65756a8412726a491ca48da1e0693eaeb3f38f19fb6cbc8f53005cab1f2491a
-SIZE (php-5.2.12.tar.bz2) = 9075161
-MD5 (suhosin-patch-5.2.11-0.9.7.patch.gz) = 8f9de4d97fae6eba163cf3699509a260
-SHA256 (suhosin-patch-5.2.11-0.9.7.patch.gz) = 392f10c9b7d9c47f30e989fb7775cc46d36153b933bf7ac9ccd8826b2954584b
-SIZE (suhosin-patch-5.2.11-0.9.7.patch.gz) = 23050
-MD5 (php-5.2.10-mail-header.patch) = 7f73682e78d32e22989c3fb3678d668b
-SHA256 (php-5.2.10-mail-header.patch) = a61d50540f4aae32390118453845c380fe935b6d1e46cef6819c8561946e942f
-SIZE (php-5.2.10-mail-header.patch) = 3383
+MD5 (php-5.3.2.tar.bz2) = 46f500816125202c48a458d0133254a4
+SHA256 (php-5.3.2.tar.bz2) = 9a380a574adcb3a9abe3226e7c3a9bae619e8a1b90842ec2a7edf0ad92afdeda
+SIZE (php-5.3.2.tar.bz2) = 10477662
+MD5 (suhosin-patch-5.3.2-0.9.9.1.patch.gz) = 4647b05330862d6a1fc4469245cc6ade
+SHA256 (suhosin-patch-5.3.2-0.9.9.1.patch.gz) = a61f081022888bf78997e434744d6c0604194c73a00e70c1165524a0a6329de2
+SIZE (suhosin-patch-5.3.2-0.9.9.1.patch.gz) = 40847
+MD5 (php-5.3.2-mail-header.patch) = 012d8c4637422e724d5559513fcaaacb
+SHA256 (php-5.3.2-mail-header.patch) = 3c9faeef9080330a23286f787efec8489587c619d8910d70926359f1a9306d6c
+SIZE (php-5.3.2-mail-header.patch) = 3350
diff --git a/lang/php5/files/patch-Zend::zend.h b/lang/php5/files/patch-Zend::zend.h
index 49d678719636..0fb2398f171d 100644
--- a/lang/php5/files/patch-Zend::zend.h
+++ b/lang/php5/files/patch-Zend::zend.h
@@ -1,11 +1,11 @@
---- Zend/zend.h.orig Tue Nov 15 14:35:22 2005
-+++ Zend/zend.h Fri Nov 25 09:31:48 2005
-@@ -178,7 +178,7 @@
+--- Zend/zend.h.orig 2008-08-15 21:47:23.000000000 +0200
++++ Zend/zend.h 2008-09-25 22:52:50.000000000 +0200
+@@ -192,7 +192,7 @@
+ # define ZEND_FASTCALL
#endif
-
-#if (HAVE_ALLOCA || (defined (__GNUC__) && __GNUC__ >= 2)) && !(defined(ZTS) && defined(ZEND_WIN32)) && !(defined(ZTS) && defined(NETWARE)) && !(defined(ZTS) && defined(HPUX)) && !defined(DARWIN)
+#if (HAVE_ALLOCA || (defined (__GNUC__) && __GNUC__ >= 2)) && !(defined(ZTS) && defined(ZEND_WIN32)) && !(defined(ZTS) && defined(NETWARE)) && !(defined(ZTS) && defined(HPUX)) && !defined(DARWIN) && !(defined(ZTS) && defined(__FreeBSD__))
- # define do_alloca(p) alloca(p)
- # define free_alloca(p)
- #else
+ # define ZEND_ALLOCA_MAX_SIZE (32 * 1024)
+ # define ALLOCA_FLAG(name) \
+ zend_bool name;
diff --git a/lang/php5/files/patch-configure.in b/lang/php5/files/patch-configure.in
index f5f5c5a113c9..3cdb4241f6a2 100644
--- a/lang/php5/files/patch-configure.in
+++ b/lang/php5/files/patch-configure.in
@@ -25,14 +25,14 @@
exec_prefix=$old_exec_prefix
libdir=$old_libdir
-@@ -1344,22 +1342,19 @@
- INLINE_CFLAGS="$INLINE_CFLAGS $standard_libtool_flag"
- CXXFLAGS="$CXXFLAGS $standard_libtool_flag"
-
--all_targets="$lcov_target \$(OVERALL_TARGET) \$(PHP_MODULES) \$(PHP_ZEND_EX) \$(PHP_CLI_TARGET)"
--install_targets="$install_modules install-build install-headers install-programs $install_pear"
-+all_targets="$lcov_target \$(OVERALL_TARGET) \$(PHP_MODULES) \$(PHP_ZEND_EX) \$(PHP_CLI_TARGET) \$(PHP_CGI_TARGET)"
-+install_targets="$PHP_INSTALL_CLI_TARGET $PHP_INSTALL_CGI_TARGET $install_modules install-build install-headers install-programs $install_pear"
+@@ -1388,22 +1386,19 @@
+ pharcmd_install=
+ fi;
+
+-all_targets="$lcov_target \$(OVERALL_TARGET) \$(PHP_MODULES) \$(PHP_ZEND_EX) \$(PHP_CLI_TARGET) $pharcmd"
+-install_targets="$install_modules install-build install-headers install-programs $install_pear $pharcmd_install"
++all_targets="$lcov_target \$(OVERALL_TARGET) \$(PHP_MODULES) \$(PHP_ZEND_EX) \$(PHP_CLI_TARGET) \$(PHP_CGI_TARGET) $pharcmd"
++install_targets="$PHP_INSTALL_CLI_TARGET $PHP_INSTALL_CGI_TARGET $install_modules install-build install-headers install-programs $install_pear $pharcmd_install"
case $PHP_SAPI in
- cli)
@@ -48,8 +48,8 @@
PHP_SUBST(all_targets)
PHP_SUBST(install_targets)
--PHP_INSTALL_HEADERS([Zend/ TSRM/ include/ main/ main/streams/ regex/])
-+PHP_INSTALL_HEADERS([Zend/ TSRM/ main/ main/streams/ regex/])
+-PHP_INSTALL_HEADERS([Zend/ TSRM/ include/ main/ main/streams/])
++PHP_INSTALL_HEADERS([Zend/ TSRM/ main/ main/streams/])
PHP_ADD_SOURCES(TSRM, TSRM.c tsrm_strtok_r.c tsrm_virtual_cwd.c)
diff --git a/lang/php5/files/patch-ext_standard_array.c b/lang/php5/files/patch-ext_standard_array.c
deleted file mode 100644
index bd6d4d0c95d4..000000000000
--- a/lang/php5/files/patch-ext_standard_array.c
+++ /dev/null
@@ -1,33 +0,0 @@
---- ext/standard/array.c.orig Mon Feb 12 20:20:48 2007
-+++ ext/standard/array.c Mon Feb 12 20:22:14 2007
-@@ -295,6 +295,7 @@
- PHP_FUNCTION(count)
- {
- zval *array;
-+ zend_class_entry **ce_Countable;
- long mode = COUNT_NORMAL;
-
- if (zend_parse_parameters (ZEND_NUM_ARGS() TSRMLS_CC, "z|l", &array, &mode) == FAILURE)
-@@ -308,11 +309,11 @@
- RETURN_LONG (php_count_recursive (array, mode TSRMLS_CC));
- break;
- case IS_OBJECT: {
--#ifdef HAVE_SPL
- /* it the object implements Countable we call its count() method */
- zval *retval;
-
-- if (Z_OBJ_HT_P(array)->get_class_entry && instanceof_function(Z_OBJCE_P(array), spl_ce_Countable TSRMLS_CC)) {
-+ if (zend_lookup_class_ex("Countable", 9, 0, &ce_Countable TSRMLS_CC) != FAILURE) {
-+ if (Z_OBJ_HT_P(array)->get_class_entry && instanceof_function(Z_OBJCE_P(array), *ce_Countable TSRMLS_CC)) {
- zend_call_method_with_0_params(&array, NULL, NULL, "count", &retval);
- if (retval) {
- convert_to_long(retval);
-@@ -321,7 +322,7 @@
- }
- return;
- }
--#endif
-+ }
- /* if not we return the number of properties (not taking visibility into account) */
- if (Z_OBJ_HT_P(array)->count_elements) {
- RETVAL_LONG(1);
diff --git a/lang/php5/files/patch-ext_standard_basic_functions.c b/lang/php5/files/patch-ext_standard_basic_functions.c
index 9ef6dd343cbf..1907338d0298 100644
--- a/lang/php5/files/patch-ext_standard_basic_functions.c
+++ b/lang/php5/files/patch-ext_standard_basic_functions.c
@@ -1,13 +1,5 @@
--- ext/standard/basic_functions.c.orig 2008-06-09 14:06:40.000000000 +0200
+++ ext/standard/basic_functions.c 2008-06-09 14:08:28.000000000 +0200
-@@ -87,6 +87,7 @@
- # include <sys/loadavg.h>
- #endif
-
-+#define HARTMUT_0
- #ifdef HARTMUT_0
- #include <getopt.h>
- #endif
@@ -3859,7 +3860,7 @@
SetEnvironmentVariable(pe->key, "bugbug");
#endif
diff --git a/lang/php5/files/patch-ext_standard_php_dns.h b/lang/php5/files/patch-ext_standard_php_dns.h
deleted file mode 100644
index 8ab9e9c01d38..000000000000
--- a/lang/php5/files/patch-ext_standard_php_dns.h
+++ /dev/null
@@ -1,13 +0,0 @@
---- ext/standard/php_dns.h.orig Sun Jun 19 11:57:31 2005
-+++ ext/standard/php_dns.h Sun Jun 19 12:03:37 2005
-@@ -25,6 +25,10 @@
-
- #if HAVE_RES_NMKQUERY && HAVE_RES_NSEND && HAVE_DN_EXPAND && HAVE_DN_SKIPNAME
- #define HAVE_DNS_FUNCS 1
-+#define res_ninit __res_ninit
-+#define res_nmkquery __res_nmkquery
-+#define res_nsend __res_nsend
-+#define res_nclose __res_nclose
- #endif
-
- PHP_FUNCTION(gethostbyaddr);
diff --git a/lang/php5/files/patch-php.ini-recommended b/lang/php5/files/patch-php.ini-development
index 7b648b1ea0b5..dadeb4b838b1 100644
--- a/lang/php5/files/patch-php.ini-recommended
+++ b/lang/php5/files/patch-php.ini-development
@@ -1,18 +1,18 @@
---- php.ini-recommended.orig Fri Dec 30 18:19:43 2005
-+++ php.ini-recommended Mon Oct 16 08:13:05 2006
-@@ -223,6 +223,15 @@
- ;
+--- php.ini-development.orig 2009-06-28 19:56:18.000000000 +0200
++++ php.ini-development 2009-08-24 17:17:53.000000000 +0200
+@@ -335,6 +335,15 @@
+
; Safe Mode
- ;
+ ; http://php.net/safe-mode
++;
+; SECURITY NOTE: The FreeBSD Security Officer strongly recommend that
+; the PHP Safe Mode feature not be relied upon for security, since the
+; issues Safe Mode tries to handle cannot properly be handled in PHP
+; (primarily due to PHP's use of external libraries). While many bugs
+; in Safe Mode has been fixed it's very likely that more issues exist
+; which allows a user to bypass Safe Mode restrictions.
-+; For increased security we recommend to always install the Suhosin
++; For increased security we always recommend to install the Suhosin
+; extension.
-+;
safe_mode = Off
; By default, Safe Mode does a UID compare check when
diff --git a/lang/php5/files/patch-php.ini-dist b/lang/php5/files/patch-php.ini-production
index 6d84f3a80891..67d3480ad4a6 100644
--- a/lang/php5/files/patch-php.ini-dist
+++ b/lang/php5/files/patch-php.ini-production
@@ -1,9 +1,10 @@
---- php.ini-dist.orig Fri Dec 30 18:19:43 2005
-+++ php.ini-dist Mon Oct 16 08:12:28 2006
-@@ -165,6 +165,15 @@
+--- php.ini-production.orig 2009-08-24 17:18:23.000000000 +0200
++++ php.ini-production 2009-08-24 17:18:33.000000000 +0200
+@@ -335,6 +335,15 @@
; Safe Mode
- ;
+ ; http://php.net/safe-mode
++;
+; SECURITY NOTE: The FreeBSD Security Officer strongly recommend that
+; the PHP Safe Mode feature not be relied upon for security, since the
+; issues Safe Mode tries to handle cannot properly be handled in PHP
@@ -12,7 +13,6 @@
+; which allows a user to bypass Safe Mode restrictions.
+; For increased security we always recommend to install the Suhosin
+; extension.
-+;
safe_mode = Off
; By default, Safe Mode does a UID compare check when
diff --git a/lang/php5/files/patch-sapi_cgi_config9.m4 b/lang/php5/files/patch-sapi_cgi_config9.m4
index c40894155cc8..7682dad43110 100644
--- a/lang/php5/files/patch-sapi_cgi_config9.m4
+++ b/lang/php5/files/patch-sapi_cgi_config9.m4
@@ -1,6 +1,6 @@
---- sapi/cgi/config9.m4.orig Thu Jul 12 01:20:36 2007
-+++ sapi/cgi/config9.m4 Wed Sep 5 07:55:06 2007
-@@ -25,7 +25,6 @@
+--- sapi/cgi/config9.m4.orig 2007-10-01 14:40:54.000000000 +0200
++++ sapi/cgi/config9.m4 2008-09-25 23:07:13.000000000 +0200
+@@ -8,7 +8,6 @@
dnl
dnl CGI setup
dnl
@@ -8,19 +8,19 @@
AC_MSG_CHECKING(whether to build CGI binary)
if test "$PHP_CGI" != "no"; then
AC_MSG_RESULT(yes)
-@@ -85,8 +84,9 @@
- AC_MSG_RESULT($PHP_PATH_INFO_CHECK)
+@@ -53,8 +52,9 @@
+ PHP_SUBST(SAPI_CGI_PATH)
dnl Set install target and select SAPI
- INSTALL_IT="@echo \"Installing PHP CGI binary: \$(INSTALL_ROOT)\$(bindir)/\"; \$(INSTALL) -m 0755 \$(SAPI_CGI_PATH) \$(INSTALL_ROOT)\$(bindir)/\$(program_prefix)php-cgi\$(program_suffix)\$(EXEEXT)"
-- PHP_SELECT_SAPI(cgi, program, $PHP_FCGI_FILES cgi_main.c getopt.c,, '$(SAPI_CGI_PATH)')
+- PHP_SELECT_SAPI(cgi, program, cgi_main.c fastcgi.c,, '$(SAPI_CGI_PATH)')
+ INSTALL_CGI="@echo \"Installing PHP CGI binary: \$(INSTALL_ROOT)\$(bindir)/\"; \$(INSTALL) -m 0755 \$(SAPI_CGI_PATH) \$(INSTALL_ROOT)\$(bindir)/\$(program_prefix)php-cgi\$(program_suffix)\$(EXEEXT)"
-+ PHP_ADD_SOURCES(sapi/cgi, $PHP_FCGI_FILES cgi_main.c getopt.c,, cgi)
++ PHP_ADD_SOURCES(sapi/cgi, cgi_main.c fastcgi.c,, cgi)
+ PHP_ADD_SOURCES(/main, internal_functions.c,,cgi)
case $host_alias in
*aix*)
-@@ -96,17 +96,29 @@
+@@ -64,17 +64,29 @@
BUILD_CGI="\$(CC) \$(CFLAGS_CLEAN) \$(EXTRA_CFLAGS) \$(EXTRA_LDFLAGS_PROGRAM) \$(LDFLAGS) \$(NATIVE_RPATHS) \$(PHP_GLOBAL_OBJS:.lo=.o) \$(PHP_SAPI_OBJS:.lo=.o) \$(PHP_FRAMEWORKS) \$(EXTRA_LIBS) \$(ZEND_EXTRA_LIBS) -o \$(SAPI_CGI_PATH)"
;;
*)
@@ -32,13 +32,14 @@
+ PHP_CGI_TARGET="\$(SAPI_CGI_PATH)"
+ PHP_INSTALL_CGI_TARGET="install-cgi"
PHP_SUBST(BUILD_CGI)
+-
+- elif test "$PHP_CLI" != "no"; then
+- AC_MSG_RESULT(no)
+ PHP_SUBST(INSTALL_CGI)
+ PHP_SUBST(PHP_CGI_OBJS)
+ PHP_SUBST(PHP_CGI_TARGET)
+ PHP_SUBST(PHP_INSTALL_CGI_TARGET)
-
-- elif test "$PHP_CLI" != "no"; then
-- AC_MSG_RESULT(no)
++
+ if test "$PHP_SAPI" = "default" ; then
+ PHP_BUILD_PROGRAM($SAPI_CGI_PATH)
+ fi
diff --git a/lang/php5/pkg-plist b/lang/php5/pkg-plist
index d5d252f247f7..d10208092c53 100644
--- a/lang/php5/pkg-plist
+++ b/lang/php5/pkg-plist
@@ -3,8 +3,8 @@
bin/php-config
bin/phpize
etc/php.conf
-etc/php.ini-dist
-etc/php.ini-recommended
+etc/php.ini-development
+etc/php.ini-production
include/php/TSRM/TSRM.h
include/php/TSRM/acconfig.h
include/php/TSRM/readdir.h
@@ -15,12 +15,13 @@ include/php/TSRM/tsrm_nw.h
include/php/TSRM/tsrm_strtok_r.h
include/php/TSRM/tsrm_virtual_cwd.h
include/php/TSRM/tsrm_win32.h
-include/php/Zend/FlexLexer.h
include/php/Zend/acconfig.h
include/php/Zend/zend.h
include/php/Zend/zend_API.h
include/php/Zend/zend_alloc.h
+include/php/Zend/zend_build.h
include/php/Zend/zend_builtin_functions.h
+include/php/Zend/zend_closures.h
include/php/Zend/zend_compile.h
include/php/Zend/zend_config.h
include/php/Zend/zend_config.nw.h
@@ -32,6 +33,8 @@ include/php/Zend/zend_exceptions.h
include/php/Zend/zend_execute.h
include/php/Zend/zend_extensions.h
include/php/Zend/zend_fast_cache.h
+include/php/Zend/zend_float.h
+include/php/Zend/zend_gc.h
include/php/Zend/zend_globals.h
include/php/Zend/zend_globals_macros.h
include/php/Zend/zend_hash.h
@@ -40,11 +43,13 @@ include/php/Zend/zend_indent.h
include/php/Zend/zend_ini.h
include/php/Zend/zend_ini_parser.h
include/php/Zend/zend_ini_scanner.h
+include/php/Zend/zend_ini_scanner_defs.h
include/php/Zend/zend_interfaces.h
include/php/Zend/zend_istdiostream.h
include/php/Zend/zend_iterators.h
include/php/Zend/zend_language_parser.h
include/php/Zend/zend_language_scanner.h
+include/php/Zend/zend_language_scanner_defs.h
include/php/Zend/zend_list.h
include/php/Zend/zend_llist.h
include/php/Zend/zend_modules.h
@@ -71,13 +76,38 @@ include/php/ext/date/lib/timelib.h
include/php/ext/date/lib/timelib_config.h
include/php/ext/date/lib/timelib_structs.h
include/php/ext/date/php_date.h
+include/php/ext/ereg/php_ereg.h
+include/php/ext/ereg/php_regex.h
+include/php/ext/ereg/regex/cclass.h
+include/php/ext/ereg/regex/cname.h
+include/php/ext/ereg/regex/regex.h
+include/php/ext/ereg/regex/regex2.h
+include/php/ext/ereg/regex/utils.h
include/php/ext/libxml/php_libxml.h
+%%PCRE%%include/php/ext/pcre/pcrelib/config.h
+%%PCRE%%include/php/ext/pcre/pcrelib/pcre.h
+%%PCRE%%include/php/ext/pcre/pcrelib/pcre_internal.h
+%%PCRE%%include/php/ext/pcre/pcrelib/pcreposix.h
+%%PCRE%%include/php/ext/pcre/pcrelib/ucp.h
+include/php/ext/pcre/php_pcre.h
+include/php/ext/spl/php_spl.h
+include/php/ext/spl/spl_array.h
+include/php/ext/spl/spl_directory.h
+include/php/ext/spl/spl_dllist.h
+include/php/ext/spl/spl_engine.h
+include/php/ext/spl/spl_exceptions.h
+include/php/ext/spl/spl_fixedarray.h
+include/php/ext/spl/spl_functions.h
+include/php/ext/spl/spl_heap.h
+include/php/ext/spl/spl_iterators.h
+include/php/ext/spl/spl_observer.h
include/php/ext/standard/base64.h
include/php/ext/standard/basic_functions.h
include/php/ext/standard/crc32.h
include/php/ext/standard/credits.h
include/php/ext/standard/credits_ext.h
include/php/ext/standard/credits_sapi.h
+include/php/ext/standard/crypt_freesec.h
include/php/ext/standard/css.h
include/php/ext/standard/cyr_convert.h
include/php/ext/standard/datetime.h
@@ -97,6 +127,7 @@ include/php/ext/standard/php_array.h
include/php/ext/standard/php_assert.h
include/php/ext/standard/php_browscap.h
include/php/ext/standard/php_crypt.h
+include/php/ext/standard/php_crypt_r.h
include/php/ext/standard/php_dir.h
include/php/ext/standard/php_dns.h
include/php/ext/standard/php_ext_syslog.h
@@ -123,18 +154,17 @@ include/php/ext/standard/php_var.h
include/php/ext/standard/php_versioning.h
include/php/ext/standard/proc_open.h
include/php/ext/standard/quot_print.h
-include/php/ext/standard/reg.h
include/php/ext/standard/scanf.h
include/php/ext/standard/sha1.h
include/php/ext/standard/streamsfuncs.h
include/php/ext/standard/uniqid.h
include/php/ext/standard/url.h
include/php/ext/standard/url_scanner_ex.h
+include/php/ext/standard/winver.h
@exec touch %D/include/php/ext/php_config.h
@unexec [ -s %D/include/php/ext/php_config.h ] || rm %D/include/php/ext/php_config.h
include/php/main/SAPI.h
include/php/main/build-defs.h
-include/php/main/config.w32.h
include/php/main/fopen_wrappers.h
include/php/main/logos.h
include/php/main/php.h
@@ -142,6 +172,7 @@ include/php/main/php3_compat.h
include/php/main/php_compat.h
include/php/main/php_config.h
include/php/main/php_content_types.h
+include/php/main/php_getopt.h
include/php/main/php_globals.h
include/php/main/php_ini.h
include/php/main/php_logos.h
@@ -151,7 +182,6 @@ include/php/main/php_network.h
include/php/main/php_open_temporary_file.h
include/php/main/php_output.h
include/php/main/php_reentrancy.h
-include/php/main/php_regex.h
include/php/main/php_scandir.h
include/php/main/php_streams.h
include/php/main/php_syslog.h
@@ -164,6 +194,7 @@ include/php/main/snprintf.h
include/php/main/spprintf.h
include/php/main/streams/php_stream_context.h
include/php/main/streams/php_stream_filter_api.h
+include/php/main/streams/php_stream_glob_wrapper.h
include/php/main/streams/php_stream_mmap.h
include/php/main/streams/php_streams_int.h
include/php/main/streams/php_stream_transport.h
@@ -172,13 +203,8 @@ include/php/main/streams/php_stream_plain_wrapper.h
%%SUHOSIN%%include/php/main/suhosin_globals.h
%%SUHOSIN%%include/php/main/suhosin_logo.h
%%SUHOSIN%%include/php/main/suhosin_patch.h
+include/php/main/win32_internal_function_disabled.h
include/php/main/win95nt.h
-include/php/regex/cclass.h
-include/php/regex/cname.h
-include/php/regex/regex.h
-include/php/regex/regex2.h
-include/php/regex/regex_extra.h
-include/php/regex/utils.h
lib/php/build/Makefile.global
lib/php/build/acinclude.m4
lib/php/build/config.guess
@@ -197,12 +223,16 @@ lib/php/build/shtool
@dirrm include/php/Zend
@dirrm include/php/ext/date/lib
@dirrm include/php/ext/date
+@dirrm include/php/ext/ereg/regex
+@dirrm include/php/ext/ereg
@dirrm include/php/ext/libxml
+%%PCRE%%@dirrm include/php/ext/pcre/pcrelib
+@dirrm include/php/ext/pcre
+@dirrm include/php/ext/spl
@dirrm include/php/ext/standard
@dirrmtry include/php/ext
@dirrm include/php/main/streams
@dirrm include/php/main
-@dirrm include/php/regex
@dirrmtry include/php
@dirrm lib/php/build
@dirrmtry lib/php