aboutsummaryrefslogtreecommitdiff
path: root/lang/php5
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2013-10-18 12:37:45 +0000
committerAlex Dupre <ale@FreeBSD.org>2013-10-18 12:37:45 +0000
commit8e7fdd9d3722b47cd3464e9e665dd26baad980e9 (patch)
tree9d9502b03cc760872a9797fcfb18bf12bbe516d7 /lang/php5
parent0031c1839bb7863171a4f4a1e1b7036e52acb5a2 (diff)
downloadports-8e7fdd9d3722b47cd3464e9e665dd26baad980e9.tar.gz
ports-8e7fdd9d3722b47cd3464e9e665dd26baad980e9.zip
Notes
Diffstat (limited to 'lang/php5')
-rw-r--r--lang/php5/Makefile1
-rw-r--r--lang/php5/files/patch-sapi_apache2filter_config.m411
-rw-r--r--lang/php5/files/patch-sapi_apache2handler_config.m411
-rw-r--r--lang/php5/pkg-plist2
4 files changed, 24 insertions, 1 deletions
diff --git a/lang/php5/Makefile b/lang/php5/Makefile
index f192b35f5afc..aee65e0a1e8b 100644
--- a/lang/php5/Makefile
+++ b/lang/php5/Makefile
@@ -101,7 +101,6 @@ IGNORE= cannot be built with multiple SAPI (apache and embedded)
.endif
.if ${PORT_OPTIONS:MAPACHE}
-BROKEN= doesn't install in STAGEDIR: working on a fix
PHP_SAPI+= mod
USE_APACHE= 22+
.include "${PORTSDIR}/Mk/bsd.apache.mk"
diff --git a/lang/php5/files/patch-sapi_apache2filter_config.m4 b/lang/php5/files/patch-sapi_apache2filter_config.m4
new file mode 100644
index 000000000000..ce71383f9fa4
--- /dev/null
+++ b/lang/php5/files/patch-sapi_apache2filter_config.m4
@@ -0,0 +1,11 @@
+--- sapi/apache2filter/config.m4.orig 2013-10-18 12:17:14.622544934 +0000
++++ sapi/apache2filter/config.m4 2013-10-18 12:22:13.032234760 +0000
+@@ -68,7 +68,7 @@
+ fi
+
+ APXS_LIBEXECDIR='$(INSTALL_ROOT)'`$APXS -q LIBEXECDIR`
+- if test -z `$APXS -q SYSCONFDIR`; then
++ if true; then
+ INSTALL_IT="\$(mkinstalldirs) '$APXS_LIBEXECDIR' && \
+ $APXS -S LIBEXECDIR='$APXS_LIBEXECDIR' \
+ -i -n php5"
diff --git a/lang/php5/files/patch-sapi_apache2handler_config.m4 b/lang/php5/files/patch-sapi_apache2handler_config.m4
new file mode 100644
index 000000000000..149c4ef0fc80
--- /dev/null
+++ b/lang/php5/files/patch-sapi_apache2handler_config.m4
@@ -0,0 +1,11 @@
+--- sapi/apache2handler/config.m4.orig 2013-10-18 12:22:26.576545216 +0000
++++ sapi/apache2handler/config.m4 2013-10-18 12:23:00.903131412 +0000
+@@ -67,7 +67,7 @@
+ fi
+
+ APXS_LIBEXECDIR='$(INSTALL_ROOT)'`$APXS -q LIBEXECDIR`
+- if test -z `$APXS -q SYSCONFDIR`; then
++ if true; then
+ INSTALL_IT="\$(mkinstalldirs) '$APXS_LIBEXECDIR' && \
+ $APXS -S LIBEXECDIR='$APXS_LIBEXECDIR' \
+ -i -n php5"
diff --git a/lang/php5/pkg-plist b/lang/php5/pkg-plist
index b7a68bbede7c..3ac31938c8b0 100644
--- a/lang/php5/pkg-plist
+++ b/lang/php5/pkg-plist
@@ -239,7 +239,9 @@ lib/php/build/shtool
%%APACHE%%@exec %D/sbin/apxs -e -a -n %%AP_NAME%% %f
%%APACHE%%@unexec %D/sbin/apxs -e -A -n %%AP_NAME%% %f
%%CGI%%man/man1/php-cgi.1.gz
+man/man1/php-config.1.gz
%%CLI%%man/man1/php.1.gz
+man/man1/phpize.1.gz
%%FPM%%man/man8/php-fpm.8.gz
%%FPM%%share/php/fpm/status.html
@dirrm include/php/TSRM