aboutsummaryrefslogtreecommitdiff
path: root/lang/php5
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2005-01-10 17:00:34 +0000
committerAlex Dupre <ale@FreeBSD.org>2005-01-10 17:00:34 +0000
commitaa4d81d3be6bcd9281b5a8e0987a3bbfbf9e0794 (patch)
tree0ceb731bd69e281e6da2a6d68144727867ef6aba /lang/php5
parent3fdf71fa1aa55a91ff217ee6c6f35a4b03af4735 (diff)
downloadports-aa4d81d3be6bcd9281b5a8e0987a3bbfbf9e0794.tar.gz
ports-aa4d81d3be6bcd9281b5a8e0987a3bbfbf9e0794.zip
Notes
Diffstat (limited to 'lang/php5')
-rw-r--r--lang/php5/Makefile.ext6
-rw-r--r--lang/php5/files/patch-Zend::zend.h12
2 files changed, 15 insertions, 3 deletions
diff --git a/lang/php5/Makefile.ext b/lang/php5/Makefile.ext
index 248df410681e..27b1ee61528a 100644
--- a/lang/php5/Makefile.ext
+++ b/lang/php5/Makefile.ext
@@ -169,7 +169,7 @@ LIB_DEPENDS+= mcve.3:${PORTSDIR}/devel/libmcve
CONFIGURE_ARGS+=--with-mcve=${LOCALBASE} \
--with-openssl-dir=${OPENSSLBASE}
-LDFLAGS+= -lcrypto -lssl
+LDFLAGS+= -L${OPENSSLLIB} -lcrypto -lssl
USE_OPENSSL= yes
.endif
@@ -226,7 +226,7 @@ CONFIGURE_ARGS+=--with-unixODBC=${LOCALBASE}
CONFIGURE_ARGS+=--with-openssl=${OPENSSLBASE} \
--with-openssl-dir=${OPENSSLBASE}
-LDFLAGS+= -lcrypto -lssl
+LDFLAGS+= -L${OPENSSLLIB} -lcrypto -lssl
USE_OPENSSL= yes
.endif
@@ -294,7 +294,7 @@ CONFIGURE_ARGS+=--with-snmp=${LOCALBASE} \
--with-openssl-dir=${OPENSSLBASE} \
--enable-ucd-snmp-hack
-LDFLAGS+= -lcrypto -lssl
+LDFLAGS+= -L${OPENSSLLIB} -lcrypto -lssl
USE_OPENSSL= yes
OPTIONS= SNMP4 "Use old UCD SNMP instead of the new NET SNMP" off
diff --git a/lang/php5/files/patch-Zend::zend.h b/lang/php5/files/patch-Zend::zend.h
new file mode 100644
index 000000000000..50625c403417
--- /dev/null
+++ b/lang/php5/files/patch-Zend::zend.h
@@ -0,0 +1,12 @@
+--- Zend/zend.h.orig Mon Dec 6 15:42:56 2004
++++ Zend/zend.h Mon Dec 6 15:46:40 2004
+@@ -176,7 +176,7 @@
+ #endif
+
+
+-#if (HAVE_ALLOCA || (defined (__GNUC__) && __GNUC__ >= 2)) && !(defined(ZTS) && defined(ZEND_WIN32)) && !(defined(ZTS) && defined(NETWARE)) && !(defined(ZTS) && defined(HPUX)) && !defined(__darwin__) && !defined(__APPLE__)
++#if (HAVE_ALLOCA || (defined (__GNUC__) && __GNUC__ >= 2)) && !(defined(ZTS) && defined(ZEND_WIN32)) && !(defined(ZTS) && defined(NETWARE)) && !(defined(ZTS) && defined(HPUX)) && !defined(__darwin__) && !defined(__APPLE__) && !(defined(ZTS) && defined(__FreeBSD__))
+ # define do_alloca(p) alloca(p)
+ # define free_alloca(p)
+ #else
+