aboutsummaryrefslogtreecommitdiff
path: root/lang/php5
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2006-01-17 13:57:29 +0000
committerAlex Dupre <ale@FreeBSD.org>2006-01-17 13:57:29 +0000
commit2265e438583f3942fdf308bc32400289b6e66f2a (patch)
tree058b4ce9206990b007e276beb366057831185259 /lang/php5
parent86687513905ac7c8421ca2e38963523f8e1df5b7 (diff)
downloadports-2265e438583f3942fdf308bc32400289b6e66f2a.tar.gz
ports-2265e438583f3942fdf308bc32400289b6e66f2a.zip
Notes
Diffstat (limited to 'lang/php5')
-rw-r--r--lang/php5/Makefile.ext6
1 files changed, 5 insertions, 1 deletions
diff --git a/lang/php5/Makefile.ext b/lang/php5/Makefile.ext
index b5d56d805179..c30ee22a6b3e 100644
--- a/lang/php5/Makefile.ext
+++ b/lang/php5/Makefile.ext
@@ -6,10 +6,13 @@ PHP_MODNAME= ${PKGNAMESUFFIX:S/-//}
DEFAULT_PHP_VER=5
BROKEN_WITH_PHP=4
-WRKSRC= ${WRKDIR}/php-${PORTVERSION:S/.r/RC/}/ext/${PHP_MODNAME}
+PHP_EXTDIR= ${DISTNAME}/ext/${PHP_MODNAME}
+WRKSRC= ${WRKDIR}/${PHP_EXTDIR}
PATCHDIR= ${.CURDIR}/files
PLIST= ${NONEXISTENT}
+EXTRACT_AFTER_ARGS?= | ${TAR} -xf - ${PHP_EXTDIR}
+
.if ${PHP_MODNAME} == "bcmath"
CONFIGURE_ARGS+=--enable-bcmath
@@ -380,6 +383,7 @@ CONFIGURE_ARGS+=--with-xsl=${LOCALBASE}
USE_GNOME= libxslt
USE_PHP= dom xml
+USE_PHP_BUILD= yes
.endif
.if ${PHP_MODNAME} == "zlib"