aboutsummaryrefslogtreecommitdiff
path: root/lang/php73
diff options
context:
space:
mode:
authorTorsten Zuehlsdorff <tz@FreeBSD.org>2018-10-09 10:02:36 +0000
committerTorsten Zuehlsdorff <tz@FreeBSD.org>2018-10-09 10:02:36 +0000
commit676a54f7ce0cd3089d8bc3bb4efc1ec4f5992838 (patch)
treefc9a381040bd0cff143ec6e6e0af36e68c923416 /lang/php73
parentc40ca9acf104802e7d3bbc17a3bf5687bd8852da (diff)
downloadports-676a54f7ce0cd3089d8bc3bb4efc1ec4f5992838.tar.gz
ports-676a54f7ce0cd3089d8bc3bb4efc1ec4f5992838.zip
Notes
Diffstat (limited to 'lang/php73')
-rw-r--r--lang/php73/Makefile4
-rw-r--r--lang/php73/Makefile.ext8
2 files changed, 2 insertions, 10 deletions
diff --git a/lang/php73/Makefile b/lang/php73/Makefile
index 0f5ce7b03aca..e99bf7e1976a 100644
--- a/lang/php73/Makefile
+++ b/lang/php73/Makefile
@@ -17,8 +17,8 @@ CPE_PRODUCT= php
NO_OPTIONS_SORT=yes
.if !defined(PKGNAMESUFFIX)
-BUILD_DEPENDS= pcre2>=2.31:devel/pcre2
-LIB_DEPENDS= libargon2.so:security/libargon2
+LIB_DEPENDS= libpcre2-8.so:devel/pcre2 \
+ libargon2.so:security/libargon2
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-layout=GNU \
diff --git a/lang/php73/Makefile.ext b/lang/php73/Makefile.ext
index 1339e70453c7..a6a1d0e7b1ec 100644
--- a/lang/php73/Makefile.ext
+++ b/lang/php73/Makefile.ext
@@ -73,7 +73,6 @@ CONFIGURE_ARGS+=--enable-exif
.endif
.if ${PHP_MODNAME} == "fileinfo"
-BUILD_DEPENDS= pcre2>=2.31:devel/pcre2
CONFIGURE_ARGS+=--enable-fileinfo \
--with-pcre-dir=${LOCALBASE}
@@ -81,7 +80,6 @@ PHP_HEADER_DIRS= libmagic
.endif
.if ${PHP_MODNAME} == "filter"
-BUILD_DEPENDS= pcre2>=2.31:devel/pcre2
CONFIGURE_ARGS+=--enable-filter \
--with-pcre-dir=${LOCALBASE}
.endif
@@ -142,7 +140,6 @@ USES+= iconv:translit
.endif
.if ${PHP_MODNAME} == "imap"
-BUILD_DEPENDS= pcre2>=2.31:devel/pcre2
OPTIONS_DEFINE= PANDA
PANDA_DESC= Uses the forked panda-cclient instead of the original cclient
@@ -216,7 +213,6 @@ USES+= ssl
.if ${PHP_MODNAME} == "opcache"
# This is needed by Zend extensions, keep before everything.
PHP_MOD_PRIO= 10
-BUILD_DEPENDS= pcre2>=2.31:devel/pcre2
CONFIGURE_ARGS+=--enable-opcache
USES+= localbase
.endif
@@ -278,14 +274,12 @@ USE_PHP= pdo:build
.endif
.if ${PHP_MODNAME} == "pgsql"
-BUILD_DEPENDS= pcre2>=2.31:devel/pcre2
USES+= pgsql
CONFIGURE_ARGS+=--with-pgsql=${LOCALBASE}
.endif
.if ${PHP_MODNAME} == "phar"
-BUILD_DEPENDS= pcre2>=2.31:devel/pcre2
CONFIGURE_ARGS+=--enable-phar \
--with-pcre-dir=${LOCALBASE}
@@ -323,7 +317,6 @@ CONFIGURE_ARGS+=--enable-shmop
.endif
.if ${PHP_MODNAME} == "simplexml"
-BUILD_DEPENDS= pcre2>=2.31:devel/pcre2
CONFIGURE_ARGS+=--enable-simplexml \
--with-pcre-dir=${LOCALBASE} \
--with-libxml-dir=${LOCALBASE}
@@ -439,7 +432,6 @@ USE_PHP= dom:build xml:build
.endif
.if ${PHP_MODNAME} == "zip"
-BUILD_DEPENDS= pcre2>=2.31:devel/pcre2
LIB_DEPENDS+= libzip.so:archivers/libzip
CONFIGURE_ARGS+=--enable-zip \