aboutsummaryrefslogtreecommitdiff
path: root/lang/picoc
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-08-15 19:44:13 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-08-15 19:44:13 +0000
commitc987682a7773dd8f7fad72a7e96f45493f22e887 (patch)
treec15f61e341473a50a565310598c9b9ad000ab451 /lang/picoc
parent05b00bce0caa5f79f88339730f33d09e276f54eb (diff)
downloadports-c987682a7773dd8f7fad72a7e96f45493f22e887.tar.gz
ports-c987682a7773dd8f7fad72a7e96f45493f22e887.zip
Notes
Diffstat (limited to 'lang/picoc')
-rw-r--r--lang/picoc/Makefile5
-rw-r--r--lang/picoc/files/patch-Makefile19
-rw-r--r--lang/picoc/pkg-descr2
3 files changed, 21 insertions, 5 deletions
diff --git a/lang/picoc/Makefile b/lang/picoc/Makefile
index 930542eb197c..d8ffd0ab9a7e 100644
--- a/lang/picoc/Makefile
+++ b/lang/picoc/Makefile
@@ -8,7 +8,7 @@ MASTER_SITES= GOOGLE_CODE
MAINTAINER= ports@FreeBSD.org
COMMENT= Very small C interpreter for scripting
-LICENSE= BSD
+LICENSE= BSD3CLAUSE
USES= gmake readline tar:bzip2
@@ -16,9 +16,6 @@ PLIST_FILES= bin/picoc
WRKSRC= ${WRKDIR}/${PORTNAME}
-MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}"
-CFLAGS+= -DUNIX_HOST
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/picoc ${STAGEDIR}${PREFIX}/bin/picoc
diff --git a/lang/picoc/files/patch-Makefile b/lang/picoc/files/patch-Makefile
new file mode 100644
index 000000000000..c03e4ebfa85d
--- /dev/null
+++ b/lang/picoc/files/patch-Makefile
@@ -0,0 +1,19 @@
+--- Makefile.orig 2014-08-15 15:40:43.000000000 -0400
++++ Makefile 2014-08-15 15:41:37.000000000 -0400
+@@ -1,5 +1,5 @@
+-CC=gcc
+-CFLAGS=-Wall -pedantic -g -DUNIX_HOST
++CC?=gcc
++CFLAGS+=-Wall -pedantic -g -DUNIX_HOST
+ LIBS=-lm -lreadline
+
+ TARGET = picoc
+@@ -14,7 +14,7 @@
+ all: $(TARGET)
+
+ $(TARGET): $(OBJS)
+- $(CC) $(CFLAGS) -o $(TARGET) $(OBJS) $(LIBS)
++ $(CC) $(CFLAGS) ${CPPFLAGS} -o $(TARGET) $(OBJS) ${LDFLAGS} $(LIBS)
+
+ test: all
+ (cd tests; make test)
diff --git a/lang/picoc/pkg-descr b/lang/picoc/pkg-descr
index 82e32488d9ee..c5b16e227e79 100644
--- a/lang/picoc/pkg-descr
+++ b/lang/picoc/pkg-descr
@@ -2,4 +2,4 @@ PicoC is a very small C interpreter for scripting. It was originally written for
scripting a UAV's on-board flight system and it's also very suitable for other
robotic, embedded and non-embedded applications too.
-WWW: http://code.google.com/p/picoc/
+WWW: http://code.google.com/p/picoc/