aboutsummaryrefslogtreecommitdiff
path: root/lang/pike72/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-03-15 02:15:08 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-03-15 02:15:08 +0000
commit4cfc3fa1affe34d95fa2f9028d12129061255492 (patch)
tree912959836286de266f2aa02743acd6bc015dec00 /lang/pike72/Makefile
parent5f0c3169c7223568a2bdf58549da98bd29b2eb82 (diff)
downloadports-4cfc3fa1affe34d95fa2f9028d12129061255492.tar.gz
ports-4cfc3fa1affe34d95fa2f9028d12129061255492.zip
Notes
Diffstat (limited to 'lang/pike72/Makefile')
-rw-r--r--lang/pike72/Makefile25
1 files changed, 1 insertions, 24 deletions
diff --git a/lang/pike72/Makefile b/lang/pike72/Makefile
index 75f28802a0c4..6f337d462272 100644
--- a/lang/pike72/Makefile
+++ b/lang/pike72/Makefile
@@ -30,10 +30,9 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/src/
WANT_MESA= yes
WANT_GTK= yes
-#WANT_GNOME= yes
USE_BISON= yes
-GNU_CONFIGURE= yes
+GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --without-debug \
--with-double-precision \
@@ -58,15 +57,9 @@ CONFIGURE_ARGS+= --without-debug \
--with-tiff \
--with-gdbm \
--without-ssleay
-# --with-gdbm=${PREFIX} \
-# --without-relocatable-dumped-modules \
.include <bsd.port.pre.mk>
-.if ${ARCH} != "i386"
-BROKEN= "Does not compile on !i386"
-.endif
-
PLIST_SUB+= PORTVERSION=${PORTVERSION}
# FreeBSD 5.0 Needs to have libgmp port to support gmp.
@@ -194,22 +187,6 @@ CONFIGURE_ARGS+= --with-GL --with-GLUT
CONFIGURE_ARGS+= --without-GL --without-GLUT
.endif
-#.if defined(HAVE_GNOME)
-#USE_GNOME= yes
-#USE_GTK= yes
-#USE_GLI= yes
-#CONFIGURE_ARGS+= --with-GTK --with-gnome --with-glade
-#.else
-CONFIGURE_ARGS+= --without-GTK --without-gnome --without-glade
-#.endif
-
-.if (${MACHINE} == "i386")
-CONFIGURE_ARGS+= --with-poll
-.else
-# Alpha seems to have problems with poll() with pike... :/
-CONFIGURE_ARGS+= --without-poll
-.endif
-
USE_GMAKE= yes
MAN1= hilfe.1 pike.1
MAN1PREFIX= ${PREFIX}/pike/${PORTVERSION}