aboutsummaryrefslogtreecommitdiff
path: root/lang/pike74/scripts/configure.pike
diff options
context:
space:
mode:
authorJames E. Housley <jeh@FreeBSD.org>2000-10-02 21:53:13 +0000
committerJames E. Housley <jeh@FreeBSD.org>2000-10-02 21:53:13 +0000
commite7a1a279e0d0537828e9709bcf017344c629d0a3 (patch)
tree14ac460f0a1054a34bde73339b65e5ecf6dbdd7b /lang/pike74/scripts/configure.pike
parentefb3b72a65b71e18dd9043e7296390a6817ebe31 (diff)
MAINTAINER submitted update.
PR: 21382
Notes
Notes: svn path=/head/; revision=33337
Diffstat (limited to 'lang/pike74/scripts/configure.pike')
-rw-r--r--lang/pike74/scripts/configure.pike8
1 files changed, 6 insertions, 2 deletions
diff --git a/lang/pike74/scripts/configure.pike b/lang/pike74/scripts/configure.pike
index cca627c9cc9c..1145e3be67d8 100644
--- a/lang/pike74/scripts/configure.pike
+++ b/lang/pike74/scripts/configure.pike
@@ -17,8 +17,8 @@ readline "support for command line editing" ON \
MySQL "MySQL database support" OFF \
PostgreSQL "PostgreSQL database support" OFF \
mSQL "mSQL database support" OFF \
+ssl "SSL support" OFF \
2> /tmp/checklist.tmp.$$
-#ssl "SSL support" OFF \
retval=$?
if [ -s /tmp/checklist.tmp.$$ ]; then
@@ -86,6 +86,10 @@ while [ "$1" ]; do
echo "CONFIGURE_ARGS+= --with-msql=\${PREFIX}" >> ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
mSQL=1
;;
+ \"ssl\")
+ echo "CONFIGURE_ARGE+= --with-ssleay" >> ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
+ ssl=1
+ ;;
esac
shift
done
@@ -111,7 +115,7 @@ if [ -z "$mSQL" ]; then
echo "CONFIGURE_ARGS+= --without-msql" >> ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
fi
if [ -z "$gmp" ]; then
- echo "CONFIGURE_ARGS+= --without-gmp" >> ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
+ echo "CONFIGURE_ARGS+= --without-gmp --without-bignums" >> ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
fi
if [ -z "$JPEG" ]; then
echo "CONFIGURE_ARGS+= --without-jpeg" >> ${WRKDIRPREFIX}${CURDIR}/Makefile.inc